Bank Websites Have Security Error

Please put your bug reports here, and only here.

Moderators: Support Staff², Support Staff, AvantGuard, Developer

Post Reply
newtekie1
Semi-Fan
Semi-Fan
Posts: 93
Joined: Fri Jul 29, 2005 2:40 pm
Windows Version: Windows 7 Pro x64
Avant Version: Latest
Default engine: Chrome
IE Version: 11
Skin: Opal Glass

Bank Websites Have Security Error

Post by newtekie1 » Fri Jan 27, 2017 2:54 pm

This morning no banks websites, or other financial websites will open with Avant using the Chrome engine.

http://www.chase.com/

It does it with chase as well as several others. It seems like this is caused by an outdated version of Chromium.

Can we get an update to Avant to get the latest version of Chromium?

newtekie1
Semi-Fan
Semi-Fan
Posts: 93
Joined: Fri Jul 29, 2005 2:40 pm
Windows Version: Windows 7 Pro x64
Avant Version: Latest
Default engine: Chrome
IE Version: 11
Skin: Opal Glass

Re: Bank Websites Have Security Error

Post by newtekie1 » Fri Jan 27, 2017 11:28 pm

So is it safe to assume that since there is no response, and no response to other bug threads on the forums, that Avant is dead?

User avatar
Nederpietos
Semi-Avantic
Semi-Avantic
Posts: 454
Joined: Sun Jan 25, 2004 5:25 pm
Windows Version: 10 pro
Avant Version: 2017 build 2 ult
Default engine: Firefox
IE Version: IE11
Skin: stickers on blue

Re: Bank Websites Have Security Error

Post by Nederpietos » Fri Jan 27, 2017 11:36 pm

Your url should change to https:

does it work if you use https://www.chase.com/ directly? they both work here btw

oops, sorry i tested it in firefox.... cant test it in chrome since i deleted that engine.

newtekie1
Semi-Fan
Semi-Fan
Posts: 93
Joined: Fri Jul 29, 2005 2:40 pm
Windows Version: Windows 7 Pro x64
Avant Version: Latest
Default engine: Chrome
IE Version: 11
Skin: Opal Glass

Re: Bank Websites Have Security Error

Post by newtekie1 » Fri Jan 27, 2017 11:54 pm

Yes, it auto changes to https. It works fine in IE and Firefox engines, but not in Chrome, I get a security error, pictured below. This breaks a lot of websites. Even going to newegg.com doesn't work probably. The page loads, but half the images don't because they use a secure connection.

I would think keeping up on something as basic as SSL/TLS security would be a priority. But it seems Avant has been abandoned. :cry:
avantsecurityerror.png
Also, here is a thread on Google's Help Forum that basically says updating Chromium fixes the problem: https://productforums.google.com/forum/ ... LX1__NgPj0

Also, beginning with Chromium version 53, it seems that the security certificate has a built in 10 week time bomb. This is explained in this bug report: https://bugs.chromium.org/p/chromium/is ... ?id=664177

So any website that uses a symantec security certificate will stop working on Chromium versions older than 10 weeks.

So Avant now has to stick to a maximum of 10 weeks between releases if it wants to remain usable, or release a way to update Chromium independently of Avant.

Pennywise
Newbie
Newbie
Posts: 1
Joined: Wed Feb 01, 2017 6:22 am
Windows Version: Windows 7 32 Bit
Avant Version: 2006 build 17
Default engine: Chrome
IE Version: 11
Skin: Office XP

Re: Bank Websites Have Security Error

Post by Pennywise » Wed Feb 01, 2017 6:33 am

You can work around this problem by setting another temporary rendering engine for the page you have problem with.

Go to settings and assign another rendering engine that works with your bank.

Do it like this *.mybank.com and select engine.

Avant will then change rendering engine when you go to that page and change back to your dafault engine when you leave.
Attachments
Rendering.jpg

newtekie1
Semi-Fan
Semi-Fan
Posts: 93
Joined: Fri Jul 29, 2005 2:40 pm
Windows Version: Windows 7 Pro x64
Avant Version: Latest
Default engine: Chrome
IE Version: 11
Skin: Opal Glass

Re: Bank Websites Have Security Error

Post by newtekie1 » Wed Feb 01, 2017 2:45 pm

Not exactly a good work around. I have to go through all the 2 factor authentication again, since all the websites would see it as a new browser. Plus, there are all the websites that just randomly don't work anymore, and I'd have to manually enter them in every time I come across them. Like the image server for newegg.

Unfortunately, since we haven't seen any response to any of the recent bug reports from the developers or staff, I've just assumed Avant is now dead and switched to Chrome. I miss a few of the features of Avant, but I'm learning to live without them. I'm willing to give the few features up in exchange for a properly updated and support and most importantly secure browser.

User avatar
DutchGemini
Avant Fanatic
Avant Fanatic
Posts: 338
Joined: Wed Jan 28, 2004 8:10 am
Windows Version: 2000, XP, Vista, 7 (32/64bit)
Avant Version: Always the Latest
Default engine: Chromium
IE Version: 11.0.9600.18282
Skin: Aluminum
Location: Lake Maggiore - Italy, just below the Swiss border

Re: Bank Websites Have Security Error

Post by DutchGemini » Thu Feb 02, 2017 2:56 pm

Security errors on Chromium are becoming a norm lately, I have to switch many of them to FF. In addition, and more or less at the same time, with Chromium there are many sites that have issues with CSS.

newtekie1
Semi-Fan
Semi-Fan
Posts: 93
Joined: Fri Jul 29, 2005 2:40 pm
Windows Version: Windows 7 Pro x64
Avant Version: Latest
Default engine: Chrome
IE Version: 11
Skin: Opal Glass

Re: Bank Websites Have Security Error

Post by newtekie1 » Fri Feb 03, 2017 7:05 am

I wouldn't be a surprised if that comes down to the fact that Avant uses such an outdated version of Chromium.

User avatar
Nederpietos
Semi-Avantic
Semi-Avantic
Posts: 454
Joined: Sun Jan 25, 2004 5:25 pm
Windows Version: 10 pro
Avant Version: 2017 build 2 ult
Default engine: Firefox
IE Version: IE11
Skin: stickers on blue

Re: Bank Websites Have Security Error

Post by Nederpietos » Fri Feb 03, 2017 4:40 pm

2017 build 2 is out, maybe it's any better.

Avant Browser 2017 build 2, Released 2.2.2017

[Update]Chrome: 56.0.2924.87
[Update]Firefox: 51.0.1.6240
[Fix]Incorrect size of popup tabs
[Fix]A bug result in memory crash


There's no official announcing of new builds anymore on this forum since Xiaobing left (i think) the Avant support.

Post Reply

Who is online

Users browsing this forum: No registered users