Page 1 of 1

AB Extension Pack issue - 'Open URL' feature misbehaving

Posted: Mon May 24, 2010 2:13 pm
by notestracker
This is about AB Extension Pack (ABEP) and not AB itself, so I hope it's okay to post in this thread.

Most of the time the Open URL context menu action works properly: highlight some plain text on a page (which is not a live hyperlink but DOES represent a valid URL), right click and select "Open URL", then the web page corresponding to that URL is opened.

But sometimes the Open URL action misbehaves, which is rather annoying. The symptom is a dialog box:
An error has occurred in the script on this page.
Line: 3
Char: 2
Error: Object doesn't support this property or method.
'external.menuArguments.document.selection'
Code: 0
URL: [points to the location of the ABEP file: OpenURL.htm]
The first three lines of this ABEP file (Open URL.htm) contain:
<script Language=VBScript>
Set objShell = CreateObject("WScript.Shell")
lcSelection = external.menuArguments.document.selection.createRange().text
So for some reason it seems to be saying that a script method/property that usually works -- which I presume is either createRange() or createRange().text -- is not supported, and this seems strange to me when it does work most of the time.

Folks, any ideas why this happens, fairly regularly, every now and then?

Re: AB Extension Pack issue - 'Open URL' feature misbehaving

Posted: Mon May 24, 2010 5:28 pm
by kudos
Methinks that this is a 64bit issue because I have never had this issue on my 32bit system.
Avant calls the script as a 32bit process, ie: cscript or wscript followed by the filename.
Maybe some of the tips/suggestions in this article may be able to help you.

Re: AB Extension Pack issue - 'Open URL' feature misbehaving

Posted: Mon May 24, 2010 11:26 pm
by notestracker
Thanks for the idea, Monsieur kudos, but I didn't really understand the implications of ANY of te suggested workarounds on that blog post so I'd rather live with it than do something that might have a disastrous effect on something else! (Apart from the fact that it mightn't be a 64-bit issue, anyway. But it also might be.)

Re: AB Extension Pack issue - 'Open URL' feature misbehaving

Posted: Mon May 24, 2010 11:40 pm
by kudos
Well let me know if you can reliably create the issue (specific links?) and I shall try to duplicate and look into it.