GMail not displaying properly with IE8

Moderators: André, AvantGuard

User avatar
kudos
Support Staff²
Support Staff²
Posts: 3384
Joined: Wed Mar 22, 2006 10:35 am
Avant Version:

Re: GMail not displaying properly with IE8

Post by kudos » Tue May 05, 2009 8:50 pm

I had one computer that experienced the reported problem. After a lot of fiddling, I finally fixed it by changing Avant's user agent string (details here) to that of IE8. Can you try too - I'm pretty sure that I narrowed it down to just the UA - but would like confirmation. If so, then it's a problem with GMail.
 
.:Volunteer support staff (regular user):.
Image
I am not a member of the Avant / Orca development team
Please search this forum / the Wiki before posting questions
Forum Rules | Frequently Asked Questions | Active Topics

bigC
AvantGuard
AvantGuard
Posts: 7244
Joined: Thu Jan 30, 2003 10:40 pm
Windows Version: 10
Avant Version: 2016 Build 1
Default engine: Firefox
IE Version: 11
Skin: Crystal
Location: New York

Re: GMail not displaying properly with IE8

Post by bigC » Wed May 06, 2009 8:10 pm

kudos wrote:I had one computer that experienced the reported problem. After a lot of fiddling, I finally fixed it by changing Avant's user agent string (details here) to that of IE8. Can you try too - I'm pretty sure that I narrowed it down to just the UA - but would like confirmation. If so, then it's a problem with GMail.
How exactly do I change the UA? That thread is confusing.

User avatar
kudos
Support Staff²
Support Staff²
Posts: 3384
Joined: Wed Mar 22, 2006 10:35 am
Avant Version:

Re: GMail not displaying properly with IE8

Post by kudos » Thu May 07, 2009 12:09 pm

Sorry for the late reply. Here is the content of the registry file that I used (import it while Avat is running):

Code: Select all

REGEDIT4

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\User Agent\Post Platform]
"Avant Browser"=-
"Avant Browser [avantbrowser.com]"=-

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\User Agent\Post Platform]
"Avant Browser"=-
"Avant Browser [avantbrowser.com]"=-

[HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet Settings\User Agent\Post Platform]
"Avant Browser"=-
"Avant Browser [avantbrowser.com]"=-

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"User Agent"="Mozilla/4.0 (compatible; MSIE 8.0; Win32)"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings]
"User Agent"="Mozilla/4.0 (compatible; MSIE 8.0; Win32)"

[HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"User Agent"="Mozilla/4.0 (compatible; MSIE 8.0; Win32)"
BUT upon further testing, I found a bug with Avant in that it does not always repect the registry and it sometimes adds "Avant Browser" to the string. It happens randomly.

Fortunately I found a simple solution - UAPick "This small little add-on allows you to quickly customize the User-Agent string sent by IE8 without restarting."

It works perfectly with Avant and allows me to change the user agent to anything that I want.

Let me know how you get on.
 
.:Volunteer support staff (regular user):.
Image
I am not a member of the Avant / Orca development team
Please search this forum / the Wiki before posting questions
Forum Rules | Frequently Asked Questions | Active Topics

bigC
AvantGuard
AvantGuard
Posts: 7244
Joined: Thu Jan 30, 2003 10:40 pm
Windows Version: 10
Avant Version: 2016 Build 1
Default engine: Firefox
IE Version: 11
Skin: Crystal
Location: New York

Re: GMail not displaying properly with IE8

Post by bigC » Thu May 07, 2009 7:12 pm

Nope, changing the UA didn't do any good. It still happens...

User avatar
AXEMAN
Avantic Elite
Avantic Elite
Posts: 1606
Joined: Thu Jan 24, 2008 12:55 am
Windows Version: WIN 7 64 BIT
Avant Version: THE LATEST
IE Version: 9

Re: GMail not displaying properly with IE8

Post by AXEMAN » Thu May 07, 2009 8:27 pm

Try IE7 see what happens :)

bigC
AvantGuard
AvantGuard
Posts: 7244
Joined: Thu Jan 30, 2003 10:40 pm
Windows Version: 10
Avant Version: 2016 Build 1
Default engine: Firefox
IE Version: 11
Skin: Crystal
Location: New York

Re: GMail not displaying properly with IE8

Post by bigC » Thu May 07, 2009 9:34 pm

AXEMAN wrote:Try IE7 see what happens :)
Why?... its already been determined that the issue is IE8 related.

User avatar
AXEMAN
Avantic Elite
Avantic Elite
Posts: 1606
Joined: Thu Jan 24, 2008 12:55 am
Windows Version: WIN 7 64 BIT
Avant Version: THE LATEST
IE Version: 9

Re: GMail not displaying properly with IE8

Post by AXEMAN » Fri May 08, 2009 7:04 pm

bigC wrote:
AXEMAN wrote:Try IE7 see what happens :)
Why?... its already been determined that the issue is IE8 related.
I say that for people who would like to be operational now . This would fix that problem so then when you guys get the problem fixed .Then go back to IE 8 . Now i did this then i am sure you know.I had the problem only had IE 8 For 1 day 24 hours and i then removed it. IE 8. Then i re enstalled IE 7. Everything went back to normal. However i am useing XP pro. So that was all i did was replaced IE 8 with IE 7. I guess just a option to fix it til the problem with IE 8 IS FIXED :)

User avatar
statm1
Moderator
Moderator
Posts: 2168
Joined: Thu Mar 10, 2005 10:03 pm
Windows Version: Windows 8/7
Avant Version: 2012 Build 181
IE Version: 10
Location: North Carolina, USA
Contact:

Re: GMail not displaying properly with IE8

Post by statm1 » Fri May 08, 2009 8:22 pm

You can have IE8 installed and have the problem fixed. You just use Compatibility mode. There isn't "in my opinion" a reason to get rid of IE8 whatsoever.
Image
-- Matt --

User avatar
Darkson1
Semi-Fan
Semi-Fan
Posts: 95
Joined: Sat Mar 12, 2005 12:25 pm
Windows Version: XPsp3 and Vista Home
Avant Version: 11.7 b43
IE Version: 8.0.6001.18702
Location: England - God's own country.

Re: GMail not displaying properly with IE8

Post by Darkson1 » Fri May 08, 2009 9:42 pm

statm1 wrote:EDIT: I can reproduce it in IE8 itself using the Developer Tools.(that little mouse cursor looking icon). I have found a way to fix this in Avant and still use standards mode but it uses a method of overriding any switch that a site has put in place to control which mode you use in order to thwart glitches on their pages due to incompatibilities.

Go to this key in the registry: HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION and change avant.exe from either 7000 or 8000 to 8888 as a decimal not a hexadecimal. Gmail will work just like IE8 itself does from then on.
Tried this before, and it didn't seem to make any difference, but tried it again tonight, and it's fixed the issue (at least for now).

Will keep an eye on it, and report back if it goes wrong again.
Ha, ha ha! Very funny!

Run for the hills, it's Darkson!

User avatar
kudos
Support Staff²
Support Staff²
Posts: 3384
Joined: Wed Mar 22, 2006 10:35 am
Avant Version:

Re: GMail not displaying properly with IE8

Post by kudos » Sun May 10, 2009 11:41 am

I now think that it is related to screen resolution - it always works correctly with my desktop set to 1024x768, but anything above, or even not 4:3, is intermittently incorrect.
 
.:Volunteer support staff (regular user):.
Image
I am not a member of the Avant / Orca development team
Please search this forum / the Wiki before posting questions
Forum Rules | Frequently Asked Questions | Active Topics

v0pelor
Newbie
Newbie
Posts: 10
Joined: Sun May 17, 2009 2:28 pm
Windows Version: Vista (x64) SP1
Avant Version: 11.7.23
IE Version: 8.0.6001.18762 (x64)

Re: GMail not displaying properly with IE8

Post by v0pelor » Sun May 17, 2009 2:37 pm

in IE 7 it's ok

Post Reply