GMail not displaying properly with IE8

Moderators: André, AvantGuard

User avatar
hornakapopolis
AvantGuard
AvantGuard
Posts: 11321
Joined: Thu Jul 31, 2003 2:09 pm
Windows Version: Windows 10 Pro 64
Avant Version: 2015
Default engine: Chrome
IE Version: 11
Skin: Stickers
Location: Ohio, USA
Contact:

GMail not displaying properly with IE8

Post by hornakapopolis » Wed Apr 01, 2009 11:56 am

This happened to me with the IE8 Beta and it's happening now with the release. My buttons are formatting incorrectly. It's not happening in plain IE, though.

There have been some times when the page has loaded properly, though, but it's so rare I never think about it until it jumps back to the incorrect formatting.

Is anyone else having this problem?
Attachments
GMailScreenshot.jpg

User avatar
kudos
Support Staff²
Support Staff²
Posts: 3384
Joined: Wed Mar 22, 2006 10:35 am
Avant Version:

Re: GMail not displaying properly with IE8

Post by kudos » Wed Apr 01, 2009 12:25 pm

There are discussions of this on the web, such as this one.

The answer is:
I solved it by changing the theme (to any theme), then change back to the original theme.
If you're the issue is with Google Apps - (managed domain - where themes are not available) change to a different language - and then switch back to English (Settings-> Language).
Apparently, there is also an update though Windows Update that will correct this.
 
.:Volunteer support staff (regular user):.
Image
I am not a member of the Avant / Orca development team
Please search this forum / the Wiki before posting questions
Forum Rules | Frequently Asked Questions | Active Topics

User avatar
hornakapopolis
AvantGuard
AvantGuard
Posts: 11321
Joined: Thu Jul 31, 2003 2:09 pm
Windows Version: Windows 10 Pro 64
Avant Version: 2015
Default engine: Chrome
IE Version: 11
Skin: Stickers
Location: Ohio, USA
Contact:

Re: GMail not displaying properly with IE8

Post by hornakapopolis » Wed Apr 01, 2009 12:34 pm

Well, no look there. Changed it a couple of times, too. I also tried changing it in IE, although, just to note again, I'm not having the problem there at all... just Avant.

Also, I'm up to date with Windows.

edit: Oops, uploaded screenshot of new theme, not original. It is switched back to the original theme, though, with no change.
Attachments
WindowsUpdateScreenshot.jpg
GMailScreenshot02.jpg

User avatar
hornakapopolis
AvantGuard
AvantGuard
Posts: 11321
Joined: Thu Jul 31, 2003 2:09 pm
Windows Version: Windows 10 Pro 64
Avant Version: 2015
Default engine: Chrome
IE Version: 11
Skin: Stickers
Location: Ohio, USA
Contact:

Re: GMail not displaying properly with IE8

Post by hornakapopolis » Wed Apr 01, 2009 12:40 pm

Another possibility is that it's just taking a little while for it to "stick." I'll wait a day or so and see what happens. I see that that update you were referring to was just released today.

User avatar
statm1
Moderator
Moderator
Posts: 2168
Joined: Thu Mar 10, 2005 10:03 pm
Windows Version: Windows 8/7
Avant Version: 2012 Build 181
IE Version: 10
Location: North Carolina, USA
Contact:

Re: GMail not displaying properly with IE8

Post by statm1 » Wed Apr 01, 2009 12:44 pm

I have the same problem.. It doesnt have anything to do with Avant itself.. Its a problem with the control Avant uses to get access to the Trident engine. Some glitch there.

EDIT: I can reproduce it in IE8 itself using the Developer Tools.(that little mouse cursor looking icon). I have found a way to fix this in Avant and still use standards mode but it uses a method of overriding any switch that a site has put in place to control which mode you use in order to thwart glitches on their pages due to incompatibilities.

Go to this key in the registry: HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION and change avant.exe from either 7000 or 8000 to 8888 as a decimal not a hexadecimal. Gmail will work just like IE8 itself does from then on.
Image
-- Matt --

addonsfan
Avantic Elite
Avantic Elite
Posts: 1940
Joined: Sun Aug 05, 2007 11:56 am
Windows Version: Windows 7
Avant Version: N/A
IE Version: N/A
Location: California, USA
Contact:

Re: GMail not displaying properly with IE8

Post by addonsfan » Wed Apr 01, 2009 9:31 pm

I can't seem to reproduce it at all...

User avatar
Darkson1
Semi-Fan
Semi-Fan
Posts: 95
Joined: Sat Mar 12, 2005 12:25 pm
Windows Version: XPsp3 and Vista Home
Avant Version: 11.7 b43
IE Version: 8.0.6001.18702
Location: England - God's own country.

Re: GMail not displaying properly with IE8

Post by Darkson1 » Wed Apr 08, 2009 7:54 pm

This has (literally) just happened to me. I had Gmail open earlier today with no problems, but going back online this evening, opened Gmail and had the issue as posted above.
Ha, ha ha! Very funny!

Run for the hills, it's Darkson!

User avatar
kudos
Support Staff²
Support Staff²
Posts: 3384
Joined: Wed Mar 22, 2006 10:35 am
Avant Version:

Re: GMail not displaying properly with IE8

Post by kudos » Wed Apr 08, 2009 8:01 pm

Same here (UK too). The Google team are obviously fiddling...
 
.:Volunteer support staff (regular user):.
Image
I am not a member of the Avant / Orca development team
Please search this forum / the Wiki before posting questions
Forum Rules | Frequently Asked Questions | Active Topics

User avatar
Darkson1
Semi-Fan
Semi-Fan
Posts: 95
Joined: Sat Mar 12, 2005 12:25 pm
Windows Version: XPsp3 and Vista Home
Avant Version: 11.7 b43
IE Version: 8.0.6001.18702
Location: England - God's own country.

Re: GMail not displaying properly with IE8

Post by Darkson1 » Sun May 03, 2009 8:43 pm

Anyone found a solution (other than the one above) for this? I've started to use Chrome more and more, as Gamil is one of the first pages I open, and it seems daft to have a browser open for one page, and another for all the others.
Ha, ha ha! Very funny!

Run for the hills, it's Darkson!

bigC
AvantGuard
AvantGuard
Posts: 7244
Joined: Thu Jan 30, 2003 10:40 pm
Windows Version: 10
Avant Version: 2016 Build 1
Default engine: Firefox
IE Version: 11
Skin: Crystal
Location: New York

Re: GMail not displaying properly with IE8

Post by bigC » Sun May 03, 2009 10:13 pm

I get this too. Its weird though... if I login with IE first then AB, its fine.

User avatar
statm1
Moderator
Moderator
Posts: 2168
Joined: Thu Mar 10, 2005 10:03 pm
Windows Version: Windows 8/7
Avant Version: 2012 Build 181
IE Version: 10
Location: North Carolina, USA
Contact:

Re: GMail not displaying properly with IE8

Post by statm1 » Mon May 04, 2009 12:28 am

I dont usually login at all. I just click on gmail notifier and it logs me in automatically and I have this problem as well.
Image
-- Matt --

maur0
Newbie
Newbie
Posts: 5
Joined: Tue Apr 28, 2009 3:24 pm
Windows Version: xp sp3
Avant Version: 11.7 build 26
IE Version: 8.0

Re: GMail not displaying properly with IE8

Post by maur0 » Mon May 04, 2009 1:44 am

test close avant browser rename avant.exe to iexplore.exe and run gmail 100% function in avant browser please report results tks

bigC
AvantGuard
AvantGuard
Posts: 7244
Joined: Thu Jan 30, 2003 10:40 pm
Windows Version: 10
Avant Version: 2016 Build 1
Default engine: Firefox
IE Version: 11
Skin: Crystal
Location: New York

Re: GMail not displaying properly with IE8

Post by bigC » Mon May 04, 2009 6:42 pm

I found a solution, I think. Open IE8, go to Tools > Compatibility View settings and add google.com to the list.

User avatar
statm1
Moderator
Moderator
Posts: 2168
Joined: Thu Mar 10, 2005 10:03 pm
Windows Version: Windows 8/7
Avant Version: 2012 Build 181
IE Version: 10
Location: North Carolina, USA
Contact:

Re: GMail not displaying properly with IE8

Post by statm1 » Mon May 04, 2009 9:27 pm

That really doesnt make any sense to me.. There are situations where I can't get the problem to occur and then theres only one that I can. Let me list them off:

Gmail:
1. Vista-IE8-Standards Mode: fine
2. Vista-Avant-IE8 Standards Mode: not fine
3. Vista-Avant-IE8 Compatibility Mode: fine
4. Windows 7(builds:7068 & 7100(RC))-Avant-IE8 Standards mode: fine
5. Windows 7(builds:7068 & 7100(RC))-IE8-Standards Mode: fine

FYI: Fine means that nothing is wrong with gmail.

Now explain what is different to cause it to only happen in Vista with Avant and standards mode, at least in my case.
Image
-- Matt --

bigC
AvantGuard
AvantGuard
Posts: 7244
Joined: Thu Jan 30, 2003 10:40 pm
Windows Version: 10
Avant Version: 2016 Build 1
Default engine: Firefox
IE Version: 11
Skin: Crystal
Location: New York

Re: GMail not displaying properly with IE8

Post by bigC » Mon May 04, 2009 11:01 pm

bigC wrote:I found a solution, I think. Open IE8, go to Tools > Compatibility View settings and add google.com to the list.
Scratch that... its happening again. :crazy:

User avatar
statm1
Moderator
Moderator
Posts: 2168
Joined: Thu Mar 10, 2005 10:03 pm
Windows Version: Windows 8/7
Avant Version: 2012 Build 181
IE Version: 10
Location: North Carolina, USA
Contact:

Re: GMail not displaying properly with IE8

Post by statm1 » Tue May 05, 2009 8:48 am

Yea that solution didnt really sound right.. Are you able to verify any of the scenarios I listed as fine?
Image
-- Matt --

User avatar
kudos
Support Staff²
Support Staff²
Posts: 3384
Joined: Wed Mar 22, 2006 10:35 am
Avant Version:

Re: GMail not displaying properly with IE8

Post by kudos » Tue May 05, 2009 9:07 am

Have you tried the GMail "escape hatch"? (Direct link)
 
.:Volunteer support staff (regular user):.
Image
I am not a member of the Avant / Orca development team
Please search this forum / the Wiki before posting questions
Forum Rules | Frequently Asked Questions | Active Topics

hal35a
Newbie
Newbie
Posts: 18
Joined: Mon Aug 07, 2006 6:27 pm
Avant Version:

Re: GMail not displaying properly with IE8

Post by hal35a » Tue May 05, 2009 5:03 pm

I installed IE8 a while back and it made all my Windowss based servers crash. I got rid of it and went back to IE7 and have had no major problems since.

User avatar
statm1
Moderator
Moderator
Posts: 2168
Joined: Thu Mar 10, 2005 10:03 pm
Windows Version: Windows 8/7
Avant Version: 2012 Build 181
IE Version: 10
Location: North Carolina, USA
Contact:

Re: GMail not displaying properly with IE8

Post by statm1 » Tue May 05, 2009 7:14 pm

Not to be to funny hal.. But, just use it on your personal PC then.. Not on a server..

Anyway, I use to many of the labs features to trade no labs for a glitch free Gmail..
Image
-- Matt --

bigC
AvantGuard
AvantGuard
Posts: 7244
Joined: Thu Jan 30, 2003 10:40 pm
Windows Version: 10
Avant Version: 2016 Build 1
Default engine: Firefox
IE Version: 11
Skin: Crystal
Location: New York

Re: GMail not displaying properly with IE8

Post by bigC » Tue May 05, 2009 7:39 pm

I don't have any lab features enabled.

I only have XP to test it on Matt. Its always fine in IE8... sometimes its fine in AB regardless the mode, other times its not. I don't understand it.

Post Reply