Why has Avant Browser gotten SLOW??

Moderators: André, AvantGuard

Bullroarer
Newbie
Newbie
Posts: 8
Joined: Wed Dec 24, 2008 2:45 pm
Windows Version: XP Pro
Avant Version: 11.7 build 9
IE Version: 7.0 5730.13

Why has Avant Browser gotten SLOW??

Post by Bullroarer » Wed Dec 24, 2008 3:11 pm

I use the latest version on several systems. IE is the latest version. Windows XP on all systems, plenty of RAM and CPU. It seems that Avant has become very slow to load certain web pages/sites on all my systems in the past 6 to 8 months. What happens is Avant will "hang" anywhere from 15 seconds to a minute or two while I assume the page loads. During that time Avant is non-responsive, seemingly locked up. :thumbdown: As an IT manager for several companies I've been a big advocate of Avant for many years until recently. I still use it in conjunction with IE, Orca and Chrome in order to maintain multiple, simultaneous logins into different email accounts. But I no longer recommend it to anyone due to this degrade in performance. The problem started before I upgraded to the latest IE thinking it was related to the backend. I continuously update Avant hoping the issue will be resolved. So far, nothing has improved. Again, this is over 5 different computer systems I use, and coming from several users including myself. I've since moved to using Google's Chrome as my primary browser however I miss the features of Avant like mouse gestures, URL aliases, and the customization options of Avant. I'm still hanging on hoping to see some improvement and possibly a little feedback here. I can't imagine I'm the only one having issues. I tried using Orca for a while but I get very tired of clicking and re-clicking and the browser not responding on the first click of a link or tab.

OCDetails.com
Newbie
Newbie
Posts: 1
Joined: Tue Jan 13, 2009 9:20 pm
Windows Version: Vista Ultimate x64
Avant Version: most recent
IE Version: 7

Re: Why has Avant Browser gotten SLOW??

Post by OCDetails.com » Tue Jan 13, 2009 9:28 pm

I agree totally! I am shocked that not more people are talking about this. Avant has become all but unusable for me. It used to be great, but then there were the problems with it being able to access my Gmail account and once they got that fixed the speeds were absolutely terrible. Fortunately Google released Chrome at about the same time I really got fed up with Avant and I have been able to use that. I keep waiting for Avant to get their act together and fix whatever problem causes this browser to be so useless, but they don't seem to be fixing anything. It just keeps getting worse... The fact that nobody has responded to this thread is a clear indication that nobody is concerned about the speed issues. I'm having issues with it on multiple computers running XP, Vista, and Vista Ultimate. I've stopped using it altogether on my Vista machines and my wife is just about to give up on it on the XP machine too. Avant has about one more update to get things working better before I throw in the towel and forget about it. There are other browsers out there and I'm willing to give up some of the nifty things Avant can do for the sake of speed and reliability.

Bullroarer
Newbie
Newbie
Posts: 8
Joined: Wed Dec 24, 2008 2:45 pm
Windows Version: XP Pro
Avant Version: 11.7 build 9
IE Version: 7.0 5730.13

Re: Why has Avant Browser gotten SLOW??

Post by Bullroarer » Tue Jan 13, 2009 9:56 pm

As time passes, I'm getting further way from Avant. When I posted the above, I was on the fence about ditching Avant all together. Now after using Chrome for several solid weeks and having zero issues and fast loading of pages, I will most likely not migrate back to Avant even if they miraculously (Chrome just told me I spelled miraculously wrong) fix the bugs. It was a nice ride while it lasted. I did enjoy Avant browser during those years and promoted it considerably on my popular "geek" website, but it has had its run. Chrome is now my browser of choice after having time to get used to it. These days you don't get an infinite amount of time to fix the bugs before people abandon the product especially with so many choices out there.

Image

abfan123
Avantus Maximus
Avantus Maximus
Posts: 5624
Joined: Wed Jan 26, 2005 4:24 pm
Windows Version: Vista Ultimate x64 SP2
Avant Version: 11.7 build 43
IE Version: 8
Contact:

Re: Why has Avant Browser gotten SLOW??

Post by abfan123 » Tue Jan 13, 2009 10:16 pm

The only thing I could confirm so far is that Avant is sometimes not releasing the memory when you close a tab, Which results in heavy memory usage. I've tried to do several things to confirm this issue, But couldn't find any specific cause as it seems to happen randomly. Flash is the culprit, But again, I can't seem to find any specific case to reproduce this issue on any of my 3 PCs. (On this PC, There are currently about 35 opened tabs. Some of them contents a lot of Flash & Javascript. I've not closed Avant on this PC for at least a day and the current memory usage is about 460MB.)
But I couldn't confirm at all any speed related issues. It always seems to work fast.
I've noticed that the RC build of IE8 makes it a little faster comparing to IE7.

As of your specific issue, Are you talking about the page loading/rendering speed? Or the interface speed? (Slow opening of new tabs etc)
IE8(Pro), Microsoft Security Essentials
Main PC:
Image
Secondary PC same as primary but with Windows 7 x64 Ultimate as the OS.

Bullroarer
Newbie
Newbie
Posts: 8
Joined: Wed Dec 24, 2008 2:45 pm
Windows Version: XP Pro
Avant Version: 11.7 build 9
IE Version: 7.0 5730.13

Re: Why has Avant Browser gotten SLOW??

Post by Bullroarer » Wed Jan 14, 2009 1:13 am

This is not a speed issue due to memory usage. It simply locks up entirely for anywhere from 30 seconds to well over a minute when loading certain web pages. This can be after hours of use or on a fresh start. Maybe its flash related. Maybe its a combination of several things. I don't know. Where are the Avant programmers on this? :thumbdown:

abfan123
Avantus Maximus
Avantus Maximus
Posts: 5624
Joined: Wed Jan 26, 2005 4:24 pm
Windows Version: Vista Ultimate x64 SP2
Avant Version: 11.7 build 43
IE Version: 8
Contact:

Re: Why has Avant Browser gotten SLOW??

Post by abfan123 » Wed Jan 14, 2009 1:15 am

There's only one programmer and he's not responding to threads in this forum too often.
Do you have the ads blocker enabled? (Please look under the Tools menu)
If yes, Please try to disable it.
IE8(Pro), Microsoft Security Essentials
Main PC:
Image
Secondary PC same as primary but with Windows 7 x64 Ultimate as the OS.

Bullroarer
Newbie
Newbie
Posts: 8
Joined: Wed Dec 24, 2008 2:45 pm
Windows Version: XP Pro
Avant Version: 11.7 build 9
IE Version: 7.0 5730.13

Re: Why has Avant Browser gotten SLOW??

Post by Bullroarer » Wed Jan 14, 2009 1:19 am

Ads blocker is not enabled. I develop sites for a living and ads are part of the development. I need to see ads. So no, not enabled.

Den
Semi-Fan
Semi-Fan
Posts: 79
Joined: Thu Mar 18, 2004 11:32 pm
Windows Version: XP HE/Win 7 64/
Avant Version: 2014 built 2
Default engine: IE
IE Version: IE11
Skin: crystal

Re: Why has Avant Browser gotten SLOW??

Post by Den » Thu Jan 15, 2009 2:02 pm

I'm using version 11.7 B21 and I've got the same problem: slow slow slow loading web pages: but this bug is not permanent: In my case it's a come and go problem and that's the only reason I'm still here.

If only someone would come up with an explanation to this bug. I've tried using a memory manager without success.

Do we need a new 12 version with new bugs when the existing Avant still needs improvement?

Den

PS: Avant has such great features that we all like. But I'm trying hard not to jump to Firefox or Opera. (Avant would be unbeatable with the zoom features of those two)

DeepUnder
Newbie
Newbie
Posts: 9
Joined: Thu Dec 12, 2002 10:32 am
Avant Version:

Re: Why has Avant Browser gotten SLOW??

Post by DeepUnder » Fri Jan 16, 2009 11:19 pm

i feel your pain. is it similar to this topic

http://forum.avantbrowser.com/viewtopic.php?f=6&t=23185


i am to abot to ditch Avant due to this slowness and hangs while browsing sites.

DeepUnder
Newbie
Newbie
Posts: 9
Joined: Thu Dec 12, 2002 10:32 am
Avant Version:

Re: Why has Avant Browser gotten SLOW??

Post by DeepUnder » Mon Jan 26, 2009 11:55 pm

don't want to be a pain... but is there any update on this?

thanks

2manytoys
Newbie
Newbie
Posts: 8
Joined: Wed Nov 23, 2005 2:43 pm
Avant Version:

Re: Why has Avant Browser gotten SLOW??

Post by 2manytoys » Wed Jan 28, 2009 3:48 am

Well, I have been a devout Avant user for a couple of years now but due to the slower and slower speed problem, I switched over to firefox today. After loading the latest version, the speed got so bad that surfing was just unbearable. To bad because I felt Avant had some advantages over other browsers. I will turn it on every now and again in the future to see if the problem has been corrected. I have noticed in task manager that Avant.exe seems to keep loading up more and more and more memory till it basically hangs. That being said, firefox seems to run very quick at around 174,000 k , the speed at which Avant usually starts hanging.

Bullroarer
Newbie
Newbie
Posts: 8
Joined: Wed Dec 24, 2008 2:45 pm
Windows Version: XP Pro
Avant Version: 11.7 build 9
IE Version: 7.0 5730.13

Re: Why has Avant Browser gotten SLOW??

Post by Bullroarer » Wed Jan 28, 2009 3:52 am

Give Google's Chrome a try. Better than Firefox and fast. Tabs are independent processes so if one hangs, it won't hang the whole browser.

gr_b
Newbie
Newbie
Posts: 4
Joined: Tue Nov 04, 2008 6:37 pm
Windows Version: XP
Avant Version: 11.7
IE Version: 6

Re: Why has Avant Browser gotten SLOW??

Post by gr_b » Fri May 15, 2009 8:13 pm

I'm also having same issue. for the past couple of months Avant is very very slow in loading pages..I'm using Avant browser since 2004..and I might switch to Chrome if the performance remains like this..

iceshake
Newbie
Newbie
Posts: 48
Joined: Mon Oct 24, 2005 3:31 pm
Avant Version:

Re: Why has Avant Browser gotten SLOW??

Post by iceshake » Sat May 16, 2009 3:58 pm

the new release build 28 largely fixes this for me. hope it does the same for you too.

v0pelor
Newbie
Newbie
Posts: 10
Joined: Sun May 17, 2009 2:28 pm
Windows Version: Vista (x64) SP1
Avant Version: 11.7.23
IE Version: 8.0.6001.18762 (x64)

Re: Why has Avant Browser gotten SLOW??

Post by v0pelor » Sun May 17, 2009 2:32 pm

I need to see ads too

iceshake
Newbie
Newbie
Posts: 48
Joined: Mon Oct 24, 2005 3:31 pm
Avant Version:

Re: Why has Avant Browser gotten SLOW??

Post by iceshake » Wed May 27, 2009 12:44 pm

several pages exhibit this problem of slowing down avant

www.bloomberg.com
www.ign.com
www.todayonline.com

User avatar
AXEMAN
Avantic Elite
Avantic Elite
Posts: 1606
Joined: Thu Jan 24, 2008 12:55 am
Windows Version: WIN 7 64 BIT
Avant Version: THE LATEST
IE Version: 9

Re: Why has Avant Browser gotten SLOW??

Post by AXEMAN » Wed May 27, 2009 6:22 pm

Maby anderson should focus on avant i think doing 2 browsers avant and orca at the same time is to much for one guy. So again focus on avant then orca or just get some help add a few coders make it a team. I have noticed each version of avant seams to have even more problems so again this is just a thought and in no way do i disrespect anderson :)

User avatar
André
Administrator
Administrator
Posts: 5787
Joined: Sat Dec 14, 1901 3:19 am
Windows Version: Windows 7 x64
Avant Version:
Location: Baltimore and McHenry, Maryland, USA
Contact:

Re: Why has Avant Browser gotten SLOW??

Post by André » Wed May 27, 2009 6:42 pm

Anderson does have a couple of extra programmers working for him.
Formerly known as DrDrrae.
Image
I am not a member of the development team.
Please search the forum before posting questions.

Avant Force Wiki || Avant Force Blog
Desktop:
Intel C2Q Q9550 @ 3.7GHz || 8GiBs DDR2 800 @ 435MHz || Asus P5E
112 GiB SSD || 931 GiB HDD || 2x ATI 5770 in CrossfireX || Picture

NetBook:
ASUS Eee PC 1000HE || 1.66 GHz Atom N280 || 2 GiB DDR2 667 || 320 GiB HDD

NAS:
Intel E5200 @ 2.632 GHz || 4 GiB DDR2 800 @ 421 MHz || Foxconn G31MXP-K
5.45 TiB RAID 6

iceshake
Newbie
Newbie
Posts: 48
Joined: Mon Oct 24, 2005 3:31 pm
Avant Version:

Re: Why has Avant Browser gotten SLOW??

Post by iceshake » Thu May 28, 2009 4:06 am

for example:

www.channelnewsasia.com

Visiting that website will always cause avant to use 99% Cpu resources for 5 to 10 seconds. Does anyone experience this in build 31?

User avatar
ftboomer
Avant Fanatic
Avant Fanatic
Posts: 295
Joined: Tue Sep 07, 2004 8:50 pm
Windows Version: Windows 7 x64
Avant Version: Latest
IE Version: IE8 x64
Location: Tampa, FL
Contact:

Re: Why has Avant Browser gotten SLOW??

Post by ftboomer » Thu May 28, 2009 11:46 am

iceshake wrote:for example:

http://www.channelnewsasia.com

Visiting that website will always cause avant to use 99% Cpu resources for 5 to 10 seconds. Does anyone experience this in build 31?

I just opened it (with Orca) and it worked rather quickly but I did notice that there were a ton of ads loading. This is also a link heavy site whic could be another reason for the slow load. My suggestion, switch to Orca.
Image
Give me a dirty martini and a great cigar, cause nothing beats a nice tight white ash!

Post Reply