Clicking link changes focus to next app

Moderators: André, AvantGuard

Post Reply
RWLC
Newbie
Newbie
Posts: 12
Joined: Wed Nov 04, 2009 8:23 am
Windows Version: 7, 8gb RAM
Avant Version: 2012 Build 7
IE Version: 9, up-to-date

Clicking link changes focus to next app

Post by RWLC » Wed Nov 04, 2009 11:53 am

Has anyone else encountered a problem with focus changing to another open application upon clicking a link on a web page? It's always the next app in line that you would switch to if you hit Alt-Tab and released. And, simply clicking on the AB window doesn't bring AB back into focus, I have to click somewhere else first.

I thought I was inadvertently doing something that caused me to switch foreground application, but no, it's actually happening upon clicking links. Clicking File, Print, Print did it once, too.

When this happens I can duplicate the problem by clicking the same link again, but I don't seem to be able to duplicate it with the same link from one AB session to another. I encountered this problem with v. 11 bld 39, and also have it with 11.41. OS is Vista Home Prem SP2.

User avatar
kudos
Support Staff²
Support Staff²
Posts: 3384
Joined: Wed Mar 22, 2006 10:35 am
Avant Version:

Re: Clicking link changes focus to next app

Post by kudos » Wed Nov 04, 2009 12:54 pm

Is there anything special about the pages, ie lots of Flash, popups, etc?
Can you check what happens if you disable the popup and ad blockers.
 
.:Volunteer support staff (regular user):.
Image
I am not a member of the Avant / Orca development team
Please search this forum / the Wiki before posting questions
Forum Rules | Frequently Asked Questions | Active Topics

addonsfan
Avantic Elite
Avantic Elite
Posts: 1940
Joined: Sun Aug 05, 2007 11:56 am
Windows Version: Windows 7
Avant Version: N/A
IE Version: N/A
Location: California, USA
Contact:

Re: Clicking link changes focus to next app

Post by addonsfan » Fri Nov 06, 2009 1:59 am

Been experiencing this since many versions ago, and since WinXP. I've been through Vista, and now on Win7. It does seem to be triggered by popup ads. In Win7, however, there's a little light of hope that makes this less annoying. If you have all other windows minimized, it doesn't happen. This kinda makes me think it's a problem related with the Windows API, which opens doors to all sorts of theories for me.

I'll try to keep my eye open for a website that does this. One major clue for the thing that is triggering it, is that it uses popups which bypass Avant's popup blocker. Same thing always happens reguardless of the features enabled/disabled in the "Tools" menu.

Edit:
I have a couple of link that I feel aren't very appropriate to post here, due to content of these sites... (legal sites, links to probably illegal files) I wonder if I should post them anyways, or atleast give names?

Post Reply