Avant "locks up" on certain websites

Moderators: André, AvantGuard

phidelio
Newbie
Newbie
Posts: 5
Joined: Sun Sep 16, 2007 12:43 am
Avant Version:

Avant "locks up" on certain websites

Post by phidelio » Tue Jun 10, 2008 9:27 am

Hi guys!

I am currently running the latest Avant Browser, and since xmas or so (numerous updates back) I am having problems with some sites. Please try these two sites (no virus, spam etc):

www.svd.se
www.dn.se

On both of them my browser loads about half the page, locks up for like 15 seconds or longer, and then the page "works normally". However, every refresh or visit of a new site gives the same problem. This occurs on 3 different machines (all running Win XP Sp2). Any ideas? Thx!

abfan123
Avantus Maximus
Avantus Maximus
Posts: 5624
Joined: Wed Jan 26, 2005 4:24 pm
Windows Version: Vista Ultimate x64 SP2
Avant Version: 11.7 build 43
IE Version: 8
Contact:

Re: Avant "locks up" on certain websites

Post by abfan123 » Tue Jun 10, 2008 1:57 pm

Hello,
Weird, I can't seem to confirm it here.
What's your IE version? Do you have the same problem in IE? What's your Flash player version?
IE8(Pro), Microsoft Security Essentials
Main PC:
Image
Secondary PC same as primary but with Windows 7 x64 Ultimate as the OS.

User avatar
LarryE1946
Newbie
Newbie
Posts: 41
Joined: Sat Oct 27, 2007 12:18 am
Windows Version: Vista Home Premium
Avant Version: 11.5 build 21
IE Version: IE 7
Location: Illinois
Contact:

Re: Avant "locks up" on certain websites

Post by LarryE1946 » Tue Jun 10, 2008 5:53 pm

Sorry, I can't duplicate your problems either. Latest build 11.6 Build 16 on Vista Ultimate 32-bit.
Vista Home Premium
Core2Duo
2GB RDRAM

User avatar
Arandora
Semi-Avantic
Semi-Avantic
Posts: 474
Joined: Sat Aug 09, 2003 10:33 pm
Windows Version: Win 8.1 64 PC/Win 8. 64 laptop
Avant Version: Both AB Lite 2016 v2
Default engine: IE11 Standards
IE Version: IE 11 on PC and laptop
Skin: Aluminium
Location: Poulton-le-Fylde, UK

Re: Avant "locks up" on certain websites

Post by Arandora » Tue Jun 10, 2008 9:27 pm

Accessing both sites is as described by the OP on my laptop. Very slow loading, then freezes, side scroll bar doesn't work. Thereafter accessing links in the other open tabs is slower than before I accessed these sites. I closed down AB and reopened same tabs and performance back to normal.
Laptop Windows 8.2 64 bit, IE11; PC Win 8.1, IE11. Both AB Lite 2016 b 2 IE Favorites, IE11 Standards rendering engine.

abfan123
Avantus Maximus
Avantus Maximus
Posts: 5624
Joined: Wed Jan 26, 2005 4:24 pm
Windows Version: Vista Ultimate x64 SP2
Avant Version: 11.7 build 43
IE Version: 8
Contact:

Re: Avant "locks up" on certain websites

Post by abfan123 » Tue Jun 10, 2008 9:53 pm

Arandora wrote:Accessing both sites is as described by the OP on my laptop. Very slow loading, then freezes, side scroll bar doesn't work. Thereafter accessing links in the other open tabs is slower than before I accessed these sites.
What's your Flash Player version?
Will the website load fine if you'll disable Flash?
Do you get the same problem in IE?
IE8(Pro), Microsoft Security Essentials
Main PC:
Image
Secondary PC same as primary but with Windows 7 x64 Ultimate as the OS.

phidelio
Newbie
Newbie
Posts: 5
Joined: Sun Sep 16, 2007 12:43 am
Avant Version:

Re: Avant "locks up" on certain websites

Post by phidelio » Tue Jun 10, 2008 10:42 pm

Yes Arandora - thats exactly the problem I have. Very annoying considering this is the best browser on the planet:) I will try to make all updates of XP, IE etc and see what happens.


>>> Abfan = I have tried to enable/disable flashplayer/popupblocker/adblocker etc = no difference

User avatar
Arandora
Semi-Avantic
Semi-Avantic
Posts: 474
Joined: Sat Aug 09, 2003 10:33 pm
Windows Version: Win 8.1 64 PC/Win 8. 64 laptop
Avant Version: Both AB Lite 2016 v2
Default engine: IE11 Standards
IE Version: IE 11 on PC and laptop
Skin: Aluminium
Location: Poulton-le-Fylde, UK

Re: Avant "locks up" on certain websites

Post by Arandora » Wed Jun 11, 2008 4:30 pm

Hi,
I tried the links as well both on my PC and on IE7 on my PC with the same result except on IE after loading the firsyt link and then opening another tab, it completely froze and took several minutes to unfreeze and then to close IE down.
My Flash version on both my PC and muy laptop is 9.0.124.0
After accessing the first link in AB, other previously opened tabs refresdh very slowly with a message on the bottom toolbar that 1 picture is downloading. Here is a screenshot of a typical page showing the message. Hope you can read it.

http://star.walagata.com/w/arandora/7198518.jpg

Image
Laptop Windows 8.2 64 bit, IE11; PC Win 8.1, IE11. Both AB Lite 2016 b 2 IE Favorites, IE11 Standards rendering engine.

phidelio
Newbie
Newbie
Posts: 5
Joined: Sun Sep 16, 2007 12:43 am
Avant Version:

Re: Avant "locks up" on certain websites

Post by phidelio » Thu Jun 12, 2008 3:58 am

Same here... updated to latest IE and Flash... problem persists:(

zaax2007
Newbie
Newbie
Posts: 1
Joined: Mon Jun 16, 2008 11:27 pm
Windows Version: xp
Avant Version: 11.6
IE Version: 7

Re: Avant "locks up" on certain websites

Post by zaax2007 » Mon Jun 16, 2008 11:30 pm

I get the same problem when I log into http://katz.cd/ but only when I enter the page for the first time that day.

The browser freezes for a while than come back

phidelio
Newbie
Newbie
Posts: 5
Joined: Sun Sep 16, 2007 12:43 am
Avant Version:

Re: Avant "locks up" on certain websites

Post by phidelio » Tue Jun 17, 2008 3:20 pm

Finding more and more sites with the problem every day.. f.ex yahoo maps and sterling.com

kaib00
Newbie
Newbie
Posts: 3
Joined: Fri Jun 20, 2008 7:49 pm
Windows Version: Vista Premium
Avant Version: 11.6 b19
IE Version: IE7

Re: Avant "locks up" on certain websites

Post by kaib00 » Fri Jun 20, 2008 8:10 pm

I have a problem that sounds similar to this, however it seems to be effecting any website I go to. Avant seems to lock up when first opening, for about a minute, then each time a link is clicked or a new page opened it does the same thing. I am able to minimize the window by clicking on the tray icon, but not the window button or the taskbar (I have to close the program through task manager while it is locked up)
It started just a few days ago (I was on 11.6b18) I tried upgrading to the newest version, uninstalling/reinstalling, and even clearing all traces of registry files and program data after uninstalling (this last bit helped for awhile, the problem was gone for an hour or so after reinstalling, then came back)

I am using Vista Ultimate x32 and IE 7, AB 11.6b19
(I am currently typing this in IE7 because avant is taking way too long to navigate through the forums)

kaib00
Newbie
Newbie
Posts: 3
Joined: Fri Jun 20, 2008 7:49 pm
Windows Version: Vista Premium
Avant Version: 11.6 b19
IE Version: IE7

Re: Avant "locks up" on certain websites

Post by kaib00 » Fri Jun 20, 2008 8:48 pm

I forgot to add, I also am using google toolbar and Download Accellerator as add-ons

trying something real quick...

:arrow: >> disabling all of these seems to have fixed the problem for now, I will try to further narrow down the exact problem if I can, (I guess when I had reinstalled Avant it had taken me that hour or so to put those add-ons back into avant)

...too bad my mouse scrollwheel still doesnt work lol

addonsfan
Avantic Elite
Avantic Elite
Posts: 1940
Joined: Sun Aug 05, 2007 11:56 am
Windows Version: Windows 7
Avant Version: N/A
IE Version: N/A
Location: California, USA
Contact:

Re: Avant "locks up" on certain websites

Post by addonsfan » Sat Jun 21, 2008 12:54 pm

has something to do with long pages. IE will freeze up monetarily while it loads, but quickly recover. Avant will freeze up, and fail to recover. a good example would be viewing all comments on a Youtube video.

example:
WARNING, this will almost certainly freeze up Avant and may cause you to need to restart it!!!

kaib00
Newbie
Newbie
Posts: 3
Joined: Fri Jun 20, 2008 7:49 pm
Windows Version: Vista Premium
Avant Version: 11.6 b19
IE Version: IE7

Re: Avant "locks up" on certain websites

Post by kaib00 » Sat Jun 21, 2008 2:13 pm

Ok so I found the solution (to my problem at least, not sure if we have the same one)

:idea: installed the new beta of google toolbar (5.xx) and it works great so far with avant, no locking up anymore, it was version 4.xx that was causing the problem (removing or disabling version 4.xx of google also fixed it but then no google :wink: )

I also verified this by fixing the problem on my squad leaders computer, I even 'stress tested' it by opening a lot of windows at once, it still worked fine

abfan123
Avantus Maximus
Avantus Maximus
Posts: 5624
Joined: Wed Jan 26, 2005 4:24 pm
Windows Version: Vista Ultimate x64 SP2
Avant Version: 11.7 build 43
IE Version: 8
Contact:

Re: Avant "locks up" on certain websites

Post by abfan123 » Sat Jun 21, 2008 3:02 pm

addonsfan wrote:has something to do with long pages. IE will freeze up monetarily while it loads, but quickly recover. Avant will freeze up, and fail to recover. a good example would be viewing all comments on a Youtube video.

example:
WARNING, this will almost certainly freeze up Avant and may cause you to need to restart it!!!
Even tried the new FasterIE feature of IE7Pro?
Yes, IE does freeze for about 1 second on this page, But it's mostly fine. (I'm talking about IE8 here... Not tried with Avant yet)
And I don't think that MDI is the problem...
IE8(Pro), Microsoft Security Essentials
Main PC:
Image
Secondary PC same as primary but with Windows 7 x64 Ultimate as the OS.

addonsfan
Avantic Elite
Avantic Elite
Posts: 1940
Joined: Sun Aug 05, 2007 11:56 am
Windows Version: Windows 7
Avant Version: N/A
IE Version: N/A
Location: California, USA
Contact:

Re: Avant "locks up" on certain websites

Post by addonsfan » Sun Jun 22, 2008 12:07 am

abfan123 wrote:And I don't think that MDI is the problem...
well, here's what I think could be causing it.

Every little window/tab being opened in Avant is contributing to the RAM. Avant itself is acting as a container for the windows. So it's like having a bunch of M&Ms, and one color representing each window. You dump all your M&Ms into a big jar (or Avant Browser), and try to filter out the color of each windows you're closing. It's really hard, and would take a lot of CPU. But closing Avant, or just dumping all the M&Ms out would take you back to square one.

Now I believe MDI itself is not the problem, but the method of using MDI is. Right now Anderson is having all the M&Ms dump into one big jar, when there should be a smaller jar for each window.

That's my theory. Though, it's been a loooong time since I even attempted to program using MDI.

User avatar
Arandora
Semi-Avantic
Semi-Avantic
Posts: 474
Joined: Sat Aug 09, 2003 10:33 pm
Windows Version: Win 8.1 64 PC/Win 8. 64 laptop
Avant Version: Both AB Lite 2016 v2
Default engine: IE11 Standards
IE Version: IE 11 on PC and laptop
Skin: Aluminium
Location: Poulton-le-Fylde, UK

Re: Avant "locks up" on certain websites

Post by Arandora » Sun Jun 22, 2008 7:03 am

Having a multi-tab fast browser was what attracted me to AB in the first place and I have upgraded my processors, increased RAM, as will have most people, as the development of AB has progressed (not because of AB just because general demands on and usage of PC have increased). However, this and other problems with AB, it now apperars demands more. Why is that? I don't have any more M*Ms in my jar these days but I thought I had a better jar! :)
Laptop Windows 8.2 64 bit, IE11; PC Win 8.1, IE11. Both AB Lite 2016 b 2 IE Favorites, IE11 Standards rendering engine.

addonsfan
Avantic Elite
Avantic Elite
Posts: 1940
Joined: Sun Aug 05, 2007 11:56 am
Windows Version: Windows 7
Avant Version: N/A
IE Version: N/A
Location: California, USA
Contact:

Re: Avant "locks up" on certain websites

Post by addonsfan » Sun Jun 22, 2008 10:55 am

Yeah... to be honest, even I'm starting to lose faith in Avant Browser. If it were some major company, and I were an investor... I would've sold my stocks a looooong time ago.

PitterPat
Semi-Fan
Semi-Fan
Posts: 71
Joined: Sun Oct 31, 2004 3:59 am
Avant Version:

Re: Avant "locks up" on certain websites

Post by PitterPat » Sun Jun 22, 2008 4:11 pm

I have the same problem and am NOT using Google tool bar.

Avant will freeze when loading and/or refresing certain pages. Try samsclub.com.

I usually disable flash but enabling it doesn't help.

The same sites work fine in IE and FF.

This is not a new problem. It's been consistent through several versions. I'm currently on 11.6/19.

PP

Tower
Newbie
Newbie
Posts: 5
Joined: Mon Jun 23, 2008 10:19 pm
Windows Version: XP
Avant Version: 11.6
IE Version: IE7

Re: Avant "locks up" on certain websites

Post by Tower » Mon Jun 23, 2008 10:34 pm

Same here.
I'm from Italy and this "temporary freezing" is present in many others sites.
The one it is most evident (to me) is this one: http://www.corriere.it/ that is the site of the biggest online italian newspaper.
I've noticed that the problem doesn't show only if I disable scripts (which, by the way, makes the site almost useless).
I experience the problem even with blogs containing ads.

Post Reply