"white pages"

Resolved Orca Help issues and Bug Reports can be found here. Orca is a legacy browser that is no longer supported.

Moderators: Support Staff², Support Staff, AvantGuard, Developer

Post Reply
Darklord
Newbie
Newbie
Posts: 28
Joined: Fri Jan 09, 2009 1:15 pm
Windows Version: Vista Home Premium 64-bit
Avant Version: N/A
IE Version: N/A

"white pages"

Post by Darklord » Fri May 22, 2009 12:46 pm

I seem to recall seeing someone mentioning this, but I can't find it again.

Every once in a while, orca will open "white pages" - that is, when you try to open a page, or a set of pages, the pages aren't loaded and instead you're faced with an empty, white page. It's not that the loading has stalled - it doesn't "catch up" if you wait - the page just simply doesn't open. Only when you re-open (or refresh, I believe) does the page appear as intended. Note that the problem can affect a cluster of pages, so it's not tied to one particular page - it's the "opening act", so to speak.

I can't recreate it, and it doesn't happen often enough for me to remember it with absolute certainty, but I figure someone else might have experienced it (again, I couldn't find the place I thought I was it mentioned).

User avatar
kudos
Support Staff²
Support Staff²
Posts: 3384
Joined: Wed Mar 22, 2006 10:35 am
Avant Version:

Re: "white pages"

Post by kudos » Fri May 22, 2009 1:03 pm

Are you using the "pipelining" tweaks?
Do you have any extensions or plugins loaded?
Your profile shows build 2 - the latest is build 3.
 
.:Volunteer support staff (regular user):.
Image
I am not a member of the Avant / Orca development team
Please search this forum / the Wiki before posting questions
Forum Rules | Frequently Asked Questions | Active Topics

Darklord
Newbie
Newbie
Posts: 28
Joined: Fri Jan 09, 2009 1:15 pm
Windows Version: Vista Home Premium 64-bit
Avant Version: N/A
IE Version: N/A

Re: "white pages"

Post by Darklord » Sat May 23, 2009 10:40 am

kudos wrote:Are you using the "pipelining" tweaks?
no pipelining. although now you're bringing it to my attention, I'll try it! hehe. (off-topic: 30 or 8? is this guy http://egonitron.com/2007/05/25/the-tru ... ing-trick/ making sense?)
kudos wrote:Do you have any extensions or plugins loaded?
only IE Tab.
kudos wrote:Your profile shows build 2 - the latest is build 3.
sorry, hadn't updated the profile. if only it could be detected automatically, hehe...

User avatar
kudos
Support Staff²
Support Staff²
Posts: 3384
Joined: Wed Mar 22, 2006 10:35 am
Avant Version:

Re: "white pages"

Post by kudos » Sat May 23, 2009 11:06 am

Darklord wrote:(off-topic: 30 or 8? is this guy http://egonitron.com/2007/05/25/the-tru ... ing-trick/ making sense?)
Yep, he is correct. I have tried various values and selected the best from various different pc's. Here's the values from my prefs.js file:

Code: Select all

user_pref("network.http.max-connections", 96);
user_pref("network.http.max-connections-per-server", 32);
user_pref("network.http.max-persistent-connections-per-server", 8);
user_pref("network.http.pipelining", true);
user_pref("network.http.proxy.pipelining", true);
user_pref("network.http.pipelining.maxrequests", 8);
user_pref("network.http.pipelining.ssl", true);
user_pref("network.http.proxy.pipelining", true);
user_pref("nglayout.initialpaint.delay", 0);
 
.:Volunteer support staff (regular user):.
Image
I am not a member of the Avant / Orca development team
Please search this forum / the Wiki before posting questions
Forum Rules | Frequently Asked Questions | Active Topics

Dreamer
Avantic Deluxe
Avantic Deluxe
Posts: 1440
Joined: Mon Aug 23, 2004 2:17 pm
Windows Version: 10 64-bit
Avant Version: 2018 Build 7 USB
Default engine: Firefox
IE Version: 11.51.14393.0
Skin: Dream

Re: "white pages"

Post by Dreamer » Sun May 31, 2009 9:01 pm

Perhaps it's the same problem. When I've started build 5 (USB) for the first time, the first tab/page was loaded OK, the others had just white pages - it was not possible to refresh them, but when I restarted Orca, all pages were loaded correctly. This happened with build 5 USB only, with several instances in different folders, even without OrcaXtra (multiple instance launcher, not released yet) - but just for the first time. It has happened twice only with one instance.

I'm using option to auto save all tabs on exit.
Dreamer

User avatar
Horse
Semi-Fan
Semi-Fan
Posts: 62
Joined: Sun Mar 01, 2009 3:51 pm
Windows Version: 7 ultimate
Avant Version: 2010 Build 122
IE Version: 8
Location: Moscow, Russia

Re: "white pages"

Post by Horse » Tue Jun 02, 2009 8:49 am

Yes. I confirm all.

Dreamer
Avantic Deluxe
Avantic Deluxe
Posts: 1440
Joined: Mon Aug 23, 2004 2:17 pm
Windows Version: 10 64-bit
Avant Version: 2018 Build 7 USB
Default engine: Firefox
IE Version: 11.51.14393.0
Skin: Dream

Re: "white pages"

Post by Dreamer » Thu Jun 04, 2009 12:34 am

Still the same with build 6, I can confirm it with several USB instances, firewall disabled. :problem:
Dreamer

User avatar
kudos
Support Staff²
Support Staff²
Posts: 3384
Joined: Wed Mar 22, 2006 10:35 am
Avant Version:

Re: "white pages"

Post by kudos » Sun Jun 07, 2009 7:28 pm

I have done some tests and can confirm and replicate. The problem seems to be with Orca rebuilding its cache.

Steps to reproduce:

- Install Orca Browser or the portable version
- Go to the settings folder: "%appdata%\Orca Browser\.default" or "<install folder>\.default"
- Delete the folder named mozdata (to force a cache rebuild)
- Place a reopen.dat file in the .default folder (*see below)
- Start Orca Browser

Orca will start and ask to reopen web pages so select ok to all.
It will then start up, but only one page will load, the others are white/blank/dead.
You should be able to load more, but not in the started "dead" pages.
Closing Orca, putting the reopen.dat file there again then restarting Orca works fine.

(*)The reopen.dat file is a simple text file with URL and page descriptions. Here is the content of mine:

Code: Select all

Avant Force Forum
http://forum.avantbrowser.com/
Yahoo
http://www.yahoo.com/
Google
http://www.google.com/
Bing
http://www.bing.com/
Ask
http://www.ask.com/
Wikipedia
http://www.wikipedia.org/
Can anyone confirm?
 
.:Volunteer support staff (regular user):.
Image
I am not a member of the Avant / Orca development team
Please search this forum / the Wiki before posting questions
Forum Rules | Frequently Asked Questions | Active Topics

Dreamer
Avantic Deluxe
Avantic Deluxe
Posts: 1440
Joined: Mon Aug 23, 2004 2:17 pm
Windows Version: 10 64-bit
Avant Version: 2018 Build 7 USB
Default engine: Firefox
IE Version: 11.51.14393.0
Skin: Dream

Re: "white pages"

Post by Dreamer » Sun Jun 07, 2009 11:59 pm

Confirmed.
Dreamer

User avatar
kudos
Support Staff²
Support Staff²
Posts: 3384
Joined: Wed Mar 22, 2006 10:35 am
Avant Version:

Re: "white pages"

Post by kudos » Wed Jun 10, 2009 11:38 am

Looks like it's fixed in build 7 - good work Anderson. I guess that a step-by-step list to reproduce errors is always best.
 
.:Volunteer support staff (regular user):.
Image
I am not a member of the Avant / Orca development team
Please search this forum / the Wiki before posting questions
Forum Rules | Frequently Asked Questions | Active Topics

Dreamer
Avantic Deluxe
Avantic Deluxe
Posts: 1440
Joined: Mon Aug 23, 2004 2:17 pm
Windows Version: 10 64-bit
Avant Version: 2018 Build 7 USB
Default engine: Firefox
IE Version: 11.51.14393.0
Skin: Dream

Re: "white pages"

Post by Dreamer » Wed Jun 10, 2009 6:13 pm

Fixed in build 7 - confirmed!
Dreamer

Post Reply