2015 Build 28 Chrome issue

Please put your bug reports here, and only here.

Moderators: Support Staff², Support Staff, AvantGuard, Developer

Post Reply
rholster
Newbie
Newbie
Posts: 6
Joined: Thu Dec 18, 2014 5:58 pm
Windows Version: Windows 10 64-bit
Avant Version: Ultimate 2016 Build 17
Default engine: Chrome
IE Version: N/A
Skin: Aluminum

2015 Build 28 Chrome issue

Post by rholster » Wed Oct 07, 2015 1:30 pm

I recently updated to 2015 Build 28 and the Chrome engine does not work properly. The text is much larger than normal and the page is shifted to the right side of the screen. Changing the zoom does not help. Switching the the Firefox engine fixes the problem but I prefer the Chrome engine. I looked but couldn't find a link to roll it back to the previous version. Any suggestions?

rholster
Newbie
Newbie
Posts: 6
Joined: Thu Dec 18, 2014 5:58 pm
Windows Version: Windows 10 64-bit
Avant Version: Ultimate 2016 Build 17
Default engine: Chrome
IE Version: N/A
Skin: Aluminum

Re: 2015 Build 28 Chrome issue

Post by rholster » Wed Oct 07, 2015 1:35 pm

I'm posting screenshots of the same page using both Firefox and Chrome engines.
Attachments
Chrome.jpg
This is with the Chrome engine.
Firefox.jpg
This is with the Firefox engine.

User avatar
Nederpietos
Semi-Avantic
Semi-Avantic
Posts: 506
Joined: Sun Jan 25, 2004 5:25 pm
Windows Version: 10 pro
Avant Version: 2018 build 7 ult
Default engine: Firefox
IE Version: IE11
Skin: stickers on blue

Re: 2015 Build 28 Chrome issue

Post by Nederpietos » Wed Oct 07, 2015 1:45 pm


User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: 2015 Build 28 Chrome issue

Post by xiaobing » Thu Oct 08, 2015 1:51 am

rholster wrote:I recently updated to 2015 Build 28 and the Chrome engine does not work properly. The text is much larger than normal and the page is shifted to the right side of the screen. Changing the zoom does not help. Switching the the Firefox engine fixes the problem but I prefer the Chrome engine. I looked but couldn't find a link to roll it back to the previous version. Any suggestions?
It works if you rename this webkit folder (C:\Users\username\AppData\Roaming\Avant Profiles\.default\webkit) and restart Avant?

newtekie1
Semi-Fan
Semi-Fan
Posts: 93
Joined: Fri Jul 29, 2005 2:40 pm
Windows Version: Windows 7 Pro x64
Avant Version: Latest
Default engine: Chrome
IE Version: 11
Skin: Opal Glass

Re: 2015 Build 28 Chrome issue

Post by newtekie1 » Sat Oct 10, 2015 3:11 am

It seems like it has something to do with Windows display scaling. If you leave display scaling at the "Smaller" setting, which I believe is scaling turned off, then the Chrome engine renders correctly in Avant. However, if you set the display scaling setting to anything higher, the Chrome engine doesn't render properly.

newtekie1
Semi-Fan
Semi-Fan
Posts: 93
Joined: Fri Jul 29, 2005 2:40 pm
Windows Version: Windows 7 Pro x64
Avant Version: Latest
Default engine: Chrome
IE Version: 11
Skin: Opal Glass

Re: 2015 Build 28 Chrome issue

Post by newtekie1 » Sat Jan 02, 2016 5:47 am

Any chance of this issue being addressed? Avant is basically unusable on my 4K monitor.

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: 2015 Build 28 Chrome issue

Post by xiaobing » Mon Jan 04, 2016 1:58 am

Please set the display scaling to "smaller" before we fix the problem.
BTW, when you set the display scaling setting to anything higher, the links on webpage works normally?

newtekie1
Semi-Fan
Semi-Fan
Posts: 93
Joined: Fri Jul 29, 2005 2:40 pm
Windows Version: Windows 7 Pro x64
Avant Version: Latest
Default engine: Chrome
IE Version: 11
Skin: Opal Glass

Re: 2015 Build 28 Chrome issue

Post by newtekie1 » Mon Jan 04, 2016 2:16 am

Yeah, I'm the one that figured out the problem was the display scaling. But have you ever used the smaller display scaling on a 28" 4K monitor? Nothing is readable. I'd need a magnifying glass... :thumbdown:

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: 2015 Build 28 Chrome issue

Post by xiaobing » Mon Jan 04, 2016 2:50 am

The highest resolution monitor we currently have is 1080X1920 which is unable to reproduce your problem. How about using a large zoom size?

newtekie1
Semi-Fan
Semi-Fan
Posts: 93
Joined: Fri Jul 29, 2005 2:40 pm
Windows Version: Windows 7 Pro x64
Avant Version: Latest
Default engine: Chrome
IE Version: 11
Skin: Opal Glass

Re: 2015 Build 28 Chrome issue

Post by newtekie1 » Sat Mar 12, 2016 5:59 pm

The problem is easy to reproduce. It doesn't matter what resolution screen you have, just go into Window's display settings and raise the scaling to something higher than 100%. I've done this on a 1920x1080 monitor and the problem happens immediately. I've attached a picture showing exactly where to find the setting in Windows.

Simply raising the zoom size in Avant doesn't help, everything else I use in Windows, and even Avant's tool bars are too small to be usable.

Avant needs to be fixed so that it works properly with the built in Windows display scaling.
Attachments
avantproblem.png

newtekie1
Semi-Fan
Semi-Fan
Posts: 93
Joined: Fri Jul 29, 2005 2:40 pm
Windows Version: Windows 7 Pro x64
Avant Version: Latest
Default engine: Chrome
IE Version: 11
Skin: Opal Glass

Re: 2015 Build 28 Chrome issue

Post by newtekie1 » Sat Apr 09, 2016 3:02 pm

Just installed 2016 Build 5, and this problem still exists.

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: 2015 Build 28 Chrome issue

Post by xiaobing » Wed Jun 29, 2016 10:03 am

Please try 2016 build 7

newtekie1
Semi-Fan
Semi-Fan
Posts: 93
Joined: Fri Jul 29, 2005 2:40 pm
Windows Version: Windows 7 Pro x64
Avant Version: Latest
Default engine: Chrome
IE Version: 11
Skin: Opal Glass

Re: 2015 Build 28 Chrome issue

Post by newtekie1 » Mon Jul 04, 2016 1:53 pm

It seems like it is mostly fixed. But now there is an annoying black flicker every time a page loads. And the Avant Home page still doesn't work quiet right. But definitely a lot better.

Post Reply