Page 1 of 1

Old Firefox engine?

Posted: Sat May 03, 2014 8:06 am
by lefreak
"Avant Browser Ultimate 2014 Build 5 released. This version has integrated latest Chrome/Firefox rendering engine."

The actual version of FF when you released Build 5 (29th april) was FF 29.0, but when I click on "about" in Avant Browser, I see: Firefox 27.0.1

Is this info in the "about" menu wrong?

Re: Old Firefox engine?

Posted: Sat May 03, 2014 5:45 pm
by mathman
It is correct. Look for firefox.exe in gecko folder. Put the cursor on it - the version of firefox shows up.

Re: Old Firefox engine?

Posted: Sat May 03, 2014 9:09 pm
by lefreak
So, would it be possible to update the engine for myself? For example, if I copy the files from the "original" Firefox on my PC?

Then I wouldn't need to update so often Avant Browser, but only the engine, and I would prevent myself from installing a new Build of Avant with often newly introduced bugs... :wink:

Re: Old Firefox engine?

Posted: Sun May 04, 2014 1:47 am
by xiaobing
I'm afraid that users cannot upgrade the engines by themselves.

Re: Old Firefox engine?

Posted: Sun May 11, 2014 1:45 am
by mathman
xiaobing wrote:I'm afraid that users cannot upgrade the engines by themselves.
Replacing "firefox.exe" in Avant with a copy from Firefox won't work?

Re: Old Firefox engine?

Posted: Mon May 12, 2014 3:41 am
by xiaobing
mathman wrote:
xiaobing wrote:I'm afraid that users cannot upgrade the engines by themselves.
Replacing "firefox.exe" in Avant with a copy from Firefox won't work?
Yes, that may cause some problems. I just tried to copy the firefox.exe from firefox 29 to Avant, firefox engine reported errors.