Fix three main bugs

Please put your bug reports here, and only here.

Moderators: Support Staff², Support Staff, AvantGuard, Developer

Post Reply
wazib
Avant Fanatic
Avant Fanatic
Posts: 314
Joined: Fri Nov 27, 2009 4:23 pm
Windows Version: Win 10 Pro 64
Avant Version: 2017 Ultimate b.7
Default engine: Firefox
IE Version: 11.0
Skin: crystal
Location: Bydgoszcz, Poland

Fix three main bugs

Post by wazib » Tue Oct 01, 2013 10:32 pm

Developer need to fix 3 main errors (not a small bugs).
1. First tab after launch Avant Browser disappear, when I choose item from bookmark (tab disappeared and address bar was empty). Later (after next time choose the same link from bookmarks first tab was open) next tabs have been open normal.
2. Lilac error (purple screen). It`s very old bug. This post http://forum.avantbrowser.com/viewtopic.php?f=6&t=30703
is a proof.
I noticed this error often appear when antivirus software (Avast) update its bases (automatic).
After update error not appear. Maybe it is coherence with power of CPU (my computer is very old and weak - Sempron 3000 and 1GB RAM).
3. avantbrige.dll error. This is also old bug http://forum.avantbrowser.com/viewtopic.php?f=6&t=32237

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Fix three main bugs

Post by xiaobing » Tue Oct 08, 2013 6:24 am

2. Lilac error (purple screen). It`s very old bug. This post http://forum.avantbrowser.com/viewtopic.php?f=6&t=30703
is a proof.
I noticed this error often appear when antivirus software (Avast) update its bases (automatic).
After update error not appear. Maybe it is coherence with power of CPU (my computer is very old and weak - Sempron 3000 and 1GB RAM).
3. avantbrige.dll error. This is also old bug http://forum.avantbrowser.com/viewtopic.php?f=6&t=32237
Sorry about the inconvenience, but we haven't found the cause of the two problems yet :( .
1. First tab after launch Avant Browser disappear, when I choose item from bookmark (tab disappeared and address bar was empty). Later (after next time choose the same link from bookmarks first tab was open) next tabs have been open normal.
Do you use online storage? Do you use Avant's bookmarks or IE favorties as bookmarks?

wazib
Avant Fanatic
Avant Fanatic
Posts: 314
Joined: Fri Nov 27, 2009 4:23 pm
Windows Version: Win 10 Pro 64
Avant Version: 2017 Ultimate b.7
Default engine: Firefox
IE Version: 11.0
Skin: crystal
Location: Bydgoszcz, Poland

Re: Fix three main bugs

Post by wazib » Tue Oct 08, 2013 12:44 pm

Do you use online storage? Do you use Avant's bookmarks or IE favorties as bookmarks?
Yes, I use online storage. I use Avant's bookmarks not IE favourites (Firefox engine).

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Fix three main bugs

Post by xiaobing » Wed Oct 09, 2013 2:19 am

Do you have the same problem if you don't use online storage?

wazib
Avant Fanatic
Avant Fanatic
Posts: 314
Joined: Fri Nov 27, 2009 4:23 pm
Windows Version: Win 10 Pro 64
Avant Version: 2017 Ultimate b.7
Default engine: Firefox
IE Version: 11.0
Skin: crystal
Location: Bydgoszcz, Poland

Re: Fix three main bugs

Post by wazib » Mon Oct 14, 2013 10:57 pm

Yes is have. Changing account to local storage nothing improve.
Disable all extensions for FireFox also nothing improve.

One thing improve situation is close backup program - % CPU fall down (or other program which overload CPU).

Many times when % CPU if high appears lilac screen of death or avantbrige.dll error

I describe situation:
1. Launch Avant Browser and open 2 tabs with 2 different websites
2. Start program for backup (CPU was ~80%)
3. Now I try to open third
4. After about 20 sec two already opened tabs disappeared

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Fix three main bugs

Post by xiaobing » Tue Oct 15, 2013 1:43 am

What backup program do you use?
No problem if you don't use the backup program?

wazib
Avant Fanatic
Avant Fanatic
Posts: 314
Joined: Fri Nov 27, 2009 4:23 pm
Windows Version: Win 10 Pro 64
Avant Version: 2017 Ultimate b.7
Default engine: Firefox
IE Version: 11.0
Skin: crystal
Location: Bydgoszcz, Poland

Re: Fix three main bugs

Post by wazib » Tue Oct 15, 2013 7:08 am

My backup program is Cobian Backup with zip compression of archive. But it doesn`t matter because the same effect was when I try to save screen to video with "Free Screen to Video" (run program which have high CPU percentage).

Crazy_John
Avant Fanatic
Avant Fanatic
Posts: 398
Joined: Sun Apr 29, 2007 2:13 pm
Windows Version: W10 x64 / W7 x64
Avant Version: Avant Browser 2019 build 2
Default engine: 1ºFirefox \ 2ºChrome
IE Version: 7 and 10 but i never use it
Skin: Xito - old skins

Re: Fix three main bugs

Post by Crazy_John » Tue Oct 15, 2013 2:10 pm

I think the lilac screen showup because the CPU go to 100% (its running other programs + avant also) ,
avant doesn't "wait" that the other programs stop of beeing used by the CPU , and the lilac screen showup .

If the developer could make that avant stop loading pages until the CPU % goes down , maybe avant wouldn't crash... (or other solution...)



I did a test now and got 2 crashs :
•put the CPU compressing a video of 200 MBs to a winrar file (to put the CPU at 100% for 1 minute or 2)
•avant was already opened , write "cars" in a google search page.
•open 6 or 7 pages of the google search in the background (ctrl+click or midle-mouse button)
•Wait some time , avant is trying load the pages but theres no CPU power to do it (one core only) , the winrar compression finish and the lilac screen showup.


I think if this test is done with a multicore CPU , that the problem doesn't happen because it will use other core to run avant (unless that all the cores are beeing used at 100%...)
wazib pc and mine too , they are singlecore CPU's .

wazib
Avant Fanatic
Avant Fanatic
Posts: 314
Joined: Fri Nov 27, 2009 4:23 pm
Windows Version: Win 10 Pro 64
Avant Version: 2017 Ultimate b.7
Default engine: Firefox
IE Version: 11.0
Skin: crystal
Location: Bydgoszcz, Poland

Re: Fix three main bugs

Post by wazib » Thu Oct 17, 2013 10:42 am

I think the lilac screen showup because the CPU go to 100% (its running other programs + avant also) ,
avant doesn't "wait" that the other programs stop of beeing used by the CPU , and the lilac screen showup .
You are right but sometimes this errors (lilac screen, tabs disappear) appear when CPU go much less than 50%.

wazib
Avant Fanatic
Avant Fanatic
Posts: 314
Joined: Fri Nov 27, 2009 4:23 pm
Windows Version: Win 10 Pro 64
Avant Version: 2017 Ultimate b.7
Default engine: Firefox
IE Version: 11.0
Skin: crystal
Location: Bydgoszcz, Poland

Re: Fix three main bugs

Post by wazib » Sun Nov 10, 2013 8:58 am

I changed default rendering engine to Chrome.
After that bugs 1. and 3. (tab disappear, avantbrige.dll error) disappear. Stay only bug 2. (lilac screen) but this error appear about 3 times more often than in Firefox mode (sometime for open 1 website this error appear 3 times). After this error appear I twice click on purple background, screen change colour to white and than after 30 second appear lilac screen again.

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Fix three main bugs

Post by xiaobing » Mon Nov 11, 2013 2:31 am

After this error appear I twice click on purple background, screen change colour to white and than after 30 second appear lilac screen again.
If you restart Avant at this time, will the problem disappear?

wazib
Avant Fanatic
Avant Fanatic
Posts: 314
Joined: Fri Nov 27, 2009 4:23 pm
Windows Version: Win 10 Pro 64
Avant Version: 2017 Ultimate b.7
Default engine: Firefox
IE Version: 11.0
Skin: crystal
Location: Bydgoszcz, Poland

Re: Fix three main bugs

Post by wazib » Tue Nov 19, 2013 4:36 pm

If you restart Avant at this time, will the problem disappear?
It is difficulty to say yes. Because sometime it help, another time this error repeat. Sometime this error disappear but later (after about one hour) appear next time for different website.

Post Reply