Where have all the Favicons gone...?

Please put your bug reports here, and only here.

Moderators: Support Staff², Support Staff, AvantGuard, Developer

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Where have all the Favicons gone...?

Post by xiaobing » Fri Sep 06, 2013 1:53 am

Avant browser options>Exit> is the "website icons"checked?


If you set "prompt to save all opened tabs" When exiting Avant, the following window will pop up when you click the close button:
1.png
1.png (7.7 KiB) Viewed 3736 times
Don't check the option "Erase all browsing trace"

mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: 10
Avant Version: 2015 Ultimate Build 28
Default engine: Gecko (Firefox)
IE Version: 10
Skin: Monai XP
Location: Grass Valley, CA

Re: Where have all the Favicons gone...?

Post by mbrazil » Fri Sep 06, 2013 2:24 am

xiaobing, I think Arandora is referring to the favicons for the Bookmarks and Autofills, not open tabs or Tabs Bar buttons.

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Where have all the Favicons gone...?

Post by xiaobing » Fri Sep 06, 2013 2:47 am

Yes,I know. "Erase all browsing trace" can clear the favicons of bookmarks/autofills.

User avatar
Arandora
Semi-Avantic
Semi-Avantic
Posts: 474
Joined: Sat Aug 09, 2003 10:33 pm
Windows Version: Win 8.1 64 PC/Win 8. 64 laptop
Avant Version: Both AB Lite 2016 v2
Default engine: IE11 Standards
IE Version: IE 11 on PC and laptop
Skin: Aluminium
Location: Poulton-le-Fylde, UK

Re: Where have all the Favicons gone...?

Post by Arandora » Fri Sep 06, 2013 6:27 am

I have the Exit option set to Automatically save all opened tabs, as I always have in all previous AB versions. Does Clicking on the "X" Exit button (top right) act differently than File, Save All Opened Pages and Exit, or File, Exit? as I may use any of these options but mostly I just leave AB and all tabs in use open and use the Windows, Sleep function. The Favicons still are not updated in the Bookmarks list with any option.
Laptop Windows 8.2 64 bit, IE11; PC Win 8.1, IE11. Both AB Lite 2016 b 2 IE Favorites, IE11 Standards rendering engine.

User avatar
Arandora
Semi-Avantic
Semi-Avantic
Posts: 474
Joined: Sat Aug 09, 2003 10:33 pm
Windows Version: Win 8.1 64 PC/Win 8. 64 laptop
Avant Version: Both AB Lite 2016 v2
Default engine: IE11 Standards
IE Version: IE 11 on PC and laptop
Skin: Aluminium
Location: Poulton-le-Fylde, UK

Re: Where have all the Favicons gone...?

Post by Arandora » Mon Sep 09, 2013 9:23 am

Latest position:
Having reloaded the set of bookmarks I've been using to test whether Favicons were first being loaded and second being retained on my laptop, all the pages in my Bookmark folders then had either the generic Favicon or the actual one if the page was for the same website as in the test set. So reloading one page seemed to change all other pages for the same website. I then synced my IE Favourites on my laptop with my PC using Xmarks, and forced Xmarks to overwrite the local bookmarks on my PC, except for a few pages the generic Favicon was attached to all the webpages in my PC bookmark list but none of the actual ones that still remained on my laptop. I then disabled Xmarks and ran AM-Deadlink on my PC which resulted in nearly all the Favicons in the bookmark list disappearing again. So I reloaded Xmarks and forced it to overwrite the local bookmarks again and all the generic Favicons reappeared. Automatic Syncing any changes between laptop and PC updates the bookmarks but not the Favicons.
So I now have a complete set of Favicons on both machines, a mix of actual for those pages, and associated links, that have been reloaded plus generic for the rest on my laptop and mostly generic Favicons on my PC. And there it will remain until hopefully a solution is found and i will not use AM-Deadlink except for identifying duplicates and dead links but not for updating Favicons as that doesn't work.
Laptop Windows 8.2 64 bit, IE11; PC Win 8.1, IE11. Both AB Lite 2016 b 2 IE Favorites, IE11 Standards rendering engine.

User avatar
Arandora
Semi-Avantic
Semi-Avantic
Posts: 474
Joined: Sat Aug 09, 2003 10:33 pm
Windows Version: Win 8.1 64 PC/Win 8. 64 laptop
Avant Version: Both AB Lite 2016 v2
Default engine: IE11 Standards
IE Version: IE 11 on PC and laptop
Skin: Aluminium
Location: Poulton-le-Fylde, UK

Re: Where have all the Favicons gone...?

Post by Arandora » Sat Oct 12, 2013 6:50 am

How do you report Spam on this forum?
Edit - found and reported.
Laptop Windows 8.2 64 bit, IE11; PC Win 8.1, IE11. Both AB Lite 2016 b 2 IE Favorites, IE11 Standards rendering engine.

User avatar
MysteryFCM
Administrator
Administrator
Posts: 7330
Joined: Tue Dec 09, 2003 2:34 am
Windows Version: 10, 8.0, 8.1, 7, Vista, XP
Avant Version: 13.00 Build 23
Default engine: Gecko
IE Version: 7.x, 8.x, 9.x, 10.x, 11.x
Skin: AthenX
Location: Newcastle Upon Tyne, UK
Contact:

Re: Where have all the Favicons gone...?

Post by MysteryFCM » Sat Oct 12, 2013 5:24 pm

Feel free to ping me whenever you see spam as well :)

Den
Semi-Fan
Semi-Fan
Posts: 79
Joined: Thu Mar 18, 2004 11:32 pm
Windows Version: XP HE/Win 7 64/
Avant Version: 2014 built 2
Default engine: IE
IE Version: IE11
Skin: crystal

Re: Where have all the Favicons gone...?

Post by Den » Mon Mar 17, 2014 2:10 pm

Favicons again...

I'm using IE Favorites as Bookmarks. I'm also using the bookmarks bar but the favicons there are generic or blank.

BUT, if I open "Bookmarks/Organise bookmarks/" all the favicons are there: not one missing.

Now how can I correct this problem and get back those favicons on the bookmark bar ? Everything is there but I must be missing something. :problem:

Den

BTW I've deleted the file "favicons.dat" with no success.

User avatar
Arandora
Semi-Avantic
Semi-Avantic
Posts: 474
Joined: Sat Aug 09, 2003 10:33 pm
Windows Version: Win 8.1 64 PC/Win 8. 64 laptop
Avant Version: Both AB Lite 2016 v2
Default engine: IE11 Standards
IE Version: IE 11 on PC and laptop
Skin: Aluminium
Location: Poulton-le-Fylde, UK

Re: Where have all the Favicons gone...?

Post by Arandora » Mon Mar 17, 2014 4:27 pm

No change for me from position as reported in my reply #24. When I open "Bookmarks/Organise bookmarks" all my favourites have the Avant favicon. If I reopen each of my favourites the favicon then appears. So it is a painstaking task to do this for all my favourites. This is made worse when having done that if I clear my cache, all the favicons revert to the generic IE one. This is obviously not on the priority list for investigating and correcting.
Laptop Windows 8.2 64 bit, IE11; PC Win 8.1, IE11. Both AB Lite 2016 b 2 IE Favorites, IE11 Standards rendering engine.

User avatar
Arandora
Semi-Avantic
Semi-Avantic
Posts: 474
Joined: Sat Aug 09, 2003 10:33 pm
Windows Version: Win 8.1 64 PC/Win 8. 64 laptop
Avant Version: Both AB Lite 2016 v2
Default engine: IE11 Standards
IE Version: IE 11 on PC and laptop
Skin: Aluminium
Location: Poulton-le-Fylde, UK

Re: Where have all the Favicons gone...?

Post by Arandora » Mon Apr 07, 2014 9:52 am

Any progress on this please?
Laptop Windows 8.2 64 bit, IE11; PC Win 8.1, IE11. Both AB Lite 2016 b 2 IE Favorites, IE11 Standards rendering engine.

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Where have all the Favicons gone...?

Post by xiaobing » Tue Apr 08, 2014 3:18 am

I have recorded it. The developer will look into it.But I'm not sure whether it can be fixed in later versions.

User avatar
Arandora
Semi-Avantic
Semi-Avantic
Posts: 474
Joined: Sat Aug 09, 2003 10:33 pm
Windows Version: Win 8.1 64 PC/Win 8. 64 laptop
Avant Version: Both AB Lite 2016 v2
Default engine: IE11 Standards
IE Version: IE 11 on PC and laptop
Skin: Aluminium
Location: Poulton-le-Fylde, UK

Re: Where have all the Favicons gone...?

Post by Arandora » Tue Apr 08, 2014 5:27 am

I hope it can
Laptop Windows 8.2 64 bit, IE11; PC Win 8.1, IE11. Both AB Lite 2016 b 2 IE Favorites, IE11 Standards rendering engine.

Den
Semi-Fan
Semi-Fan
Posts: 79
Joined: Thu Mar 18, 2004 11:32 pm
Windows Version: XP HE/Win 7 64/
Avant Version: 2014 built 2
Default engine: IE
IE Version: IE11
Skin: crystal

Re: Where have all the Favicons gone...?

Post by Den » Wed Apr 09, 2014 6:56 am

Just in case this would help explain or find a solution...

I'm using Win7 with AB 2014B2 and IE10.

IE10 : All favicons are present.

AB 2014B2 (in ORGANISE Bookmark) : All favicons are present. *this is strange*

AB 2014B2 (with the Bookmarks Bar) : A few favicons here and there but 90% of recent weebsites have favicons.

AB 2014B2 (Bookmarks from menu) : A few favicons here and there but 90% of recent weebsites have favicons.

Can't understand that all favicons are present in "Bookmarks/Organise Bookmarks" and not in the menu or link bar.

Den

User avatar
Arandora
Semi-Avantic
Semi-Avantic
Posts: 474
Joined: Sat Aug 09, 2003 10:33 pm
Windows Version: Win 8.1 64 PC/Win 8. 64 laptop
Avant Version: Both AB Lite 2016 v2
Default engine: IE11 Standards
IE Version: IE 11 on PC and laptop
Skin: Aluminium
Location: Poulton-le-Fylde, UK

Re: Where have all the Favicons gone...?

Post by Arandora » Wed Apr 09, 2014 7:30 am

A comparison of my position with Den's shows:


Den: I'm using Win7 with AB 2014B2 and IE10.
Me: PC = same, laptop = Win8 with AB 2013 B 120 (reverted from AB 2014 B2 for other reported problem)

Den: IE10 : All favicons are present.
Me: No favicons present on either machine,

Den: AB 2014B2 (in ORGANISE Bookmark) : All favicons are present. *this is strange*
Me: No favicons present on either machine.

Den: AB 2014B2 (with the Bookmarks Bar) : A few favicons here and there but 90% of recent websites have favicons.
Me: Don't usually have Bookmarks bar enabled but when I do they are regularly visited websites so all favicons present on both machines.

Den: AB 2014B2 (Bookmarks from menu) : A few favicons here and there but 90% of recent websites have favicons.
Me: Once a bookmarked site has been visited or refreshed the favicon changes from the generic one to the site specific one. If I completely clear my cache, all favicons revert to generic on both machines.

Den: Can't understand that all favicons are present in "Bookmarks/Organise Bookmarks" and not in the menu or link bar.
Me: Can't understand anything! :thumbdown:
Laptop Windows 8.2 64 bit, IE11; PC Win 8.1, IE11. Both AB Lite 2016 b 2 IE Favorites, IE11 Standards rendering engine.

Den
Semi-Fan
Semi-Fan
Posts: 79
Joined: Thu Mar 18, 2004 11:32 pm
Windows Version: XP HE/Win 7 64/
Avant Version: 2014 built 2
Default engine: IE
IE Version: IE11
Skin: crystal

Re: Where have all the Favicons gone...?

Post by Den » Wed Apr 30, 2014 12:20 pm

trentz566 wrote:we also don't know where all the favicons gones
I just can't believe that everybody on this forum has problems with the favicons. It would show...loud and clear.

So it's the case for only a few individuals maybe less then ten, I would then suggest that we have to find out what's wrong with OUR installation of AB.

Should we do a clean install? I, for exemple, always installed AB on top of the previous one. Is it because we use Win7 64bit or just OS 64bit? What's different in our case. Is it because we use the link bar?

How come, in my case, IE10 shows all favicons and SO DOES AB in "organise Favorites" but not in the favorites themself? I suspect a directory problem but...

Den

User avatar
Arandora
Semi-Avantic
Semi-Avantic
Posts: 474
Joined: Sat Aug 09, 2003 10:33 pm
Windows Version: Win 8.1 64 PC/Win 8. 64 laptop
Avant Version: Both AB Lite 2016 v2
Default engine: IE11 Standards
IE Version: IE 11 on PC and laptop
Skin: Aluminium
Location: Poulton-le-Fylde, UK

Re: Where have all the Favicons gone...?

Post by Arandora » Wed Apr 30, 2014 4:13 pm

Den
I take your points but:
1) Should we do a clean install? I, for example, always installed AB on top of the previous one. Is it because we use Win7 64bit or just OS 64bit? What's different in our case?
- I have tried a clean install on both my laptop running 64 bit Win 8 (now 8.1) and on my PC running 32 bit Win 7 and still same problem and on my previous laptop with 64 bit Win 7 where the problem first started in October 2013.
2) How come, in my case, IE10 shows all Favicons and SO DOES AB in "organise Favorites" but not in the favorites themselves? I suspect a directory problem but...
- that is not the case with me as my Favicons do not appear in IE10 at all when I display IE Favorites nor under Organise Favorites in AB. They just have the generic IE Favicons.
I used to use AM-Deadlink periodically to search for duplicate bookmarks and update my Favicons but when I tried running that it deleted all the site Favicons and replaced them with the generic ones in AB. So I've not tried that again. I have about 200 Favorites folders containing sub-folders with hundreds more individual web pages for that folder/sub-folder. I also have an open list displayed in the Favorites side bar which are my most commonly used ones, some of which are sub-pages of sites in my folders. If I reload these "open" sites the generic Favicon changes to the correct one, as do the other pages for that web site in my folders. When I upgraded to v 2014 all of those Favicons reverted to the generic ones. After refreshing all the open ones again when I reverted to v2013 b120 and did a clean install and reloaded IE Favorites they too had reverted to generic ones. So having refreshed them all once again I do not propose to lose them all again until AB either cures the bug or confirms your theory that it must be just a small number of AB users who are experiencing it and so it must be peculiar to our set ups rather than AB.
Laptop Windows 8.2 64 bit, IE11; PC Win 8.1, IE11. Both AB Lite 2016 b 2 IE Favorites, IE11 Standards rendering engine.

Den
Semi-Fan
Semi-Fan
Posts: 79
Joined: Thu Mar 18, 2004 11:32 pm
Windows Version: XP HE/Win 7 64/
Avant Version: 2014 built 2
Default engine: IE
IE Version: IE11
Skin: crystal

Re: Where have all the Favicons gone...?

Post by Den » Wed Apr 30, 2014 5:33 pm

Very very interesting comments Arandora.

Also had a bad experience with AM-Deadlink; no more for me.

But I'm without words when I compare your experience and mine. Many differences.

I'll keep searching for an answer... :)

Den

Post Reply