Where have all the Favicons gone...?

Please put your bug reports here, and only here.

Moderators: Support Staff², Support Staff, AvantGuard, Developer

User avatar
Victor Delta
Fan
Fan
Posts: 193
Joined: Thu Sep 18, 2003 10:28 pm
Windows Version: Windows 10
Avant Version: Ultimate 2019 b2
Default engine: Firefox
IE Version: IE 11
Skin: Office XP
Location: Poole, UK

Where have all the Favicons gone...?

Post by Victor Delta » Thu May 30, 2013 12:33 pm

I use the 'Use IE Favorites as bookmarks' setting in Avant and, ever since v11.7, I've had minor problems from time to time with favicons (mainly the one where they all disappear following Avant updates).

However, I've now been using v2013/107 for a couple of weeks and none of my favicons are visible, even after revisiting the appropriative website (and even though the favicon appears on the left hand side of the url address box when one does so).

Am I the only person experiencing this or is it a bug?

V

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Where have all the Favicons gone...?

Post by xiaobing » Fri May 31, 2013 3:07 am

favicons are stored in Avant Profiles\.default\favicons.dat
Delete this file and then reopen the pages, will they reappear?

User avatar
Victor Delta
Fan
Fan
Posts: 193
Joined: Thu Sep 18, 2003 10:28 pm
Windows Version: Windows 10
Avant Version: Ultimate 2019 b2
Default engine: Firefox
IE Version: IE 11
Skin: Office XP
Location: Poole, UK

Re: Where have all the Favicons gone...?

Post by Victor Delta » Fri May 31, 2013 8:48 pm

No, they don't reappear. However, some favorites do immediately have a blue globe favicon. I think these are the ones that don't have an individual favicon. I presume you'll know what I mean but I'll attach a picture if you wish...?

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Where have all the Favicons gone...?

Post by xiaobing » Mon Jun 03, 2013 3:36 am

If you open a favorite,can you see the favicon on address bar and tab bar?

User avatar
Victor Delta
Fan
Fan
Posts: 193
Joined: Thu Sep 18, 2003 10:28 pm
Windows Version: Windows 10
Avant Version: Ultimate 2019 b2
Default engine: Firefox
IE Version: IE 11
Skin: Office XP
Location: Poole, UK

Re: Where have all the Favicons gone...?

Post by Victor Delta » Thu Jun 13, 2013 8:12 pm

Yes, they appear correctly just as before. The only place they don't show is in the bookmarks list and bookmarks toolbar.

(PS Welcome back!)

User avatar
Victor Delta
Fan
Fan
Posts: 193
Joined: Thu Sep 18, 2003 10:28 pm
Windows Version: Windows 10
Avant Version: Ultimate 2019 b2
Default engine: Firefox
IE Version: IE 11
Skin: Office XP
Location: Poole, UK

Re: Where have all the Favicons gone...?

Post by Victor Delta » Wed Jul 10, 2013 12:42 pm

Further to the above, I am now running Avant b108 on two pcs - Windows 8 and Windows 7.

The Windows 8 machine is still largely without it's favicons (as described above) but the Windows 7 pc has not lost them.

I'm therefore beginning to wonder if this is just an Avant/Windows 8 problem. Can any other Windows 8 users please comment on whether they have the same issue or not (NB Using the 'Use IE Favorites as bookmarks' setting )?

Thanks.

mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: 10
Avant Version: 2015 Ultimate Build 28
Default engine: Gecko (Firefox)
IE Version: 10
Skin: Monai XP
Location: Grass Valley, CA

Re: Where have all the Favicons gone...?

Post by mbrazil » Wed Jul 10, 2013 10:13 pm

Like the 100+ builds of Avant 2013, Windows 8 is designed primarily for tablet computers and is a very poor fit for desktop and notebook computers. You'd probably be best off in the long run if you remove Windows 8 from that computer and install Windows 7 instead.

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Where have all the Favicons gone...?

Post by xiaobing » Thu Jul 11, 2013 4:55 am

I tried win8 64 bit system. When I click a link, then its favicon appears on both bookmarks list and bookmarks toolbar.

User avatar
Victor Delta
Fan
Fan
Posts: 193
Joined: Thu Sep 18, 2003 10:28 pm
Windows Version: Windows 10
Avant Version: Ultimate 2019 b2
Default engine: Firefox
IE Version: IE 11
Skin: Office XP
Location: Poole, UK

Re: Where have all the Favicons gone...?

Post by Victor Delta » Mon Jul 22, 2013 11:07 am

Slight improvement since changing to build 110. If I save a new bookmark, the favicon appears to be saved with it on the bookmarks list. However, simply visiting the site of an existing bookmark doesn't automatically update/import the favicon as in older versions of Avant (you have to manually save the new bookmark and delete the old one).

Don't suppose there is an automated way of doing this - I have lots of bookmarks!

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Where have all the Favicons gone...?

Post by xiaobing » Tue Jul 23, 2013 2:33 am

Some users cannot change the url of old bookmarks/autofills when update to the new version.
That may be the same kind of problems with yours.
I haven't encountered any one of them. But I have recorded it. Hope the developer can find out the cause and fix it.

User avatar
Arandora
Semi-Avantic
Semi-Avantic
Posts: 474
Joined: Sat Aug 09, 2003 10:33 pm
Windows Version: Win 8.1 64 PC/Win 8. 64 laptop
Avant Version: Both AB Lite 2016 v2
Default engine: IE11 Standards
IE Version: IE 11 on PC and laptop
Skin: Aluminium
Location: Poulton-le-Fylde, UK

Re: Where have all the Favicons gone...?

Post by Arandora » Fri Aug 30, 2013 4:29 pm

I've just upgraded to V 2013 b 113 on both my PC, Win7 32 bit, and my laptop, Win7 64 bit, using IE Favourites but no Favicons showing in Bookmarks list, only the occasional "Globe". I have for a long, long time used AM-Deadlinks to keep my Favourites upto date and to update my Favicons under previous builds. Despite running this and using both options to keep my previous Favicons or overwrite and replace them, it has no effect on the Bookmarks list in IE. All the Favicons show perfectly fine in IE10.
Is anything being done to address this issue? :(
Laptop Windows 8.2 64 bit, IE11; PC Win 8.1, IE11. Both AB Lite 2016 b 2 IE Favorites, IE11 Standards rendering engine.

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Where have all the Favicons gone...?

Post by xiaobing » Mon Sep 02, 2013 2:09 am

To fix the problem, we must remade the problem first. The key is that we cannot reproduce this problem so far no matter what system we use.

User avatar
Arandora
Semi-Avantic
Semi-Avantic
Posts: 474
Joined: Sat Aug 09, 2003 10:33 pm
Windows Version: Win 8.1 64 PC/Win 8. 64 laptop
Avant Version: Both AB Lite 2016 v2
Default engine: IE11 Standards
IE Version: IE 11 on PC and laptop
Skin: Aluminium
Location: Poulton-le-Fylde, UK

Re: Where have all the Favicons gone...?

Post by Arandora » Mon Sep 02, 2013 6:41 am

So let me get this straight. You are saying that if you use the latest AB Version with IE 10 using IE Favourites on a Win 7 machine, Favicons should show against those bookmarks in the Bookmarks list without having to reload every bookmarked page again?
There was no such problem with the old AB versions I used and it would appear with various newer versions since judging by the previous posts on this thread. :?:
Laptop Windows 8.2 64 bit, IE11; PC Win 8.1, IE11. Both AB Lite 2016 b 2 IE Favorites, IE11 Standards rendering engine.

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Where have all the Favicons gone...?

Post by xiaobing » Tue Sep 03, 2013 4:41 am

Arandora wrote:So let me get this straight. You are saying that if you use the latest AB Version with IE 10 using IE Favourites on a Win 7 machine, Favicons should show against those bookmarks in the Bookmarks list without having to reload every bookmarked page again?
Yes. Use IE favorites in build 112 and the favicons are there. Then I download build 113 manually and use cover installation. Open build 113, the favicons are still there.
Arandora wrote:There was no such problem with the old AB versions I used and it would appear with various newer versions since judging by the previous posts on this thread. :?:
The problem in this thread is that the favicons never appear no matter what you do. Since you can still see the favicons after reloading the page, it should be a different one.
Is there the same problem if you don't use AM-Deadlinks? You know the 2013 versions change a lot, is it possible that the AM-Deadlinks is not compatible with Avant now?

I'll try more version and see whether I can remade it.

User avatar
Arandora
Semi-Avantic
Semi-Avantic
Posts: 474
Joined: Sat Aug 09, 2003 10:33 pm
Windows Version: Win 8.1 64 PC/Win 8. 64 laptop
Avant Version: Both AB Lite 2016 v2
Default engine: IE11 Standards
IE Version: IE 11 on PC and laptop
Skin: Aluminium
Location: Poulton-le-Fylde, UK

Re: Where have all the Favicons gone...?

Post by Arandora » Tue Sep 03, 2013 6:10 am

Just to clarify, the Favicons appear on each tab. They do not appear in the IE Favourites (AB Bookmarks) list unless I reload the page and replace the bookmark. Since I have over 2000 bookmarks, to replace them one by one is not practicable. Since I have the same bookmarks on both my laptop (Win 7 Home 64 bit, IE 10) and my PC (Win 7 Pro 32 bit IE 10) that would mean doing the same on both making it doubly impracticable. I keep my bookmarks in sync using Xmarks for IE but that does not keep the Favicons in sync.
I have reloaded a group of bookmarks, some of which previously when I loaded v113 had no Favicons at all. They now all have the correct Favicons in AB but in IE 10 they only have the generic IE 10 Favicon.
Perhaps it is IE 10 and AM-Deadlink is not compatible with it. I'll look for an alternative. Any suggestions anyone? :?:
Laptop Windows 8.2 64 bit, IE11; PC Win 8.1, IE11. Both AB Lite 2016 b 2 IE Favorites, IE11 Standards rendering engine.

User avatar
Victor Delta
Fan
Fan
Posts: 193
Joined: Thu Sep 18, 2003 10:28 pm
Windows Version: Windows 10
Avant Version: Ultimate 2019 b2
Default engine: Firefox
IE Version: IE 11
Skin: Office XP
Location: Poole, UK

Re: Where have all the Favicons gone...?

Post by Victor Delta » Wed Sep 04, 2013 12:31 pm

My situation is pretty similar to Arandora - without the syncing between 2 pcs - and I am using Windows 8, 64 bit. I have also used AM-Deadlink in the past but not found it helpful with this problem.

Den
Semi-Fan
Semi-Fan
Posts: 79
Joined: Thu Mar 18, 2004 11:32 pm
Windows Version: XP HE/Win 7 64/
Avant Version: 2014 built 2
Default engine: IE
IE Version: IE11
Skin: crystal

Re: Where have all the Favicons gone...?

Post by Den » Wed Sep 04, 2013 8:20 pm

I'm using 2013 b113 and no favicons :(

If I run favormaster I can see all favicons :shock:

Den

User avatar
Victor Delta
Fan
Fan
Posts: 193
Joined: Thu Sep 18, 2003 10:28 pm
Windows Version: Windows 10
Avant Version: Ultimate 2019 b2
Default engine: Firefox
IE Version: IE 11
Skin: Office XP
Location: Poole, UK

Re: Where have all the Favicons gone...?

Post by Victor Delta » Wed Sep 04, 2013 10:09 pm

Den wrote:I'm using 2013 b113 and no favicons :(

If I run favormaster I can see all favicons :shock:

Den
What is favormaster? Are you saying it makes all the favicons appear correctly in Avant? And do they remain after favormaster is closed? :?

Den
Semi-Fan
Semi-Fan
Posts: 79
Joined: Thu Mar 18, 2004 11:32 pm
Windows Version: XP HE/Win 7 64/
Avant Version: 2014 built 2
Default engine: IE
IE Version: IE11
Skin: crystal

Re: Where have all the Favicons gone...?

Post by Den » Wed Sep 04, 2013 11:14 pm

[/quote]
What is favormaster? Are you saying it makes all the favicons appear correctly in Avant? And do they remain after favormaster is closed? :?[/quote]

The name is Favorites Management Master; it's a very old program that I still have.

And unfortunately no. All the favicons appear in Favorites Management Master but not in Avant. But it means that all favicons are somewhere on the computer. At this point I don't know how to bring them back in Avant.

Den

User avatar
Arandora
Semi-Avantic
Semi-Avantic
Posts: 474
Joined: Sat Aug 09, 2003 10:33 pm
Windows Version: Win 8.1 64 PC/Win 8. 64 laptop
Avant Version: Both AB Lite 2016 v2
Default engine: IE11 Standards
IE Version: IE 11 on PC and laptop
Skin: Aluminium
Location: Poulton-le-Fylde, UK

Re: Where have all the Favicons gone...?

Post by Arandora » Thu Sep 05, 2013 7:14 am

Yesterday, when I opened my laptop from "sleep" all the Favicons on sites that I had reloaded were still there and in addition there were Favicons, mainly the default Globe plus some for the individual bookmarked links, for every bookmark in all my Bookmark folders, eve though I had done nothing to add these Favicons. I closed AB and shut down my laptop last night instead of putting it to sleep. This morning most of the Favicons that I had updated have reverted to either the default globe or mostly no Favicon at all. Most of my Bookmark folders now contain no Favicons at all.
I step forward, several steps back! #-o
Laptop Windows 8.2 64 bit, IE11; PC Win 8.1, IE11. Both AB Lite 2016 b 2 IE Favorites, IE11 Standards rendering engine.

Post Reply