Avant switches to the IE engine when I use the back button

Please put your bug reports here, and only here.

Moderators: Support Staff², Support Staff, AvantGuard, Developer

Post Reply
mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: 10
Avant Version: 2015 Ultimate Build 28
Default engine: Gecko (Firefox)
IE Version: 10
Skin: Monai XP
Location: Grass Valley, CA

Avant switches to the IE engine when I use the back button

Post by mbrazil » Fri May 10, 2013 8:57 am

Fairly frequently, when I use the back button, Avant uses the IE engine to load the previous page even though my default engine is Firefox. This happens on various websites, and there doesn't appear to be any way to reproduce it at will. There are also no other circumstances that I've been able to identify that contribute to this happening. It seems to be totally random.

User avatar
sulpherdragon
Contributor
Contributor
Posts: 222
Joined: Sat Dec 15, 2007 9:51 pm
Windows Version: Windows 7
Avant Version: 2013 Build 23
Default engine: Firefox
IE Version:
Skin:
Contact:

Re: Avant switches to the IE engine when I use the back butt

Post by sulpherdragon » Fri May 10, 2013 9:16 am

Have you checked these settings?
http://i.imgur.com/eQhcCMT.png

Sometimes if you have a * wildcard in the wrong place Avant doesn't really know what to do and you get different pages running on different renderers.

This hasn't ever happened me :think:
Image

mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: 10
Avant Version: 2015 Ultimate Build 28
Default engine: Gecko (Firefox)
IE Version: 10
Skin: Monai XP
Location: Grass Valley, CA

Re: Avant switches to the IE engine when I use the back butt

Post by mbrazil » Fri May 10, 2013 9:31 am

Yes, I have. That's the first thing I thought of. This is the contents of the rendering engine section in the options:
rendering engine.jpg
rendering engine.jpg (19.47 KiB) Viewed 1325 times
I don't think there are any syntax errors in any of these. The only entry that I think could possibly have side effects is *localhost* which I need for an app that is hosted locally on my PC. Even then, if this or another one of the entries here could cause this to happen, why would it only happen when I use the back button? You'd think it would happen sometimes when pages loaded initially, but it never does. I'd notice it immediately if it did, because the RoboForm toolbar looks very different the way I have it set up with the Firefox engine than the way it looks with the IE engine. That's how I noticed that it is happening with the back button.

Thanks for the suggestion, though. :thumbup:

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Avant switches to the IE engine when I use the back butt

Post by xiaobing » Mon May 13, 2013 2:19 am

I found a similar problem when I testing another bug: http://forum.avantbrowser.com/viewtopic ... 74#p192018

The default engine is firefox. I assign *localhost* with IE engine, When I open this link (http://www.ίδρυματεχνολογίασέρευνασ.gr/) from other application, the link opens with IE engine. And this problem only happens when I have assigned *localhost* with IE engine.

As you said "The only entry that I think could possibly have side effects is *localhost* which I need for an app that is hosted locally on my PC."---- This probably is the cause.

Post Reply