Page 1 of 1

AB 2013 Build 23 totally slooooow and 100%CPU

Posted: Thu Apr 11, 2013 11:39 pm
by lefreak
I'm sorry, but the more development you guys do with Avant Browser, the slower it gets.

Orca was totally fast, Avant 2010 was okay, Avant 2012 was getting slow, and 2013 it's just too much, I think I will change to Firefox, which is lightning fast.

Avantvw.exe takes 30 % and firefox.exe more than 60 % CPU when opening one or two tabs, I have to wait for ages till the sites get created and a lot of times I get the lilac monitor...
Avant.jpg
Avant.jpg (2.66 KiB) Viewed 1409 times
Using Windows XP SP3 (CPU: Athlon XP 2600+)

Less sometimes is more! You should go back to Orca and develop it from the bottom up again...

Just opening new sites takes more than 70% (firefox.exe + Avantvw.exe), opening new tabs is even worse. As you see firefox.exe of Avant is also the process with most memory consumption!
opening new sites.jpg

Re: AB 2013 Build 23 totally slooooow and 100%CPU

Posted: Fri Apr 12, 2013 12:44 am
by Tinman57
I'm on an XP SP3 machine too. With that much CPU time being taken, obviously you have an issue. Before you do anything, see if all of your plugins, including Java, Flash, etc, are up to date. If that don't work you should try disabling your plugins and re-enabling them one at a time to find the culprit. If that's not the problem then you should do a complete re-install of Avant.

Re: AB 2013 Build 23 totally slooooow and 100%CPU

Posted: Fri Apr 12, 2013 3:25 am
by Climhazard
Try downloading a fresh copy of Ultimate USB version and run it (no installation needed).

http://browser.avantforce.com/release/avant.exe

If it works ok then it must be something in your user profile folder, possibly some addon or setting gone wrong. Fixing that 100% CPU usage will probably also fix lilac background crashing. Orca probably has old Firefox engine running so that's why its resource usage may be lower. Firefox 19 still has CPU usage issues usually going up to 15% on single core CPUs, and a little more in avant when idle.

On page load it goes up to 25% on my dual core, which would be more than 50% on old single core. I noticed same behavior in Firefox or Waterfox browsers.

Re: AB 2013 Build 23 totally slooooow and 100%CPU

Posted: Fri Apr 12, 2013 3:03 pm
by Crazy_John
1•What happens if you change the skin of avant from Windows Traditional to Stickers on classic ?

2•What happens if you install IE7 , reboot , and change the skin of avant from Windows Traditional to Stickers on classic ?


I ask this because here in my pc , theres a conflict with avant and IE6 , if i reopen more than 3 pages , the cpu goes to 100% and stays there for 2 or 3 minutes and usually the crash lilac page showup.
I wouldn't mind if avant dont need IE to work (as it is with orca) , i use ff rendering , never use IE or IE rendering.

Also the new skins use less cpu than the old skins , in some pages with scripts , videos...

Try it and see what happen.

You have alot of ff extensions on ? which ones ? try with all extensions off.