Flash Blocker Not Working

Please put your bug reports here, and only here.

Moderators: Support Staff², Support Staff, AvantGuard, Developer

Post Reply
User avatar
Tinman57
Avantic
Avantic
Posts: 834
Joined: Tue Oct 13, 2009 2:26 am
Windows Version: Linux Ubuntu 13.10
Avant Version: Linux Firefox
Default engine: Linux Firefox
IE Version: N/A
Skin: N/A
Location: TEXAS

Flash Blocker Not Working

Post by Tinman57 » Sat Mar 16, 2013 12:42 am

Tonight I went to this website: http://www.equities.com/news/headline-s ... =material and the flash movie started playing even though I have the Disable Flash Animations turned on.
((((TINMAN))))
----------------------------------------------------------
(Duck! It's another MicroSoft Patch!)

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Flash Blocker Not Working

Post by xiaobing » Mon Mar 18, 2013 2:24 am

The video is blocked here.Try the option "disable videos".

User avatar
Tinman57
Avantic
Avantic
Posts: 834
Joined: Tue Oct 13, 2009 2:26 am
Windows Version: Linux Ubuntu 13.10
Avant Version: Linux Firefox
Default engine: Linux Firefox
IE Version: N/A
Skin: N/A
Location: TEXAS

Re: Flash Blocker Not Working

Post by Tinman57 » Mon Mar 18, 2013 11:25 pm

xiaobing wrote:The video is blocked here.Try the option "disable videos".
Why don't Avant have a "Disable Video" button along with the Disable Flash and Block Ads buttons?
((((TINMAN))))
----------------------------------------------------------
(Duck! It's another MicroSoft Patch!)

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Flash Blocker Not Working

Post by xiaobing » Tue Mar 19, 2013 2:29 am

I have recorded it as a request.

darth
AvantGuard
AvantGuard
Posts: 970
Joined: Mon Jun 11, 2007 9:16 pm
Windows Version: Windows 7
Avant Version: Avant 11_0 Build 46
Default engine: trident
IE Version: 10
Skin: default

Re: Flash Blocker Not Working

Post by darth » Tue Mar 19, 2013 1:23 pm

html5 no flash video maybe tinman. zdnet, etc sites has quite bit

on html5 which is on the scene. Will adobe flash go away. I doubt

not for a long long time.
Dell Precision 360 Work Staton XP 32/64 bits

User avatar
Tinman57
Avantic
Avantic
Posts: 834
Joined: Tue Oct 13, 2009 2:26 am
Windows Version: Linux Ubuntu 13.10
Avant Version: Linux Firefox
Default engine: Linux Firefox
IE Version: N/A
Skin: N/A
Location: TEXAS

Re: Flash Blocker Not Working

Post by Tinman57 » Wed Apr 17, 2013 9:03 pm

Even with both Disable Flash Animations and Disable Video's, I still have instances where flash ads with load and play.
((((TINMAN))))
----------------------------------------------------------
(Duck! It's another MicroSoft Patch!)

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Flash Blocker Not Working

Post by xiaobing » Thu Apr 18, 2013 2:12 am

Tinman57 wrote:Even with both Disable Flash Animations and Disable Video's, I still have instances where flash ads with load and play.
Can you give me a test link?

User avatar
Tinman57
Avantic
Avantic
Posts: 834
Joined: Tue Oct 13, 2009 2:26 am
Windows Version: Linux Ubuntu 13.10
Avant Version: Linux Firefox
Default engine: Linux Firefox
IE Version: N/A
Skin: N/A
Location: TEXAS

Re: Flash Blocker Not Working

Post by Tinman57 » Fri Apr 19, 2013 12:38 am

xiaobing wrote:
Tinman57 wrote:Even with both Disable Flash Animations and Disable Video's, I still have instances where flash ads with load and play.
Can you give me a test link?
Geeze, I've slept since then. Next time it happens I'll send a link...
((((TINMAN))))
----------------------------------------------------------
(Duck! It's another MicroSoft Patch!)

User avatar
DutchGemini
Avant Fanatic
Avant Fanatic
Posts: 354
Joined: Wed Jan 28, 2004 8:10 am
Windows Version: 2000, XP, Vista, 7 (32/64bit)
Avant Version: Always the Latest
Default engine: Chromium
IE Version: 11.0.9600.18282
Skin: Aluminum
Location: Lake Maggiore - Italy, just below the Swiss border

Re: Flash Blocker Not Working

Post by DutchGemini » Thu Jan 23, 2014 2:59 pm

Flash blocker not working, at least with Chrome engine and AB 2013b 119

Disabled flash in Avant (menu and toolbar show this), every page loads flash and happily plays this.

Want an example? http://www.ad.nl/

Please advise.

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Flash Blocker Not Working

Post by xiaobing » Fri Jan 24, 2014 2:01 am

http://www.ad.nl/ad/nl/1036/Showbizz/vi ... aten.dhtml This video for example. With the option "disable flash animation" checked, the video just show black. If I uncheck the option, the video loads correctly.
I tried it with 2014 build 1/chrome engine.

Are you sure the videos that work are played with flash player not html5?

User avatar
DutchGemini
Avant Fanatic
Avant Fanatic
Posts: 354
Joined: Wed Jan 28, 2004 8:10 am
Windows Version: 2000, XP, Vista, 7 (32/64bit)
Avant Version: Always the Latest
Default engine: Chromium
IE Version: 11.0.9600.18282
Skin: Aluminum
Location: Lake Maggiore - Italy, just below the Swiss border

Re: Flash Blocker Not Working

Post by DutchGemini » Fri Jan 24, 2014 8:54 am

The clip in the centre of the screen at the particular link does indeed not play, just like YouTube does not. When I opened the link there were 2 flash animations at the right and at the top that played without problem. The attached image also shows this, on the main page of AD.NL.

It may be that these animations are embedded or pushed by another website and thus not intercepted, but nevertheless they are flash files and play regardless of the settings.

There are many sites where flash ads pop up out of the blue and start yelling through my speakers (Vodafone is such example) and I'm really getting p!ssed off about those intrusive ads. Blocking flash would help not loosing my temper. If it worked.

Dutch
Attachments
FlashNotBlocked.png
Flash Playing while blocked by AB

Crazy_John
Avant Fanatic
Avant Fanatic
Posts: 398
Joined: Sun Apr 29, 2007 2:13 pm
Windows Version: W10 x64 / W7 x64
Avant Version: Avant Browser 2019 build 2
Default engine: 1ºFirefox \ 2ºChrome
IE Version: 7 and 10 but i never use it
Skin: Xito - old skins

Re: Flash Blocker Not Working

Post by Crazy_John » Fri Jan 24, 2014 8:14 pm

Here in my pc , that flash ad is blocked by avant if that option is checked (but then all flashs are completly blocked) , not sure why is not blocked in your pc .

Other way to block that flash is use the addon Flashblock . (this is what i use . A button showup in all flashs just in case i want play that video) .
https://addons.mozilla.org/en-US/firefo ... lashblock/

Other way also is use the addon addblock plus .
https://addons.mozilla.org/en-US/firefo ... lock-plus/

(i use both) .

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Flash Blocker Not Working

Post by xiaobing » Sun Jan 26, 2014 2:07 am

DutchGemini wrote:The clip in the centre of the screen at the particular link does indeed not play, just like YouTube does not. When I opened the link there were 2 flash animations at the right and at the top that played without problem. The attached image also shows this, on the main page of AD.NL.

It may be that these animations are embedded or pushed by another website and thus not intercepted, but nevertheless they are flash files and play regardless of the settings.

There are many sites where flash ads pop up out of the blue and start yelling through my speakers (Vodafone is such example) and I'm really getting p!ssed off about those intrusive ads. Blocking flash would help not loosing my temper. If it worked.

Dutch
The problem has been recorded.

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Flash Blocker Not Working

Post by xiaobing » Thu Mar 06, 2014 9:34 am

Try 2014 build 2

User avatar
DutchGemini
Avant Fanatic
Avant Fanatic
Posts: 354
Joined: Wed Jan 28, 2004 8:10 am
Windows Version: 2000, XP, Vista, 7 (32/64bit)
Avant Version: Always the Latest
Default engine: Chromium
IE Version: 11.0.9600.18282
Skin: Aluminum
Location: Lake Maggiore - Italy, just below the Swiss border

Re: Flash Blocker Not Working

Post by DutchGemini » Mon Mar 10, 2014 8:46 am

Build 2 did seem to have solved the issue, in fact I could see "movie not loaded" when right-clicking on the place holder.

However, after the initial enthusiasm, I must say it does not, or at least it does not look like it. See image for details, taken just minutes ago on http://www.corriere.it.
FlashNotBeingBlocked.png
Corriere.IT - Flash not being blocked
I have noted that many flash clips turn alive again and this is usually after an auto-refresh induced by the script in the page (I have auto-refresh turned off).

I also see that the flash blocking does not always work on the first attempts, that is, option/button enabled and page refreshed manually, likely because many of the page contents is taken from cache where it is still available. In the above image, many refresh with flash blocking turned on continue to show the clip

Dutch

User avatar
DutchGemini
Avant Fanatic
Avant Fanatic
Posts: 354
Joined: Wed Jan 28, 2004 8:10 am
Windows Version: 2000, XP, Vista, 7 (32/64bit)
Avant Version: Always the Latest
Default engine: Chromium
IE Version: 11.0.9600.18282
Skin: Aluminum
Location: Lake Maggiore - Italy, just below the Swiss border

Re: Flash Blocker Not Working

Post by DutchGemini » Mon Oct 27, 2014 2:13 pm

Flash blocking is not working any more, button pressed on toolbar, many flash animations running and Chrome Plug-in Shockwave Flash eating 126Mb of memory and constantly active. Either web sites have become smarter or AB has lost IQ. Please advise.

User avatar
DutchGemini
Avant Fanatic
Avant Fanatic
Posts: 354
Joined: Wed Jan 28, 2004 8:10 am
Windows Version: 2000, XP, Vista, 7 (32/64bit)
Avant Version: Always the Latest
Default engine: Chromium
IE Version: 11.0.9600.18282
Skin: Aluminum
Location: Lake Maggiore - Italy, just below the Swiss border

Re: Flash Blocker Not Working

Post by DutchGemini » Mon Oct 27, 2014 2:20 pm

Actually it appears that Chrome does not obey to the Flash blocker, I have switched many tabs to FF and until now no flash is playing.

User avatar
DutchGemini
Avant Fanatic
Avant Fanatic
Posts: 354
Joined: Wed Jan 28, 2004 8:10 am
Windows Version: 2000, XP, Vista, 7 (32/64bit)
Avant Version: Always the Latest
Default engine: Chromium
IE Version: 11.0.9600.18282
Skin: Aluminum
Location: Lake Maggiore - Italy, just below the Swiss border

Re: Flash Blocker Not Working

Post by DutchGemini » Mon Oct 27, 2014 3:13 pm

Sorry, I want to recall ... also with FF and flash blocked the flash player plugin is running happily.

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Flash Blocker Not Working

Post by xiaobing » Tue Oct 28, 2014 2:43 am

DutchGemini wrote:Flash blocking is not working any more, button pressed on toolbar, many flash animations running and Chrome Plug-in Shockwave Flash eating 126Mb of memory and constantly active. Either web sites have become smarter or AB has lost IQ. Please advise.
Recorded.

Post Reply