[Firefox engine] Specific sites perform very slowly

Please put your bug reports here, and only here.

Moderators: Support Staff², Support Staff, AvantGuard, Developer

Post Reply
Kryz
Semi-Fan
Semi-Fan
Posts: 52
Joined: Sat Dec 23, 2006 11:57 pm
Windows Version: 7 Ultimate SP1 64bit
Avant Version: Ultimate 2014 build 2
Default engine: Firefox
IE Version: 10.0.9200.16635 64bit
Skin: Aero Glass

[Firefox engine] Specific sites perform very slowly

Post by Kryz » Tue Jan 22, 2013 10:57 am

The following sites perform very poorly when opened in a tab using the Firefox engine:

- www.nu.nl
- www.webwereld.nl

When these sites are opened, the tab gets very slow in performance. This means scrolling is very difficult (moves in "chunks" instead of fluently), mouse-over on links responds slowly (takes a while before a link becomes underlined) and clicking a link is slow. When navigating deeper into these websites, the problem often disappears. I have the strong impression a specific ad-script is what's slowing the tab down.

Some other details:

- Switching to any of the other engines (IE Compatible, IE9 Standards, Chrome) fixes the problem
- It does not happen 100% of the time, but more than 50%
- This happens on both PC's I use (one desktop, one laptop)
- I have not tested with a "regular" Firefox browser, since it's not installed on both machines
- The tab does not slow the rest of the browser down; other tabs work normally
- In some instances a script error is shown with the choice to stop "a script" or not; whether you answer yes or no, the tab stops responding completely after that; I haven't registered which script this was

AbelAbel
Avant Fanatic
Avant Fanatic
Posts: 368
Joined: Thu Oct 20, 2011 8:11 am
Windows Version: win7
Avant Version: 2012 beta 8
IE Version: ie9

Re: [Firefox engine] Specific sites perform very slowly

Post by AbelAbel » Thu Jan 24, 2013 1:39 am

You can assign the two sites with chrome/IE engines: Tools>Avant browser options>Rendering engine>Add>Http sites.

Kryz
Semi-Fan
Semi-Fan
Posts: 52
Joined: Sat Dec 23, 2006 11:57 pm
Windows Version: 7 Ultimate SP1 64bit
Avant Version: Ultimate 2014 build 2
Default engine: Firefox
IE Version: 10.0.9200.16635 64bit
Skin: Aero Glass

Re: [Firefox engine] Specific sites perform very slowly

Post by Kryz » Mon Feb 11, 2013 10:44 am

That would be a work-around, yes. Sadly, also those engines seem to be performing less and less with those sites.

I'd like to get a response from someone who can tell if this can be reproduced and will be worked on, because more and more sites seem to be creating this problem for me. This is one of those issues that if it takes too long, I need to get rid of Avant altogether, because it becomes unusable.

real name
Avant Fanatic
Avant Fanatic
Posts: 221
Joined: Thu Aug 05, 2004 8:43 am
Windows Version: win7 64bit(office),32bit(home)
Avant Version: 2013 beta 12
IE Version: N/A

Re: [Firefox engine] Specific sites perform very slowly

Post by real name » Mon Feb 11, 2013 1:08 pm

just FYI: I'm not able to reproduce your problem
(does it improve when you disable something in Tools menu?)

Post Reply