Mozilla FireFox Connection Settings (still) not saved.

Please put your bug reports here, and only here.

Moderators: Support Staff², Support Staff, AvantGuard, Developer

Post Reply
MrZapper61
Newbie
Newbie
Posts: 31
Joined: Sat May 14, 2011 11:43 pm
Windows Version: Windows 10 Enterprise (x64)
Avant Version: Ultimate 2016 Build 5
Default engine: IE11 Standards
IE Version: 11.0.10240.16724
Skin: Tristan
Location: Netherlands

Mozilla FireFox Connection Settings (still) not saved.

Post by MrZapper61 » Fri May 11, 2012 10:13 am

Hi,
am using the laest 169 build with Windows 7 64bit & still can not save Mozilla FireFox Connection Settings.
After setting it the configuration is lost, even in the same AvantBrowser session when changing tabs!

Did see several time that this issue is supposed to be solved, but looks like the problem is still there.
As a result of (trying) to correct this the generic AvantBrowser proxy settings, normal setting is "Internet Explorer Settings, get changed after trying to set Mozilla FireFox Connection Settings.
Due to this Avantbrowser has to be restarted, since setting it back requires restart.

Since I am using rendering engine selection for a couple of websites the above renders it useless at the office.
At home there is no problem because I have direct connection and all engines work correct with AvantBrowser proxy setting at "Internet Explorer Settings".
But at work internet is provided through a proxy which is handled correctly bij IE engines, because they integrate correct with IE "Automatic detect Settings" in connection/Local Area Network settings panel.
Since the settings in Mozilla & Google are not saved correct both engines, and sites which should be opened with them, are not working at work.

Hope to see solution to above problem soon.

Regards,
MrZapper61.

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Mozilla FireFox Connection Settings (still) not saved.

Post by xiaobing » Mon May 14, 2012 1:41 am

am using the laest 169 build with Windows 7 64bit & still can not save Mozilla FireFox Connection Settings.
After setting it the configuration is lost, even in the same AvantBrowser session when changing tabs!
Where did you set it?
You should set it in Tools>Proxy>customise... not in Tools>mozilla firefox>options>Advanced>Networks>connection directly.
The proxy settings in Avant will apply to the connection settings in firefox engine.

MrZapper61
Newbie
Newbie
Posts: 31
Joined: Sat May 14, 2011 11:43 pm
Windows Version: Windows 10 Enterprise (x64)
Avant Version: Ultimate 2016 Build 5
Default engine: IE11 Standards
IE Version: 11.0.10240.16724
Skin: Tristan
Location: Netherlands

Re: Mozilla FireFox Connection Settings (still) not saved.

Post by MrZapper61 » Mon May 14, 2012 2:08 pm

Hi,
Have set Connection settings it in Tools>mozilla firefox>options>Advanced>Networks>connection directly.

The problem with setting it in Tools>Proxy>customise is that the option "Internet Explorer Settings" is not available when Mozilla Firefox rendering engine is selected. (This explains why the previous set "Internet Explorer Settings" is lost when Mozilla Firefox is selected, this is also mentioned in my bug explanation.)

The obvious place to set network settings for mozilla Firefox should be under "Mozilla Firefox>options>Network settings".
The setting in Tools>Proxy>customise is a gobal (override) setting, in my opinion.

MrZapper61.

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Mozilla FireFox Connection Settings (still) not saved.

Post by xiaobing » Tue May 15, 2012 2:26 am

The problem with setting it in Tools>Proxy>customise is that the option "Internet Explorer Settings" is not available when Mozilla Firefox rendering engine is selected. (This explains why the previous set "Internet Explorer Settings" is lost when Mozilla Firefox is selected, this is also mentioned in my bug explanation.)
Which version of Avant browser do you use? 2011 beta 15?
We have removed the option "Internet Explorer Settings" in the latest version:
1.jpg
The obvious place to set network settings for mozilla Firefox should be under "Mozilla Firefox>options>Network settings".
The setting in Tools>Proxy>customise is a gobal (override) setting, in my opinion.
What you said is a good idea IMP. But currently,the only option to set proxy is Tools>Proxy>customise,the proxy settings under each rendering engine are unavailable in Avant.

MrZapper61
Newbie
Newbie
Posts: 31
Joined: Sat May 14, 2011 11:43 pm
Windows Version: Windows 10 Enterprise (x64)
Avant Version: Ultimate 2016 Build 5
Default engine: IE11 Standards
IE Version: 11.0.10240.16724
Skin: Tristan
Location: Netherlands

Re: Mozilla FireFox Connection Settings (still) not saved.

Post by MrZapper61 » Tue May 15, 2012 8:30 am

Currently using the latest Avant Browser 2012 Build 169.

User avatar
brawnymike
Avant Fanatic
Avant Fanatic
Posts: 362
Joined: Thu Jun 17, 2010 10:17 pm
Windows Version: 7 (32 bit)
Avant Version: Ult 2013 bld 23
Default engine: Firefox
IE Version: 10
Skin: Aero Glass
Location: Los Angeles, CA

Re: Mozilla FireFox Connection Settings (still) not saved.

Post by brawnymike » Tue May 15, 2012 8:37 pm

In AB 2012 build 169:

If you are seeing the menu item "Internet Explorer Setting" (under Tools > Proxy) then you are viewing the current tab in one of the IE rendering modes. In Mozilla rendering mode, the item "Internet Explorer Setting" does not appear in the Tools>Proxy menu.

User avatar
kudos
Support Staff²
Support Staff²
Posts: 3384
Joined: Wed Mar 22, 2006 10:35 am
Avant Version:

Re: Mozilla FireFox Connection Settings (still) not saved.

Post by kudos » Tue May 15, 2012 9:43 pm

Try the FoxyProxy extension. It works very well with Avant when in the Firefox rendering mode. It also adds an icon to the addons bar to quickly switch between proxies. There are other extensions that do a similar job too.
 
.:Volunteer support staff (regular user):.
Image
I am not a member of the Avant / Orca development team
Please search this forum / the Wiki before posting questions
Forum Rules | Frequently Asked Questions | Active Topics

MrZapper61
Newbie
Newbie
Posts: 31
Joined: Sat May 14, 2011 11:43 pm
Windows Version: Windows 10 Enterprise (x64)
Avant Version: Ultimate 2016 Build 5
Default engine: IE11 Standards
IE Version: 11.0.10240.16724
Skin: Tristan
Location: Netherlands

Re: Mozilla FireFox Connection Settings (still) not saved.

Post by MrZapper61 » Wed May 16, 2012 9:49 am

I would rather have this handled by AvantBrowser then (separate) Mozilla Firefox pluging.
From multiple tabs opening & tripple browser integration point of view the central configuration has te advantage that it follows settings set in AvantBrowser.

If i wanted to set connection settings in several different browser than Avantbrowser would not be needed, in my opinion.
In my perception the drive for me to use AvantBowser is the central & uniform configuration and presentation of webpages, with the benefit of auto selection of browser engine based on web pages.

Thanks for the alternative suggestion though.

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Mozilla FireFox Connection Settings (still) not saved.

Post by xiaobing » Thu May 17, 2012 1:40 am

We will consider your suggestion.

Jasmine
Support Staff
Support Staff
Posts: 3118
Joined: Mon Dec 11, 2006 2:10 am
Windows Version: windows sp3 2003 vista win7
Avant Version: Latest release
IE Version: IE9 8 7
Location: Beijing China

Re: Mozilla FireFox Connection Settings (still) not saved.

Post by Jasmine » Thu May 17, 2012 3:14 am

MrZapper61 wrote:Hi,
The obvious place to set network settings for mozilla Firefox should be under "Mozilla Firefox>options>Network settings".
The setting in Tools>Proxy>customise is a gobal (override) setting, in my opinion.

MrZapper61.
So you check this option in firefox rendering mode?
Tools->Mozilla Firefox->Options->Advanced->Netword->Settings->Auto-detect proxy settings for this network
MrZapper61 wrote:Hi,
The setting in Tools>Proxy>customise is a gobal (override) setting, in my opinion.
You don't want to make it a global setting? You only want to make it recognize the settings of each rendering mode?
Image
Please provide the following information before reporting problems:
Avant Version; System(also point out it is a 32 or 64-bit OS);IE; Memory Size; CPU Speed;
Optional: Firewall; Graphics Card

For the problems hard to replay, could you add me into your MSN or Skype list if you use either of them? The advantage is that you can let us know the situation in the first place by making some screenshots, sharing your screen or explaining the specific problems more clearly when they happen.
E-mail: Jasmine#avantbrowser.com(please repalce # with @)
MSN: dishmoon#msn.com
Skype: JasmineThunder

MrZapper61
Newbie
Newbie
Posts: 31
Joined: Sat May 14, 2011 11:43 pm
Windows Version: Windows 10 Enterprise (x64)
Avant Version: Ultimate 2016 Build 5
Default engine: IE11 Standards
IE Version: 11.0.10240.16724
Skin: Tristan
Location: Netherlands

Re: Mozilla FireFox Connection Settings (still) not saved.

Post by MrZapper61 » Thu May 17, 2012 10:24 am

To be able to use automatic webpage based rendering engines the (global) setting in "Tools->Proxy->Internet Explorer Settings" should be available & apply to all available rendering engines, including Firefox Mozilla.

Currently if Mozilla FireFox is selected as rendering engine, as default or through "Tools->Avant Browser Options->Rendering Engine" the option "Tools->Proxy->Internet Explorer Settings" is not available any more.

As mentioned before, because of automatic proxy detection at the office I have to set the Internet Explorer setting to "Internet Options->Connections->LAN Settings->Automatic Detect Settings".
This way I am able to use Avant Browser at home & office, as long as the settings in AVant Browser are set to "Tools->Proxy->Internet Explorer Settings". This works good for the IE rendering engine in Avant Browser at home & office.

But when I select another rendering engine, because of automatic website preference, it's not working at the office. This is because at the office the proxy setting is handled by the IE setting. Since the "Tools->Proxy->Internet Explorer Settings" is not available in the other rendering engines it's not working.

So basicle the solution to problem is to make the "Tools->Proxy->Internet Explorer Settings" be available in all rendering engine and let it overrule the local setting in the rendering engine setting in "Tools->Mozilla Firefox->Options->Connection Settings".
If this is not possible then the option in the individual rendering engine should be saved. Currently the "use internet explorer proxy setting" option in "Tools->Mozilla Firefox->Options->Connection Settings" is not saved.

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Mozilla FireFox Connection Settings (still) not saved.

Post by xiaobing » Fri May 18, 2012 1:50 am

So basicle the solution to problem is to make the "Tools->Proxy->Internet Explorer Settings" be available in all rendering engine and let it overrule the local setting in the rendering engine setting in "Tools->Mozilla Firefox->Options->Connection Settings".
If this is not possible then the option in the individual rendering engine should be saved. Currently the "use internet explorer proxy setting" option in "Tools->Mozilla Firefox->Options->Connection Settings" is not saved.
Recorded

Post Reply