Focus Problem

Please put your bug reports here, and only here.

Moderators: Support Staff², Support Staff, AvantGuard, Developer

User avatar
Tinman57
Avantic
Avantic
Posts: 834
Joined: Tue Oct 13, 2009 2:26 am
Windows Version: Linux Ubuntu 13.10
Avant Version: Linux Firefox
Default engine: Linux Firefox
IE Version: N/A
Skin: N/A
Location: TEXAS

Focus Problem

Post by Tinman57 » Sun Nov 13, 2011 1:16 am

I've experienced a different kind of focus problem in the last 3 versions of AB. I'm using 2012 b7 now and still have the problem. From time to time whenever AB is running, I can't select options in other windows and can't copy & paste in Outlook Express. When this happens I can't go very far in the Start menu. For instance, I click on the Start button (XP SP3), the start menu appears, then click on "All Programs", window appears, then when I select anything else at this point the window opens in the background.

When trying to copy/paste something in OE it goes like this; Select text with LMB, use RMB and select Copy, switch over to the new email, RMC to select Paste, soon as I RMC I'm instantly switched back to the email I was copying from.

In OE, when I click on the In-box icon to select another folder (like out-box), the menu drops down and disappears. No matter how many times I click it, it will drop down and then disappear.

Sometimes I can switch over to AB, double LMC on the display area, and that will temperarily solve the problem. But most of the time I have to exit AB to be able to do these task...
((((TINMAN))))
----------------------------------------------------------
(Duck! It's another MicroSoft Patch!)

nir
Newbie
Newbie
Posts: 36
Joined: Sun Nov 28, 2010 6:14 am
Windows Version: win 7 pro 32 sp1 (HEB)
Avant Version: 2013 b1
IE Version: 10

Re: Focus Problem

Post by nir » Mon Nov 14, 2011 6:26 am

dont get your hopes high...

http://forum.avantbrowser.com/viewtopic.php?f=6&t=30568

the bug is very old, very similar to the one I have described.

Nikata
Fan
Fan
Posts: 147
Joined: Fri May 20, 2011 2:16 am
Windows Version: XP SP3
Avant Version: 2010 build 16
IE Version: 8

Re: Focus Problem

Post by Nikata » Mon Nov 14, 2011 3:26 pm

Seems there are many users who have focus problem. But I believe that Avant team will try their best to solve our problems.Come on!

nir
Newbie
Newbie
Posts: 36
Joined: Sun Nov 28, 2010 6:14 am
Windows Version: win 7 pro 32 sp1 (HEB)
Avant Version: 2013 b1
IE Version: 10

Re: Focus Problem

Post by nir » Tue Nov 15, 2011 5:30 am

nikata: note that I have reported this bug on november, of 2010....

AbelAbel
Avant Fanatic
Avant Fanatic
Posts: 368
Joined: Thu Oct 20, 2011 8:11 am
Windows Version: win7
Avant Version: 2012 beta 8
IE Version: ie9

Re: Focus Problem

Post by AbelAbel » Tue Nov 15, 2011 8:23 am

This problem happens sporadically since pages are put into separate processes. Sometimes I can't type into other applications. Closing avant can resolve the problem.

User avatar
AEN007
Semi-Fan
Semi-Fan
Posts: 70
Joined: Tue Nov 15, 2011 4:47 pm
Windows Version: XP
Avant Version: latest/current USB v
IE Version: 6 (won't up to 8)

Re: Focus Problem

Post by AEN007 » Tue Nov 15, 2011 8:39 pm

15November2011

Greetings.

I have had AvB (portable) on my USB stick(s) for a year or so but
never had too much occassion to use AvB until the recent 2012 release(s) with Gecko!
I didn't like having IE7 on my XP laptops, so I reverted to IE6 years ago.
I had AvB on my stick(s) to render IE6 in a tabbed GUI.

I think this Gecko feature is great.
This dual rendering AvB works much better than Lunascape did/does.
Luna does triple rendering but uses its own Chome engine
instead of the open source Chromium (which Google uses ...).
The Luna Chome engine was too primitive.

Anyway, AvB should fix this focus problem.
I use AutoHotKey which utilizes the AutoIT3 WindowSpy.
Anyone could use the WSpy to see what happens when AvB loses focus.

AvB has already fixed numerous bugs in AvB2012.
It seems to me this focus bug should be a top priority for AvB ...

nir
Newbie
Newbie
Posts: 36
Joined: Sun Nov 28, 2010 6:14 am
Windows Version: win 7 pro 32 sp1 (HEB)
Avant Version: 2013 b1
IE Version: 10

Re: Focus Problem

Post by nir » Wed Nov 16, 2011 4:53 am

like !

Julien90
Fan
Fan
Posts: 146
Joined: Thu Oct 20, 2011 8:33 am
Windows Version: win7 32 bit/IE9 xp pro
Avant Version: 2012 beta 8
IE Version: ie9

Re: Focus Problem

Post by Julien90 » Wed Nov 16, 2011 1:44 pm

Is there any improvement of focus problem in build 8? :wtf:

nir
Newbie
Newbie
Posts: 36
Joined: Sun Nov 28, 2010 6:14 am
Windows Version: win 7 pro 32 sp1 (HEB)
Avant Version: 2013 b1
IE Version: 10

Re: Focus Problem

Post by nir » Wed Nov 16, 2011 3:48 pm

no

User avatar
Tinman57
Avantic
Avantic
Posts: 834
Joined: Tue Oct 13, 2009 2:26 am
Windows Version: Linux Ubuntu 13.10
Avant Version: Linux Firefox
Default engine: Linux Firefox
IE Version: N/A
Skin: N/A
Location: TEXAS

Re: Focus Problem

Post by Tinman57 » Mon Feb 13, 2012 2:22 am

Something that I have noticed about this problem of losing focus in other windows/apps when AB is running; If I leave a blank page open, then there's no focus problems. If I close out all AB tabs, then sooner or later the focus problem comes back.

Hope this helps in some small way.....
((((TINMAN))))
----------------------------------------------------------
(Duck! It's another MicroSoft Patch!)

User avatar
Tinman57
Avantic
Avantic
Posts: 834
Joined: Tue Oct 13, 2009 2:26 am
Windows Version: Linux Ubuntu 13.10
Avant Version: Linux Firefox
Default engine: Linux Firefox
IE Version: N/A
Skin: N/A
Location: TEXAS

Re: Focus Problem

Post by Tinman57 » Mon Feb 13, 2012 2:22 am

Something that I have noticed about this problem of losing focus in other windows/apps when AB is running; If I leave a blank page open, then there's no focus problems. If I close out all AB tabs, then sooner or later the focus problem comes back.

Hope this helps in some small way.....
((((TINMAN))))
----------------------------------------------------------
(Duck! It's another MicroSoft Patch!)

nir
Newbie
Newbie
Posts: 36
Joined: Sun Nov 28, 2010 6:14 am
Windows Version: win 7 pro 32 sp1 (HEB)
Avant Version: 2013 b1
IE Version: 10

Re: Focus Problem

Post by nir » Mon Feb 13, 2012 5:57 am

Something that I have noticed about this problem of losing focus in other windows/apps when AB is running: AVANT team is not responding....

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4380
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Focus Problem

Post by xiaobing » Mon Feb 13, 2012 6:13 am

Tinman57 wrote:Something that I have noticed about this problem of losing focus in other windows/apps when AB is running; If I leave a blank page open, then there's no focus problems. If I close out all AB tabs, then sooner or later the focus problem comes back.

Hope this helps in some small way.....
Thanks for your information.
The focus problem just happens very sporadically ,it's hard to reproduce it. Anyway,we will try to fix it in next versions.

Jasmine
Support Staff
Support Staff
Posts: 3118
Joined: Mon Dec 11, 2006 2:10 am
Windows Version: windows sp3 2003 vista win7
Avant Version: Latest release
IE Version: IE9 8 7
Location: Beijing China

Re: Focus Problem

Post by Jasmine » Tue Feb 14, 2012 4:17 am

Could you descirbe the steps to replay the losing focus issue?
Are there the steps with which you can always reproduce it ?
Image
Please provide the following information before reporting problems:
Avant Version; System(also point out it is a 32 or 64-bit OS);IE; Memory Size; CPU Speed;
Optional: Firewall; Graphics Card

For the problems hard to replay, could you add me into your MSN or Skype list if you use either of them? The advantage is that you can let us know the situation in the first place by making some screenshots, sharing your screen or explaining the specific problems more clearly when they happen.
E-mail: Jasmine#avantbrowser.com(please repalce # with @)
MSN: dishmoon#msn.com
Skype: JasmineThunder

User avatar
Tinman57
Avantic
Avantic
Posts: 834
Joined: Tue Oct 13, 2009 2:26 am
Windows Version: Linux Ubuntu 13.10
Avant Version: Linux Firefox
Default engine: Linux Firefox
IE Version: N/A
Skin: N/A
Location: TEXAS

Re: Focus Problem

Post by Tinman57 » Wed Feb 15, 2012 10:38 pm

Jasmine wrote:Could you descirbe the steps to replay the losing focus issue?
Are there the steps with which you can always reproduce it ?
I already posted it long ago, on Nov 12, 11
((((TINMAN))))
----------------------------------------------------------
(Duck! It's another MicroSoft Patch!)

Jasmine
Support Staff
Support Staff
Posts: 3118
Joined: Mon Dec 11, 2006 2:10 am
Windows Version: windows sp3 2003 vista win7
Avant Version: Latest release
IE Version: IE9 8 7
Location: Beijing China

Re: Focus Problem

Post by Jasmine » Thu Feb 16, 2012 4:12 am

Tinman57 wrote:Something that I have noticed about this problem of losing focus in other windows/apps when AB is running; If I leave a blank page open, then there's no focus problems. If I close out all AB tabs, then sooner or later the focus problem comes back.

Hope this helps in some small way.....
Ok sorry. Could we go over again this problem in latest avant browser 2012 pre-alpha 119?
Download:
http://dl.filekicker.com/send/file/1422 ... abbeta.exe

Does it only happen under the condition that no tab exits in avant browser?
It's the same whether you set ie or firefox or chrome as the default rendering engine?
Image
Please provide the following information before reporting problems:
Avant Version; System(also point out it is a 32 or 64-bit OS);IE; Memory Size; CPU Speed;
Optional: Firewall; Graphics Card

For the problems hard to replay, could you add me into your MSN or Skype list if you use either of them? The advantage is that you can let us know the situation in the first place by making some screenshots, sharing your screen or explaining the specific problems more clearly when they happen.
E-mail: Jasmine#avantbrowser.com(please repalce # with @)
MSN: dishmoon#msn.com
Skype: JasmineThunder

User avatar
Tinman57
Avantic
Avantic
Posts: 834
Joined: Tue Oct 13, 2009 2:26 am
Windows Version: Linux Ubuntu 13.10
Avant Version: Linux Firefox
Default engine: Linux Firefox
IE Version: N/A
Skin: N/A
Location: TEXAS

Re: Focus Problem

Post by Tinman57 » Fri Feb 17, 2012 1:33 am

Jasmine wrote: Ok sorry. Could we go over again this problem in latest avant browser 2012 pre-alpha 119?
Download:
http://dl.filekicker.com/send/file/1422 ... abbeta.exe

Does it only happen under the condition that no tab exits in avant browser?
It's the same whether you set ie or firefox or chrome as the default rendering engine?
Yes, it ONLY HAPPENS when AB IS RUNNING and there are NO TABS OPEN. I'm now using AB Ultimate 2012 build 21 with IE as the rendering engine and IE STANDARDS on XP SP3. I've NEVER tried it using Firefox or Chrome, I don't use either of those....
((((TINMAN))))
----------------------------------------------------------
(Duck! It's another MicroSoft Patch!)

nir
Newbie
Newbie
Posts: 36
Joined: Sun Nov 28, 2010 6:14 am
Windows Version: win 7 pro 32 sp1 (HEB)
Avant Version: 2013 b1
IE Version: 10

Re: Focus Problem

Post by nir » Fri Feb 17, 2012 6:47 am

i'm using pre alpha 119 on win 7 pro 32 bit, latest updates, ie9 - same problem.

as i noted before - it happens only if im using office vba.

User avatar
AEN007
Semi-Fan
Semi-Fan
Posts: 70
Joined: Tue Nov 15, 2011 4:47 pm
Windows Version: XP
Avant Version: latest/current USB v
IE Version: 6 (won't up to 8)

Re: Focus Problem

Post by AEN007 » Wed Jun 06, 2012 7:49 pm

6June2012

This focus problem remains as annoying as ever ... really reflects poorly on AvB.
xiaobing wrote:The focus problem just happens very sporadically ,it's hard to reproduce it.
Anyway,we will try to fix it in next versions.
1. Something I suspect contributes to the focus problem is»
AEN007 wrote:24November2011
Greetings.
Nikata wrote:
AEN007 wrote:It seems to me the focus bug should be a top priority for AvB ...
This problem just happens very accidentally,
I guess it's just difficult to capture it for the developer :think:
Hope they will fix it ASAP
It happens all the time. It happened even before AvB2012.
It loses focus to no other window, however. I've seen the active window go from AvB to no window.
That is, the active window has no title, no class, no text & no associated process ...

The main Avant.exe window is class:TfrmBrowserMDIMain.Avant.UnicodeClass.
Inside that is class:MDIClient. There is also the Avant.exe window class:TApplication.
I've seen exes that have the TApplication & the main GUI.
I suspect the problem is because AvB has the MDIClient window inside the separate main GUI
2. I suspect what I will call the "GUI ALT-TAB" problem undermines the "sporadically"/"accidentally" excuses.

When a app/util is ACTIVE & the user does ALT-TAB (A-T),
the A-T popup opens with the A-T "selection box" focused on the next item in the Windows "z-order".
Windows for AlwaysOnTop (AOT) app/utils are always placed at the beginning (even when minimized) of the A-T popup.

However, when AvB is active & the user does ALT-TAB,
the A-T popup opens with the A-T "selection box" focused on the first item in the A-T popup -
which will be windows (if any of AOT apps/utils).
This is not "proper" behavior.
I suspect the MDIClient not the main GUI (TfrmBrowserMDIMain.Avant.UnicodeClass) causes this.
Windows displays the main AvB GUI not MDIClient in the A-T popup,
so the A-T "selection box" does NOT behave properly
because the focus is shifting from a window NOT in the A-T popup.

Also, if AvB is active, and I do ALT-TAB but do not bring another app/util info focus and
(re)select AvB with the A-T "selection box", the AvB GUI exhibits another focus problem.
The cursor focus is lost.
The only way I can restore the cursor focus is to either
click with the mouse where the cursor focus was
(which is annoying & not an ergonomic thing to (have to) do over & over) or
do CTRL-TAB & then CTRL-SHIFT-TAB to change the active AvB tab & then change it back -
which of course is not an option if/when there is only 1 AvB tab open...

AbelAbel
Avant Fanatic
Avant Fanatic
Posts: 368
Joined: Thu Oct 20, 2011 8:11 am
Windows Version: win7
Avant Version: 2012 beta 8
IE Version: ie9

Re: Focus Problem

Post by AbelAbel » Thu Jun 07, 2012 2:09 am

They said this problem cannot be fixed here: http://forum.avantforce.com/viewtopic.p ... a8#p183164

Post Reply