[recorded]Tab dragging not working well in 2012 A6

Please put your bug reports here, and only here.

Moderators: Support Staff², Support Staff, AvantGuard, Developer

Post Reply
mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: 10
Avant Version: 2015 Ultimate Build 28
Default engine: Gecko (Firefox)
IE Version: 10
Skin: Monai XP
Location: Grass Valley, CA

[recorded]Tab dragging not working well in 2012 A6

Post by mbrazil » Thu Sep 22, 2011 8:27 pm

About half the time I try to drag a tab to another position in the bar, I never get the little icon, and the vertical indicator bar between other tabs that indicates where the tab will be dropped never appears.
Last edited by Jasmine on Mon Sep 26, 2011 7:00 am, edited 1 time in total.
Reason: unfocused tab can be moved around in 11.7.46

Nikata
Fan
Fan
Posts: 147
Joined: Fri May 20, 2011 2:16 am
Windows Version: XP SP3
Avant Version: 2010 build 16
IE Version: 8

Re: Tab dragging not working well in 2012 A6

Post by Nikata » Fri Sep 23, 2011 2:07 am

You can detach the tab first and then drag it to the place you want it to be in tab bar.

mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: 10
Avant Version: 2015 Ultimate Build 28
Default engine: Gecko (Firefox)
IE Version: 10
Skin: Monai XP
Location: Grass Valley, CA

Re: Tab dragging not working well in 2012 A6

Post by mbrazil » Fri Sep 23, 2011 2:33 am

More trouble than it's worth. Usually, the tab will drag properly on the second or third attempt, which is easier than detaching the tab and then trying to get the tab window in the right place in the tab bar.

Nikata
Fan
Fan
Posts: 147
Joined: Fri May 20, 2011 2:16 am
Windows Version: XP SP3
Avant Version: 2010 build 16
IE Version: 8

Re: Tab dragging not working well in 2012 A6

Post by Nikata » Fri Sep 23, 2011 2:38 am

Seems it only works when the tab you want to drag gets focus

orrange
Newbie
Newbie
Posts: 15
Joined: Tue Sep 06, 2011 6:16 am
Windows Version: XP
Avant Version: 2012 alpha 1
IE Version: 8

Re: Tab dragging not working well in 2012 A6

Post by orrange » Fri Sep 23, 2011 8:19 am

mbrazil wrote:More trouble than it's worth. Usually, the tab will drag properly on the second or third attempt, which is easier than detaching the tab and then trying to get the tab window in the right place in the tab bar.
Only the blue tab button can move. Before switching to the tab you can't move it around.

mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: 10
Avant Version: 2015 Ultimate Build 28
Default engine: Gecko (Firefox)
IE Version: 10
Skin: Monai XP
Location: Grass Valley, CA

Re: Tab dragging not working well in 2012 A6

Post by mbrazil » Fri Sep 23, 2011 5:06 pm

orrange wrote:Only the blue tab button can move. Before switching to the tab you can't move it around.

This is apparently true. It never used to be that way, and frankly, if that's by design, I think it sucks big time. All tab buttons should be able to be dragged at any time regardless of which one has the focus.

I also noticed that sometimes when you attempt to drag a button that doesn't have the focus, you'll get the drag icon and see the black bar between the tabs as you're moving the mouse, but when you release the mouse button nothing happens. This is definitely a bug.

mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: 10
Avant Version: 2015 Ultimate Build 28
Default engine: Gecko (Firefox)
IE Version: 10
Skin: Monai XP
Location: Grass Valley, CA

Re: [recorded]Tab dragging not working well in 2012 A6

Post by mbrazil » Sat Oct 15, 2011 6:55 am

Tab dragging works correctly in b8.

Post Reply