[fixed]2011 build 16 - Bug with Adobe Reader

Please put your bug reports here, and only here.

[fixed]2011 build 16 - Bug with Adobe Reader

Postby Lowestoft » Thu May 19, 2011 6:51 am

Hi,
There is a bug with Adobe Reader 9.4.4
When I open a PDF in Avant Browser 2011 build 16 the mouse scrolling doesn't work. The same pdf document opened directly in Adobe Reader works fine!

Best regards.
Last edited by Jasmine on Fri May 27, 2011 4:37 am, edited 3 times in total.
Reason: v2011 build 16;[fix]v2011 build 17
Lowestoft
Offline
Newbie
Newbie
 
Posts: 19
Joined: Sat Feb 12, 2005 10:13 am
Avant Version:
Top

Re: 2011 build 16 - Bug with Adobe Reader

Post Reply #1 by xiaobing » Thu May 19, 2011 9:58 am

Recorded.
xiaobing
User avatar
Offline
Support Staff
Support Staff
Avant Guru
 
Posts: 3741
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas
Top

Re: [fixed]2011 build 16 - Bug with Adobe Reader

Post Reply #2 by DutchGemini » Wed Jun 01, 2011 12:11 pm

Amongst other things, also "Find" in the PDF does not work, the focus moves constantly away from the "Find" box on the reader's toolbar. Very annoying.

Dutch
DutchGemini
User avatar
Offline
Avant Fanatic
Avant Fanatic
 
Posts: 296
Joined: Wed Jan 28, 2004 8:10 am
Location: Lake Maggiore - Italy, just below the Swiss border
Windows Version: 2000, XP, Vista, 7 (32/64bit)
Avant Version: Always the Latest
IE Version: 8.0.6001.18702
Top

Re: [fixed]2011 build 16 - Bug with Adobe Reader

Post Reply #3 by xiaobing » Thu Jun 02, 2011 2:45 am

DutchGemini wrote:Amongst other things, also "Find" in the PDF does not work, the focus moves constantly away from the "Find" box on the reader's toolbar. Very annoying.

Dutch

Are you using 2011 build 18?
xiaobing
User avatar
Offline
Support Staff
Support Staff
Avant Guru
 
Posts: 3741
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas
Top

Re: [fixed]2011 build 16 - Bug with Adobe Reader

Post Reply #4 by DutchGemini » Thu Jun 09, 2011 7:45 am

No I wasn't, just upgraded this morning, now it seems to work, though I need to click *twice* in the Find box if AB does not have the focus (I work on multiple screens and AB is sitting on screen #3) because of the "Focus bug" that continues to persist in AB.

Dutch
DutchGemini
User avatar
Offline
Avant Fanatic
Avant Fanatic
 
Posts: 296
Joined: Wed Jan 28, 2004 8:10 am
Location: Lake Maggiore - Italy, just below the Swiss border
Windows Version: 2000, XP, Vista, 7 (32/64bit)
Avant Version: Always the Latest
IE Version: 8.0.6001.18702
Top

Re: [fixed]2011 build 16 - Bug with Adobe Reader

Post Reply #5 by Jasmine » Wed Jun 15, 2011 8:34 am

DutchGemini wrote:No I wasn't, just upgraded this morning, now it seems to work, though I need to click *twice* in the Find box if AB does not have the focus (I work on multiple screens and AB is sitting on screen #3) because of the "Focus bug" that continues to persist in AB.

Dutch


What's the focus bug? Video downloader opens on wrong screen?
Image
Please provide the following information before reporting problems:
Avant Version; System(also point out it is a 32 or 64-bit OS);IE; Memory Size; CPU Speed;
Optional: Firewall; Graphics Card

For the problems hard to replay, could you add me into your MSN or Skype list if you use either of them? The advantage is that you can let us know the situation in the first place by making some screenshots, sharing your screen or explaining the specific problems more clearly when they happen.
E-mail: Jasmine#avantbrowser.com(please repalce # with @)
MSN: dishmoon#msn.com
Skype: JasmineThunder
Jasmine
User avatar
Offline
Support Staff
Support Staff
Avant Guru
 
Posts: 3118
Joined: Mon Dec 11, 2006 2:10 am
Location: Beijing China
Windows Version: windows sp3 2003 vista win7
Avant Version: Latest release
IE Version: IE9 8 7
Top

Re: [fixed]2011 build 16 - Bug with Adobe Reader

Post Reply #6 by DutchGemini » Thu Jun 16, 2011 1:01 pm

The "focus bug" is about having to click twice (or even more) on the place you want to be in AB when coming from another application, for instance you need to click twice in the address bar, twice in the search bar, twice on a tab, twice *in* a page, twice on the scrollbars, etc. before AB moves the focus there where you clicked initially. Most of these issues have been solved, but once in a while AB still does not properly set the focus to the active object when before clicking it was not your active application.

To the problem: in Adobe's PDF reader there is a "Find" box. Well, when AB is not the active application and you are viewing a PDF and you want to search text, when you click for the first time *in* the Find box to move the focus nothing happens, then you click a second time in the same box upon which AB makes this the active object and now you can type the string you're looking for.

Dutch
DutchGemini
User avatar
Offline
Avant Fanatic
Avant Fanatic
 
Posts: 296
Joined: Wed Jan 28, 2004 8:10 am
Location: Lake Maggiore - Italy, just below the Swiss border
Windows Version: 2000, XP, Vista, 7 (32/64bit)
Avant Version: Always the Latest
IE Version: 8.0.6001.18702
Top

Re: [fixed]2011 build 16 - Bug with Adobe Reader

Post Reply #7 by Jasmine » Fri Jun 17, 2011 7:22 am

DutchGemini wrote:The "focus bug" is about having to click twice (or even more) on the place you want to be in AB when coming from another application, for instance you need to click twice in the address bar, twice in the search bar, twice on a tab, twice *in* a page, twice on the scrollbars, etc. before AB moves the focus there where you clicked initially. Most of these issues have been solved, but once in a while AB still does not properly set the focus to the active object when before clicking it was not your active application.
Dutch


Do you mean for example you have to click the address bar twice before being able to input url inside? It happens one in a while? You are not sure when that appears?
Image
Please provide the following information before reporting problems:
Avant Version; System(also point out it is a 32 or 64-bit OS);IE; Memory Size; CPU Speed;
Optional: Firewall; Graphics Card

For the problems hard to replay, could you add me into your MSN or Skype list if you use either of them? The advantage is that you can let us know the situation in the first place by making some screenshots, sharing your screen or explaining the specific problems more clearly when they happen.
E-mail: Jasmine#avantbrowser.com(please repalce # with @)
MSN: dishmoon#msn.com
Skype: JasmineThunder
Jasmine
User avatar
Offline
Support Staff
Support Staff
Avant Guru
 
Posts: 3118
Joined: Mon Dec 11, 2006 2:10 am
Location: Beijing China
Windows Version: windows sp3 2003 vista win7
Avant Version: Latest release
IE Version: IE9 8 7
Top

Re: [fixed]2011 build 16 - Bug with Adobe Reader

Post Reply #8 by Jasmine » Fri Jun 17, 2011 7:46 am

DutchGemini wrote:To the problem: in Adobe's PDF reader there is a "Find" box. Well, when AB is not the active application and you are viewing a PDF and you want to search text, when you click for the first time *in* the Find box to move the focus nothing happens, then you click a second time in the same box upon which AB makes this the active object and now you can type the string you're looking for.

Dutch

Confirmed
Image
Please provide the following information before reporting problems:
Avant Version; System(also point out it is a 32 or 64-bit OS);IE; Memory Size; CPU Speed;
Optional: Firewall; Graphics Card

For the problems hard to replay, could you add me into your MSN or Skype list if you use either of them? The advantage is that you can let us know the situation in the first place by making some screenshots, sharing your screen or explaining the specific problems more clearly when they happen.
E-mail: Jasmine#avantbrowser.com(please repalce # with @)
MSN: dishmoon#msn.com
Skype: JasmineThunder
Jasmine
User avatar
Offline
Support Staff
Support Staff
Avant Guru
 
Posts: 3118
Joined: Mon Dec 11, 2006 2:10 am
Location: Beijing China
Windows Version: windows sp3 2003 vista win7
Avant Version: Latest release
IE Version: IE9 8 7
Top

Re: [fixed]2011 build 16 - Bug with Adobe Reader

Post Reply #9 by DutchGemini » Fri Jun 17, 2011 10:17 am

Jasmine wrote:Do you mean for example you have to click the address bar twice before being able to input url inside? It happens one in a while? You are not sure when that appears?


I almost always happens when coming from another application that has focus while AB has not (so you can't use Alt-Tab, Taskbar clicks, etc., to switch to AB).

For instance here is a very common situation :

    AB is open and visible
    you are entering data on a form in AB
    you go to Word (or e-mail app where some relevant data is stored) and select-copy or read a string
    you click in the edit field on the tab's page shown AB and press either [Ctrl-V] or start typing

At that point you will notice that nothing happens. Although the cursor blinks in AB, the focus is somewhere else. After clicking for the second time in the edit field, whatever combination of keys that produces characters ([Ctrl+V], typing, etc.) will indeed cause characters to appear. This is also the case for the "Search Bar".

Funny enough it just happened to me while AB was the indeed the active app. To understand what the name of the "Search Bar" was, while I was typing this reply I right-clicked on the toolbar area but then I clicked on the menu bar and went to View->Toolbars and then back to my text. The cursor was showing but I could not type anything. I had to click again before control was given to the editor for me to type. Although not persistent, 1 out of 3 it does.

Try this one out: (quick) reply to this memo; while the focus is in the editor, from the menu bar click View to show the view pulldown menu; click again on View to make it disappear; click in the reply text; start typing. If not immediately, you may need to repeat this a few time, all your keystrokes are "lost" and no text will appear.

Dutch
DutchGemini
User avatar
Offline
Avant Fanatic
Avant Fanatic
 
Posts: 296
Joined: Wed Jan 28, 2004 8:10 am
Location: Lake Maggiore - Italy, just below the Swiss border
Windows Version: 2000, XP, Vista, 7 (32/64bit)
Avant Version: Always the Latest
IE Version: 8.0.6001.18702
Top


Return to Avant Browser Bug Reports



Who is online

Users browsing this forum: No registered users

ABPro style designed by Statm1