Unable to install plugin via the aba:// protocol.

Please put your bug reports here, and only here.

Moderators: Support Staff², Support Staff, Developer, AvantGuard

User avatar
sulpherdragon
Contributor
Contributor
Posts: 222
Joined: Sat Dec 15, 2007 9:51 pm
Windows Version: Windows 7
Avant Version: 2013 Build 23
Default engine: Firefox
IE Version:
Skin:
Contact:

Unable to install plugin via the aba:// protocol.

Postby sulpherdragon » Tue Aug 07, 2012 5:17 pm

I've recently made a large update to a plugin of mine.

I've posted it here, but it wont install automatically like all the others.

viewtopic.php?f=58&t=28523&p=185982#p185982

I can only assume it's due to the size of the plugin, its now 800KB.

Can anyone else try this out and confirm if it's an issue, or point out something that I might be doing wrong? It works fine if you import it manually.

Thank you.
Image

User avatar
mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: XP Pro SP3 x86 + all updates
Avant Version: 2013 Ultimate Build 23 & Build 115 (USB)
Default engine: Gecko (Firefox)
IE Version: IE8 + all patches and updates
Skin: Monai XP
Location: Grass Valley, CA

Re: Unable to install plugin via the aba:// protocol.

Postby mbrazil » Tue Aug 07, 2012 9:22 pm

sulpherdragon wrote:Can anyone else try this out and confirm if it's an issue

I tried the install and had the same results you described. I had to download it and import it manually.

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4039
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Unable to install plugin via the aba:// protocol.

Postby xiaobing » Wed Aug 08, 2012 2:28 am

That's strange, I can auto install it(using IE engine)
Click this link "Download Latest Version: Multitool V0.7f"
Then it adds itself to the "avant add-ons" panel automatically.

User avatar
mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: XP Pro SP3 x86 + all updates
Avant Version: 2013 Ultimate Build 23 & Build 115 (USB)
Default engine: Gecko (Firefox)
IE Version: IE8 + all patches and updates
Skin: Monai XP
Location: Grass Valley, CA

Re: Unable to install plugin via the aba:// protocol.

Postby mbrazil » Wed Aug 08, 2012 3:03 am

xiaobing wrote:That's strange, I can auto install it(using IE engine)
Click this link "Download Latest Version: Multitool V0.7f"
Then it adds itself to the "avant add-ons" panel automatically.

I tried it with the IE engine, and it did download and install properly. With the Firefox engine, the download seems to stop shortly after the download activity dialog appears, but there is nothing to indicate whether or not the download completed, and it does not get installed. I don't think the download actually starts.

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4039
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Unable to install plugin via the aba:// protocol.

Postby xiaobing » Wed Aug 08, 2012 3:52 am

With the Firefox engine, the download seems to stop shortly after the download activity dialog appears, but there is nothing to indicate whether or not the download completed, and it does not get installed. I don't think the download actually starts.

Yes, both fireofox engine and chrome engine have the same problem.
Is this a Avant bug? I'm not sure...

User avatar
mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: XP Pro SP3 x86 + all updates
Avant Version: 2013 Ultimate Build 23 & Build 115 (USB)
Default engine: Gecko (Firefox)
IE Version: IE8 + all patches and updates
Skin: Monai XP
Location: Grass Valley, CA

Re: Unable to install plugin via the aba:// protocol.

Postby mbrazil » Wed Aug 08, 2012 4:14 am

xiaobing wrote:
Yes, both fireofox engine and chrome engine have the same problem.
Is this a Avant bug? I'm not sure...

Isn't the aba:// protocol proprietary to Avant? If so, it seems as though the problem would have to be fixed in Avant, since Google and Mozilla are unlikely to be willing to do anything about it.

AbelAbel
Avant Fanatic
Avant Fanatic
Posts: 368
Joined: Thu Oct 20, 2011 8:11 am
Windows Version: win7
Avant Version: 2012 beta 8
IE Version: ie9

Re: Unable to install plugin via the aba:// protocol.

Postby AbelAbel » Wed Aug 08, 2012 6:11 am

Isn't the aba add-ons designed for IE egnine only?

User avatar
sulpherdragon
Contributor
Contributor
Posts: 222
Joined: Sat Dec 15, 2007 9:51 pm
Windows Version: Windows 7
Avant Version: 2013 Build 23
Default engine: Firefox
IE Version:
Skin:
Contact:

Re: Unable to install plugin via the aba:// protocol.

Postby sulpherdragon » Wed Aug 08, 2012 10:05 am

I think its definitely, a bug. If it weren't, then it should not say its installing a plugin at all.
I think this is just a small oversight when AB became a tri-engine browser.

AbelAbel wrote:Isn't the aba add-ons designed for IE egnine only?

No, the plugins can work with FF and Chrome as long as the javascript is written in a compatible format, the plugin I linked was designed for FF engine only and it works well with it. So I think it's fair to assume that the aba:// protocol is supposed to work no matter what engine you have it set to.
Image

User avatar
mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: XP Pro SP3 x86 + all updates
Avant Version: 2013 Ultimate Build 23 & Build 115 (USB)
Default engine: Gecko (Firefox)
IE Version: IE8 + all patches and updates
Skin: Monai XP
Location: Grass Valley, CA

Re: Unable to install plugin via the aba:// protocol.

Postby mbrazil » Wed Aug 08, 2012 6:02 pm

Once it's installed, the Multitool add-on works fine with all three engines.

Very nice update, sulpherdragon. I really like the new features.

User avatar
sulpherdragon
Contributor
Contributor
Posts: 222
Joined: Sat Dec 15, 2007 9:51 pm
Windows Version: Windows 7
Avant Version: 2013 Build 23
Default engine: Firefox
IE Version:
Skin:
Contact:

Re: Unable to install plugin via the aba:// protocol.

Postby sulpherdragon » Wed Aug 08, 2012 10:57 pm

mbrazil wrote:Once it's installed, the Multitool add-on works fine with all three engines.

Well it seems to work somewhat in IE, but it's only appearing correctly in Firefox, and it sort of looks fine in Chrome too.
mbrazil wrote:Very nice update, sulpherdragon. I really like the new features.

Thanks, this version went through a massive overhaul. Thank you for your support :)
Image

User avatar
mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: XP Pro SP3 x86 + all updates
Avant Version: 2013 Ultimate Build 23 & Build 115 (USB)
Default engine: Gecko (Firefox)
IE Version: IE8 + all patches and updates
Skin: Monai XP
Location: Grass Valley, CA

Re: Unable to install plugin via the aba:// protocol.

Postby mbrazil » Thu Aug 09, 2012 12:08 am

sulpherdragon wrote:
mbrazil wrote:Well it seems to work somewhat in IE, but it's only appearing correctly in Firefox, and it sort of looks fine in Chrome too.


I spoke to soon. Now it doesn't work for me in IE or Chrome, but it still works fine in Firefox. Since Firefox is my default engine, that's not a problem for me.

User avatar
xiaobing
Support Staff
Support Staff
Posts: 4039
Joined: Wed Apr 22, 2009 1:52 am
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas

Re: Unable to install plugin via the aba:// protocol.

Postby xiaobing » Thu Aug 09, 2012 2:56 am

Recorded


Return to “Avant Browser Bug Reports”

Who is online

Users browsing this forum: No registered users

cron