Avant Browser

Avant Browser community forum
It is currently Wed Nov 26, 2014 5:10 am

All times are UTC




Post new topic Reply to topic  [ 14 posts ] 
Author Message
 Post subject: Wrong Tooltips
Poston: Mon Jul 09, 2012 11:54 am 
Offline
Newbie
Newbie

Joined: Sat Jun 16, 2012 7:14 am
Posts: 29
Windows Version: 7
Avant Version: 2012 Build 173
IE Version: 9
Hi..

I've found that wrong tooltips appears when mouse over the online storage icon, ect.. (as screenshot of objects in the red cyrcle I sent you along this post).

The tooltips seems right in the fullscreen mode, but there's no tooltips when mouse over the "Close current tab"

You can check them one by one by moving the mouse over each object in the red cyrcle

Please fix the problem

Best Regards,
Herman Semm


Attachments:
File comment: Wrong Tooltips
WrongTT.jpg
WrongTT.jpg [ 17.43 KiB | Viewed 507 times ]
Top
 Profile  
 
 Post subject: Re: Wrong Tooltips
Post Reply #1 on: Tue Jul 10, 2012 1:58 am 
Offline
Support Staff
Support Staff
Avant Guru
User avatar

Joined: Wed Apr 22, 2009 1:52 am
Posts: 3917
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas
Quote:
I've found that wrong tooltips appears when mouse over the online storage icon, ect.. (as screenshot of objects in the red cyrcle I sent you along this post).

There isn't any tooltip when I hover my mouse on the main menu and the six buttons on the right.
Can you still see the wrong tooltip if you restart Avant?

Quote:
The tooltips seems right in the fullscreen mode, but there's no tooltips when mouse over the "Close current tab"

Yea, I can confirm this one.


Top
 Profile  
 
 Post subject: Re: Wrong Tooltips
Post Reply #2 on: Tue Jul 10, 2012 2:17 am 
Offline
Newbie
Newbie

Joined: Sat Jun 16, 2012 7:14 am
Posts: 29
Windows Version: 7
Avant Version: 2012 Build 173
IE Version: 9
yes I still see the wrong tooltip after restart Avant or even I restrart the computer

I think you should add tooltips on the normal main menu same as in fullscreen mode


Top
 Profile  
 
 Post subject: Re: Wrong Tooltips
Post Reply #3 on: Tue Jul 10, 2012 2:31 am 
Offline
Support Staff
Support Staff
Avant Guru
User avatar

Joined: Wed Apr 22, 2009 1:52 am
Posts: 3917
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas
Do you have this page opened (viewforum.php?f=6) when you have the wrong tooltip?
What will happen if you close the page?


Top
 Profile  
 
 Post subject: Re: Wrong Tooltips
Post Reply #4 on: Tue Jul 10, 2012 2:44 am 
Offline
AvantGuard
AvantGuard
Avantic Elite
User avatar

Joined: Tue Jul 26, 2005 10:04 pm
Posts: 1965
Location: Grass Valley, CA
Windows Version: XP Pro SP3 x86 + all updates
Avant Version: 2013 Ultimate Build 23 & Build 115 (USB)
Default engine: Gecko (Firefox)
IE Version: IE8 + all patches and updates
Skin: Monai XP
xiaobing wrote:
There isn't any tooltip when I hover my mouse on the main menu and the six buttons on the right.

He's talking about the Online Storage icon/button to the left of the Menu bar (in the upper-left corner below the Avant logo in the title bar).

When I hover my mouse cursor over the Online Storage button, I get the following tooltip, which seems correct: Connected to Online Storage.


Top
 Profile  
 
 Post subject: Re: Wrong Tooltips
Post Reply #5 on: Tue Jul 10, 2012 3:25 am 
Offline
Newbie
Newbie

Joined: Sat Jun 16, 2012 7:14 am
Posts: 29
Windows Version: 7
Avant Version: 2012 Build 173
IE Version: 9
I have the wrong tooltip at every webpage I visited, not only at viewforum.php?f=6 (this only one example)

I've observed that the text(words) appears as the wrong tooltips as the same as text of every Title of webpages I visited
The wrong tooltips appears when hover my mouse on every object in the red cyrcle (see the screenshot). And I think because of in normal menu there're no tooltips (for objects in the red cyrcle) then they use the title of current webpage as tooltip

Anyway I think you should add tooltips on the normal main menu same as in fullscreen mode, it may fix the problem


Top
 Profile  
 
 Post subject: Re: Wrong Tooltips
Post Reply #6 on: Tue Jul 10, 2012 4:43 am 
Offline
AvantGuard
AvantGuard
Avantic Elite
User avatar

Joined: Tue Jul 26, 2005 10:04 pm
Posts: 1965
Location: Grass Valley, CA
Windows Version: XP Pro SP3 x86 + all updates
Avant Version: 2013 Ultimate Build 23 & Build 115 (USB)
Default engine: Gecko (Firefox)
IE Version: IE8 + all patches and updates
Skin: Monai XP
Where is your mouse cursor in the screenshot?


Top
 Profile  
 
 Post subject: Re: Wrong Tooltips
Post Reply #7 on: Tue Jul 10, 2012 4:57 am 
Offline
Newbie
Newbie

Joined: Sat Jun 16, 2012 7:14 am
Posts: 29
Windows Version: 7
Avant Version: 2012 Build 173
IE Version: 9
I use PrtSc (Print Screen) of keyboard button to make a screenshot, so there will no mouse cursor appear there..

If I told you there're problems in Avant browser that means there're really problems there, I don't like wasting time to make just freak..

You just need to test them as I did then fix them if you would..

Regards,
Herman Semm


Top
 Profile  
 
 Post subject: Re: Wrong Tooltips
Post Reply #8 on: Tue Jul 10, 2012 2:12 pm 
Offline
Avant Fanatic
Avant Fanatic

Joined: Sun Apr 29, 2007 2:13 pm
Posts: 374
Windows Version: Xp Pro Sp3 32-bit
Avant Version: 2014 Ultimate 5
Default engine: Firefox Rendering
IE Version: 7 but i never use it
Skin: Xito - old skins
mbrazil wrote:
Where is your mouse cursor in the screenshot?


Looks like the mouse is in the close all tabs button , but the tooltip is of a tab (link of the forum) .
Its giving tooltips of a wrong place for him , for me its all ok with tooltips.

Herman.Semm , if you exit of Compact style , the tooltips work or not ?
To exit of the Compact style go to View >>> Compact style and Uncheck it.


Top
 Profile  
 
 Post subject: Re: Wrong Tooltips
Post Reply #9 on: Tue Jul 10, 2012 6:28 pm 
Offline
AvantGuard
AvantGuard
Avantic Elite
User avatar

Joined: Tue Jul 26, 2005 10:04 pm
Posts: 1965
Location: Grass Valley, CA
Windows Version: XP Pro SP3 x86 + all updates
Avant Version: 2013 Ultimate Build 23 & Build 115 (USB)
Default engine: Gecko (Firefox)
IE Version: IE8 + all patches and updates
Skin: Monai XP
That's why I asked him where the mouse cursor was. The tooltip looks like it's for a tab button. My next question would have been where he keeps his tab bar (top or bottom).

Like you, I am not experiencing any problems with incorrect tooltips anywhere in Avant, so I'm wondering whether there is something unusual about his system that might be causing it, like a defect in a video driver or a mouse driver. Something like that could confuse the tooltip code in Avant so that it seems like the mouse cursor is at a different set of coordinates than it really is.

He seems to think that, because he's observing this problem, it has to be an Avant bug, even though no one else has reported experiencing the same thing. It could be something wrong in Avant, but it could also be something else on his system that's causing the tooltip problem he's experiencing. We need more information about his operating system and other software to try to determine what's happening.


Top
 Profile  
 
 Post subject: Re: Wrong Tooltips
Post Reply #10 on: Wed Jul 11, 2012 12:57 am 
Offline
Newbie
Newbie

Joined: Sat Jun 16, 2012 7:14 am
Posts: 29
Windows Version: 7
Avant Version: 2012 Build 173
IE Version: 9
Hi..
Sorry for my unknown..

I've test Avant Browser on 5 computers:
1. My laptop, Acer branded with win7 SP1 and 14" LCD Wide Monitor
2. Both of my kids' Netbook, Acer branded With Win7 SP1 and 10.1" LCD Wide Monitor
3. My PC, HP branded with WinXP SP3 and 14" LCD Monitor
4. My office's PC, Lenovo branded with WinXP SP3 and 14" LCD Wide Monitor, HP branded

The problem occured the same to 5 computers above. I used standard windows settings and there're no special software or special display software, just standard software eg.Office 2010, ACDSee 5, ect. somekinds as standard software

I've setted Avant to use compact style because I need wider view, especially to both of my kids' netbook
and I keep my Tab Bar at Top, but it happen the same way even I moved the tab bar to bottom.

You're right that the wrong tooltips occured when using compact style, It's fine in standard view except the "close current tab" (No tooltip appears when hover my mouse on it)

I've observed that the text(words) appears as the wrong tooltips as the same as text of every Title of webpages I visited and same as Tab Button tooltip too
The wrong tooltips appears when hover my mouse on every object in the red cyrcle (see the screenshot). And I think because of in compact view there're no tooltips (for objects in the red cyrcle) then they use the title of current webpage as tooltip (same as Tab Button tooltip).

May I suggest you to add tooltips on the compact view of main menu same as in fullscreen mode, it may fix the problem

Best regards,
Herman Semm


Top
 Profile  
 
 Post subject: Re: Wrong Tooltips
Post Reply #11 on: Wed Jul 11, 2012 1:49 am 
Offline
AvantGuard
AvantGuard
Avantic Elite
User avatar

Joined: Tue Jul 26, 2005 10:04 pm
Posts: 1965
Location: Grass Valley, CA
Windows Version: XP Pro SP3 x86 + all updates
Avant Version: 2013 Ultimate Build 23 & Build 115 (USB)
Default engine: Gecko (Firefox)
IE Version: IE8 + all patches and updates
Skin: Monai XP
Is there any software in addition to Avant that is running on all four computers?

I don't get tooltips at all on anything (menu items, buttons, icons) in the top row in Compact Style or for anything in the menu bar when Compact Style is disabled. However, I noticed that if you disable the Management Bar, the small down arrow that's normally at its left end and any buttons you have enabled in Other Buttons (except for the first five, which appear in the Search Bar) appear inline with the menu bar either just below the title bar in regular mode or in the title bar to the right of the menu in Compact Style. I have all the buttons that normally appear in the Management Bar disabled, and I have disabled the Management Bar itself, so the small down arrow from the Management bar appears to the right of the menu. When you click this down arrow, you get a menu of several commands, and below that, a list of all your open tabs in reverse order with the PID included. When you hover your mouse cursor over any of the tabs in the list, you get a tooltip that shows the entire tab title, including the portion that is cut off at the right end in the list. I'm thinking that these tooltips for the tabs in the list may be what's showing up in your case. I don't know why it's happening, but it's a more likely explanation than anything else I can think of, and maybe it will help to determine why you're getting those tooltips.


Top
 Profile  
 
 Post subject: Re: Wrong Tooltips
Post Reply #12 on: Wed Jul 11, 2012 2:17 am 
Offline
Newbie
Newbie

Joined: Sat Jun 16, 2012 7:14 am
Posts: 29
Windows Version: 7
Avant Version: 2012 Build 173
IE Version: 9
Hi...

It's Strange..! I don't get any wrong tooltips anymore after I switch to other rendering engine then back to IE9 Standard at last.

Here I sent you screenshot of Avant on my kid's netbook

Anyway I still suggest you to add tolltip to each object in the red cyrcle.

Best Regards,
Herman Semm


Attachments:
File comment: Avant on Netbook
AvantDisp.jpg
AvantDisp.jpg [ 208.04 KiB | Viewed 442 times ]
Top
 Profile  
 
 Post subject: Re: Wrong Tooltips
Post Reply #13 on: Wed Jul 11, 2012 3:50 am 
Offline
Support Staff
Support Staff
Avant Guru
User avatar

Joined: Wed Apr 22, 2009 1:52 am
Posts: 3917
Windows Version: xp/win7 64/win8
Avant Version: latest version
Default engine: firefox/chrome/IE
IE Version: 8/9/10
Skin: aero glass/opal glas
Quote:
Anyway I still suggest you to add tolltip to each object in the red cyrcle.

Recorded


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Group