Non-recovery Start-Up

These archives contain old topics that were moved here to prevent clutter in the forums. These threads may still contain some useful information.

Moderators: Support Staff², Support Staff, AvantGuard, Developer

Locked
User avatar
Victor Delta
Fan
Fan
Posts: 193
Joined: Thu Sep 18, 2003 10:28 pm
Windows Version: Windows 10
Avant Version: Ultimate 2019 b2
Default engine: Firefox
IE Version: IE 11
Skin: Office XP
Location: Poole, UK

Non-recovery Start-Up

Post by Victor Delta » Sat Oct 02, 2004 10:43 am

When I start Avant (using Win 98), i usually get the message saying that it wasn't properly closed and would i like to recover the open pages etc. - which I never want to do.

Is there a way to disable this facility or a switch I can put in the shortcut to bypass it?

Thanks

bigC
AvantGuard
AvantGuard
Posts: 7244
Joined: Thu Jan 30, 2003 10:40 pm
Windows Version: 10
Avant Version: 2016 Build 1
Default engine: Firefox
IE Version: 11
Skin: Crystal
Location: New York

Post by bigC » Sat Oct 02, 2004 4:12 pm

No there is not. This was just discussed the other day actually. You may want to have a look at this topic,

http://forum.avantbrowser.com/viewtopic.php?t=8094

Although I'm concerned as to why AB keeps closing improperly for you. Do you have the tray icon enabled? Are you sure AB is closed when you shutdown windows & not just minimized to the system tray? This may be the cause of the improper closing of Avant. Check your settings under Tools > Avant Browser Options > Tray Icon

User avatar
Victor Delta
Fan
Fan
Posts: 193
Joined: Thu Sep 18, 2003 10:28 pm
Windows Version: Windows 10
Avant Version: Ultimate 2019 b2
Default engine: Firefox
IE Version: IE 11
Skin: Office XP
Location: Poole, UK

Post by Victor Delta » Sat Oct 02, 2004 10:27 pm

Thanks. No I don't use the tray icon (too many others already!) and I tend to shut down simply by using the Windows 'Turn Off' facility. It works for all my other programmes e.g. Word, Excel etc and I assumed Avant would be ok too (it works alright doing this in Windows XP).

Presumably you are saying that, when using Win98, one must close Avant first before shutting down? Or, is it ok if the tray icon is 'on'?

User avatar
MysteryFCM
Administrator
Administrator
Posts: 7330
Joined: Tue Dec 09, 2003 2:34 am
Windows Version: 10, 8.0, 8.1, 7, Vista, XP
Avant Version: 13.00 Build 23
Default engine: Gecko
IE Version: 7.x, 8.x, 9.x, 10.x, 11.x
Skin: AthenX
Location: Newcastle Upon Tyne, UK
Contact:

Post by MysteryFCM » Sat Oct 02, 2004 11:11 pm

Victor Delta wrote:Presumably you are saying that, when using Win98, one must close Avant first before shutting down? Or, is it ok if the tray icon is 'on'?
Under normal circumstances, closing Avant first should not be necessary. The only time it may be is when "Disable Fast Shutdown" is not ticked in msconfig.

To check this, go to;

Start > Run, type: msconfig

Click the Advanced button, and look near the bottom of the list. If the option is unticked, tick it.... click OK > Apply > OK (note: you may be asked to re-start your computer for the changes to take effect).

User avatar
Victor Delta
Fan
Fan
Posts: 193
Joined: Thu Sep 18, 2003 10:28 pm
Windows Version: Windows 10
Avant Version: Ultimate 2019 b2
Default engine: Firefox
IE Version: IE 11
Skin: Office XP
Location: Poole, UK

Post by Victor Delta » Mon Oct 04, 2004 1:15 pm

Checked msconfig this morning and the box is actually ticked - so must be something else. Any ideas? (Win98 SE by the way).

Thanks,

User avatar
MysteryFCM
Administrator
Administrator
Posts: 7330
Joined: Tue Dec 09, 2003 2:34 am
Windows Version: 10, 8.0, 8.1, 7, Vista, XP
Avant Version: 13.00 Build 23
Default engine: Gecko
IE Version: 7.x, 8.x, 9.x, 10.x, 11.x
Skin: AthenX
Location: Newcastle Upon Tyne, UK
Contact:

Post by MysteryFCM » Mon Oct 04, 2004 2:00 pm

As a general rule, I tend to close everything down before re-booting anyway as it can cause problems not doing so but, I've just tried re-booting with Avant open and got the recovery thing aswell so to be honest, I'm a little baffled aswell (this system is 98SE too btw).

However, I did it once again, only this time, had a batch file run on startup that deleted the pages.dat file, and the recovery option didn't show up, so you may want to do that until we can find out whats causing it (most likely cause is an incorrect WM_CLOSE message being sent (or indeed, not being sent at all)).

If the WM_CLOSE message is processed correctly by Avant, the return value should be 0. However, as Avant is set to go to recovery mode if shutdown by anything other than Avant itself, I'd have to hazard a guess that it's treating the WM_CLOSE message as a bad shutdown and thus..... Mr Recovery comes into it.

Oks, I'm rambling now.......

To use the batch file option, copy and paste the following into Notepad. Then save it as C:\something.bat (where something is your chosen filename and C is the drive Windows is installed on).

@ECHO OFF
@if exist C:\Windows\Applic~1\Avantb~1\pages.dat del C:\Windows\Applic~1\Avantb~1\pages.dat
exit


IMPORTANT: If Windows is installed on a drive OTHER than C, change the path above to the path that reflects your system!! (it MUST however, remain in DOS format).

Once the file is created, place a shortcut to it in your Startup folder (usually C:\WINDOWS\Start Menu\Programs\StartUp).

Voila..... the file will be deleted each time you re-boot your computer.

WARNING: Using this method will prevent Avant being able to use the recovery method under ALL circumstances!!. Use at your own risk

User avatar
Victor Delta
Fan
Fan
Posts: 193
Joined: Thu Sep 18, 2003 10:28 pm
Windows Version: Windows 10
Avant Version: Ultimate 2019 b2
Default engine: Firefox
IE Version: IE 11
Skin: Office XP
Location: Poole, UK

Post by Victor Delta » Mon Oct 04, 2004 2:11 pm

Steven,

Many thanks. I'll give it a go!

Regards.

User avatar
MysteryFCM
Administrator
Administrator
Posts: 7330
Joined: Tue Dec 09, 2003 2:34 am
Windows Version: 10, 8.0, 8.1, 7, Vista, XP
Avant Version: 13.00 Build 23
Default engine: Gecko
IE Version: 7.x, 8.x, 9.x, 10.x, 11.x
Skin: AthenX
Location: Newcastle Upon Tyne, UK
Contact:

Post by MysteryFCM » Mon Oct 04, 2004 2:18 pm

I forgot to add, you also need to set the "ProperlyClosed" setting in the Avant Browser settings file, to "yes" first.

User avatar
MysteryFCM
Administrator
Administrator
Posts: 7330
Joined: Tue Dec 09, 2003 2:34 am
Windows Version: 10, 8.0, 8.1, 7, Vista, XP
Avant Version: 13.00 Build 23
Default engine: Gecko
IE Version: 7.x, 8.x, 9.x, 10.x, 11.x
Skin: AthenX
Location: Newcastle Upon Tyne, UK
Contact:

Post by MysteryFCM » Mon Oct 04, 2004 3:04 pm

If it's any help, I've added an option to auto-disable this feature from AB Edit (Tools > Recovery Manager > Disable Recovery Manager (keyboard shortcut: Shift +F2)).

Basically, if this feature is disabled, AB Edit will run each time you start your computer, tell Avant it DID shut down properly, and then AB Edit will close itself (you won't actually know it's been run).

I've tested the new feature on both my 98SE and XP Pro systems so far.

http://support.it-mate.co.uk/index.asp? ... s&p=abedit

Edit

Forgot to mention, the new versions version number is 1.2.2 beta.

User avatar
Victor Delta
Fan
Fan
Posts: 193
Joined: Thu Sep 18, 2003 10:28 pm
Windows Version: Windows 10
Avant Version: Ultimate 2019 b2
Default engine: Firefox
IE Version: IE 11
Skin: Office XP
Location: Poole, UK

Post by Victor Delta » Fri Nov 12, 2004 8:25 pm

Steven,

Many thanks for all your help. I thought I had the problem cracked until I downloaded Avant version 10. Does he pages.dat batch file 'trick' still work with version 10 please?

Thanks.

bigC
AvantGuard
AvantGuard
Posts: 7244
Joined: Thu Jan 30, 2003 10:40 pm
Windows Version: 10
Avant Version: 2016 Build 1
Default engine: Firefox
IE Version: 11
Skin: Crystal
Location: New York

Post by bigC » Fri Nov 12, 2004 8:41 pm

I believe Steve is away at the moment but I'll see if I can help.

Pages.dat was renamed to reopen.dat in version 10. So changing

@ECHO OFF
@if exist C:\Windows\Applic~1\Avantb~1\pages.dat del C:\Windows\Applic~1\Avantb~1\pages.dat
exit


in your bat file to,

@ECHO OFF
@if exist C:\Windows\Applic~1\Avantb~1\reopen.dat del C:\Windows\Applic~1\Avantb~1\reopen.dat
exit


should get it working once again. Let us know...

If you're using the option in ABedit, he may have forgotton to update the .dat name change or perhaps you don't have the latest version of ABedit. I'll drop him a pm about this so he'll see it when he returns :wink:

User avatar
Victor Delta
Fan
Fan
Posts: 193
Joined: Thu Sep 18, 2003 10:28 pm
Windows Version: Windows 10
Avant Version: Ultimate 2019 b2
Default engine: Firefox
IE Version: IE 11
Skin: Office XP
Location: Poole, UK

Post by Victor Delta » Fri Nov 12, 2004 10:59 pm

Many thanks. I'll let you know how I get on.

User avatar
MysteryFCM
Administrator
Administrator
Posts: 7330
Joined: Tue Dec 09, 2003 2:34 am
Windows Version: 10, 8.0, 8.1, 7, Vista, XP
Avant Version: 13.00 Build 23
Default engine: Gecko
IE Version: 7.x, 8.x, 9.x, 10.x, 11.x
Skin: AthenX
Location: Newcastle Upon Tyne, UK
Contact:

Post by MysteryFCM » Sat Nov 13, 2004 6:29 pm

Victor Delta wrote:Steven,

Many thanks for all your help. I thought I had the problem cracked until I downloaded Avant version 10. Does he pages.dat batch file 'trick' still work with version 10 please?

Thanks.
Yes it will. However, as bigC has mentioned, you will need to change "pages.dat" to "reopen.dat" in the batch file (incase your using AB Edit, I've just uploaded an update that will take care of this for you (v1.2.6)).

User avatar
TOMaxwell
Semi-Fan
Semi-Fan
Posts: 68
Joined: Sun Jul 11, 2004 5:46 pm
Avant Version:

Post by TOMaxwell » Tue Nov 16, 2004 2:39 pm

I have been using a nifty little program called "Push the Freakin Button" for years. It's great for ALL the annoying 'Are You Sure' crap in Windows.

Whenever one of those dialogs pops up - the kind where your answer is ALWAYS the same - use the button selection tool to select the answer, then tell it to start watching. It runs in the SysTray but takes up very little system resources. I have at least 500 targets in mine. It prevents me from killing my computer on a daily basis. :)
Some days, it's just not worth biting through the leather straps :-#

Locked