11.5b16 losing scroll wheel and ability to enter text box

Moderators: André, AvantGuard

Post Reply
gedavies
Newbie
Newbie
Posts: 16
Joined: Tue Oct 26, 2004 5:33 pm
Avant Version:

11.5b16 losing scroll wheel and ability to enter text box

Post by gedavies » Mon Jul 16, 2007 9:03 pm

XP SP2
I upgraded this morning to 11.5b16 and twice today, the scroll wheel became inoperative and I was unable to to click into text boxes. Shutting AB and restarting brought everything back each time.

Thanks,
Geoff.

User avatar
hornakapopolis
AvantGuard
AvantGuard
Posts: 11321
Joined: Thu Jul 31, 2003 2:09 pm
Windows Version: Windows 10 Pro 64
Avant Version: 2015
Default engine: Chrome
IE Version: 11
Skin: Stickers
Location: Ohio, USA
Contact:

Post by hornakapopolis » Tue Jul 17, 2007 12:25 am

I haven't had any of these problems at all. What are your mouse & driver specs?

frosty1433

Post by frosty1433 » Tue Jul 17, 2007 3:55 am

Sounds weird. What exactly were you doing when it occured? ...Or does it just happen at random times? Also, what version of IE are you using? I've noticed this with older mouses (mice?) I've had in IE6. Is your mouse a laser mouse?

gedavies
Newbie
Newbie
Posts: 16
Joined: Tue Oct 26, 2004 5:33 pm
Avant Version:

Post by gedavies » Tue Jul 17, 2007 2:44 pm

There was nothing consistent in the actions that led to the problem.

I have IE7 as the underlying engine.

The mouse is a "Microsoft USB IntelliMouse Optical" and the driver is (not surprisingly) Microsoft version 5.1.2600.0

This is my work machine so I am two hours into using today with no problem. I did not upgrade my home machines yet just in case.

Cheers,
Geoff.

gedavies
Newbie
Newbie
Posts: 16
Joined: Tue Oct 26, 2004 5:33 pm
Avant Version:

Post by gedavies » Tue Jul 17, 2007 3:36 pm

Okay so now 2.5 hrs into work and I was on looking at the results of a google search and boom...lost scroll wheel and the ability to click into textboxes. Closed up, restarted ab and back in business.

abfan123
Avantus Maximus
Avantus Maximus
Posts: 5624
Joined: Wed Jan 26, 2005 4:24 pm
Windows Version: Vista Ultimate x64 SP2
Avant Version: 11.7 build 43
IE Version: 8
Contact:

Post by abfan123 » Tue Jul 17, 2007 4:46 pm

Make sure that you don't have any external windows that were called from Avant Browser. (WindowsUpdate/Download manager etc)
IE8(Pro), Microsoft Security Essentials
Main PC:
Image
Secondary PC same as primary but with Windows 7 x64 Ultimate as the OS.

User avatar
ADukes
Semi-Avantic
Semi-Avantic
Posts: 635
Joined: Tue Jul 19, 2005 10:53 am
Windows Version: Windows XP Pro SP2
Avant Version: 11.7 Build 19
IE Version: Internet Explorer 7

Post by ADukes » Tue Jul 17, 2007 5:44 pm

Sounds just like a window focus issue.
Thanks Anderson for checking out my AB 11.0 feature request list,
now it's time to go on with 11.8:

http://forum.avantbrowser.com/viewtopic.php?t=16116
Image
Windows XP SP2, IE7, AB 11.7 build 19

frosty1433

Post by frosty1433 » Tue Jul 17, 2007 8:41 pm

The scrollwheel isn't working, but you're able to scroll with the scrollbar, right? If so, I do not think it is a window focusing issue.
Please try going to Tools > AB options > mouse, and disable anything involving the scrollwheel, and see if it happens again.

iceshake
Newbie
Newbie
Posts: 48
Joined: Mon Oct 24, 2005 3:31 pm
Avant Version:

Post by iceshake » Sun Jul 22, 2007 3:05 pm

I experience the loss of the scroll wheel function when i have a window of search rsults from google...

closing the window and changing to other tabs a few times usually does the trick for me to get the scroll wheel back working...

User avatar
hornakapopolis
AvantGuard
AvantGuard
Posts: 11321
Joined: Thu Jul 31, 2003 2:09 pm
Windows Version: Windows 10 Pro 64
Avant Version: 2015
Default engine: Chrome
IE Version: 11
Skin: Stickers
Location: Ohio, USA
Contact:

Post by hornakapopolis » Sun Jul 22, 2007 8:28 pm

I use Google all of the time and have never had this issue there.

iceshake
Newbie
Newbie
Posts: 48
Joined: Mon Oct 24, 2005 3:31 pm
Avant Version:

Post by iceshake » Mon Jul 23, 2007 6:11 am

As in, lets say I enter text into the search toolbar, and then hit enter, i will be brought to a page of google search results. any other tab that are opened already will lose the ability to scroll the webpage using the scroll wheel. Normall scrolling by clicking the arrow buttons on the scroll bar still works.

The remedy is to close all the tabs (but avant is still open) and open new tabs again.

Oh I need to add that the action assigned to the clicking of the scroll wheel, (open a new page in the background) doesnt work when this bug occurs.

User avatar
hornakapopolis
AvantGuard
AvantGuard
Posts: 11321
Joined: Thu Jul 31, 2003 2:09 pm
Windows Version: Windows 10 Pro 64
Avant Version: 2015
Default engine: Chrome
IE Version: 11
Skin: Stickers
Location: Ohio, USA
Contact:

Post by hornakapopolis » Mon Jul 23, 2007 11:53 am

What function is set in your Window's mouse functions for the scroll wheel?

User avatar
ADukes
Semi-Avantic
Semi-Avantic
Posts: 635
Joined: Tue Jul 19, 2005 10:53 am
Windows Version: Windows XP Pro SP2
Avant Version: 11.7 Build 19
IE Version: Internet Explorer 7

Post by ADukes » Mon Jul 23, 2007 1:23 pm

iceshake wrote:I experience the loss of the scroll wheel function when i have a window of search rsults from google...
What's your AB version?
Thanks Anderson for checking out my AB 11.0 feature request list,
now it's time to go on with 11.8:

http://forum.avantbrowser.com/viewtopic.php?t=16116
Image
Windows XP SP2, IE7, AB 11.7 build 19

iceshake
Newbie
Newbie
Posts: 48
Joined: Mon Oct 24, 2005 3:31 pm
Avant Version:

Re: 11.5b16 losing scroll wheel and ability to enter text bo

Post by iceshake » Tue Jul 24, 2007 9:57 am

My version is exactly 11.5b16. My mouse is Logitech optical mouse, setpoint 3.30.165 and in the setpoint software, my middle mouse is set to "generic button".

And I also lose the ability to key into the text box of the google search page too, thats why i posted in this thread.

gquiring
Semi-Fan
Semi-Fan
Posts: 78
Joined: Mon Mar 29, 2004 11:50 pm
Windows Version: Windows
Avant Version:
Location: NJ

Re: 11.5b16 losing scroll wheel and ability to enter text bo

Post by gquiring » Tue Jul 24, 2007 2:32 pm

11.5 b16 same issue here using Vista with stock mouse drivers. I have a Logitech trackman but I don't load any Logitech drivers. This problem only started with v11.5 b16. If I close AB and relaunch it restores the wheel.

marshdabeachy
Newbie
Newbie
Posts: 40
Joined: Sat Dec 17, 2005 3:29 am
Avant Version:

Post by marshdabeachy » Wed Jul 25, 2007 5:42 am

This has been happening to me a number of times too. I've noticed while I'm typing something in MySpace a lot (yeah, MySpace... sue me). It seems to be an issue switching between tabs. I'll be typing in one tab, jump to the other tab for a bit, come back to the original tab, and the textbox I was typing in is busted. Kinda sorta a big pain, especially when I was writing something big. It won't even let me copy the text I wrote, even though I can highlight it.

User avatar
hornakapopolis
AvantGuard
AvantGuard
Posts: 11321
Joined: Thu Jul 31, 2003 2:09 pm
Windows Version: Windows 10 Pro 64
Avant Version: 2015
Default engine: Chrome
IE Version: 11
Skin: Stickers
Location: Ohio, USA
Contact:

Post by hornakapopolis » Wed Jul 25, 2007 5:46 am

marshdabeachy wrote:(yeah, MySpace... sue me)
:lol: :lol:

I'm apologize for posting such an irrelevant post, but that just killed me.

iceshake
Newbie
Newbie
Posts: 48
Joined: Mon Oct 24, 2005 3:31 pm
Avant Version:

Post by iceshake » Fri Jul 27, 2007 8:57 am

yeah i suspect this issue, is an extension of the "new tab losing focus bug" that happend a couple of versions ago

JoeVB
Newbie
Newbie
Posts: 27
Joined: Tue Oct 04, 2005 5:25 pm
Avant Version:

Post by JoeVB » Sat Jul 28, 2007 1:40 am

gedavies wrote:There was nothing consistent in the actions that led to the problem.

I have IE7 as the underlying engine.

The mouse is a "Microsoft USB IntelliMouse Optical" and the driver is (not surprisingly) Microsoft version 5.1.2600.0

This is my work machine so I am two hours into using today with no problem. I did not upgrade my home machines yet just in case.

Cheers,
Geoff.
Same for me also, and I have the same details on versions. Its really a ****.

Moved From Bug Reports To Confirmed Bugs - Terranaut

larzke
Newbie
Newbie
Posts: 6
Joined: Mon Jul 30, 2007 11:47 am
Avant Version:

Post by larzke » Mon Jul 30, 2007 11:54 am

I've got the same problem.

XPSP2, IE7 as underlying browser and standard mouse with standard driver. Since the newest version this bug is bugging the living crap out of me.

After about an hour of browsing, mouse scrolling stops working, text boxes become uneditable, and if I Ctrl-Up to a different tab, the content is shown but the window tab focus goes to the last tab and you are essentially stuck.

The only thing left to do is "Save all pages and Exit", and then restart Avant, but doing that 10 times per day and frequently having 30+ tabs open that take long to reload, this is driving me so insane that I am getting ready to throw Avant in the bin and switch to something else. And I'm a long-time fan.

Previous versions didn't have this problem, and I would greatly appreciate an older version being made available. (Oldversion.com goes back a bit too far.)

Post Reply