New Tabs Not Receiving Focus in 11.5b8

Help issues and Bug Reports for the current version that have been corrected can be found here. Only staff members may move threads to this forum.

Moderators: Support Staff², Support Staff, AvantGuard, Developer

User avatar
Blitzkrieg
Newbie
Newbie
Posts: 21
Joined: Thu Jun 12, 2003 11:17 am
Windows Version: Vista Business SP1
Avant Version: 11.6 b11
IE Version: 8 beta 1
Contact:

New Tabs Not Receiving Focus in 11.5b8

Post by Blitzkrieg » Thu Jun 14, 2007 1:51 pm

11.5 RC3 did not have this behavior. Having multiple pages open, if you open a new tab it will place focus on the last open tab and not the newly created one. It's rather annoying and feels unnatural, actually. This happens on Vista and XP.

Steps:
1. Open AB
2. Navigate to google by typing http://www.google.com in the address bar
3. Open new tab (Ctrl+N)
4. Navigate to yahoo by typing http://www.yahoo.com in the address bar

Results:
Google tab receives focus, not the newly created tab yahoo.

Expected Results:
The yahoo tab should not leave focus

User avatar
blitzmaster
Fan
Fan
Posts: 198
Joined: Wed Apr 25, 2007 12:13 pm
Windows Version: Vista Ultimate x86
Avant Version: 11.7 build 26
IE Version: IE 8
Location: Manila, Philippines

Post by blitzmaster » Thu Jun 14, 2007 3:06 pm

you want the latest tab to receive focus right? of if you have google.com open and you open yahoo.com you want the focus on yahoo?

go to options > new window > choose open foreground.
By Any Means Necessary!

User avatar
Blitzkrieg
Newbie
Newbie
Posts: 21
Joined: Thu Jun 12, 2003 11:17 am
Windows Version: Vista Business SP1
Avant Version: 11.6 b11
IE Version: 8 beta 1
Contact:

Re: New Tabs Not Receiving Focus in 11.5b8

Post by Blitzkrieg » Thu Jun 14, 2007 3:34 pm

I thought of that before I posted. Correct me if I'm wrong, but I think that option is referring to popup windows. If you follow my steps above verbatim with 11.5b8 it should do it for you. Now, I did try switching to background to try it and back to try it - no difference.

hor
Newbie
Newbie
Posts: 4
Joined: Fri Jun 11, 2004 11:46 am
Avant Version:

Re: New Tabs Not Receiving Focus in 11.5b8

Post by hor » Thu Jun 14, 2007 7:30 pm

I have just posted an article with the same bug...
Focus shifts away from the current tab to the last tab before. Build 7 had the same issue, RC3 had the correct behavior.
I have the option "open in foreground" selected.

User avatar
Blitzkrieg
Newbie
Newbie
Posts: 21
Joined: Thu Jun 12, 2003 11:17 am
Windows Version: Vista Business SP1
Avant Version: 11.6 b11
IE Version: 8 beta 1
Contact:

Post by Blitzkrieg » Fri Jun 15, 2007 5:03 am

I'm thinking of reverting back to RC3 till this is fixed, it's that annoying [to me].

User avatar
blitzmaster
Fan
Fan
Posts: 198
Joined: Wed Apr 25, 2007 12:13 pm
Windows Version: Vista Ultimate x86
Avant Version: 11.7 build 26
IE Version: IE 8
Location: Manila, Philippines

Post by blitzmaster » Fri Jun 15, 2007 6:40 am

i'm using build 8. i dont have any problems with tabs and how the tabs works!

everything works fine! even the right click function works perfectly!
By Any Means Necessary!

Beberik
Newbie
Newbie
Posts: 40
Joined: Wed May 02, 2007 2:06 am
Windows Version: Windows 7 x86
Avant Version: 2010 b2
IE Version: Internet Explorer 8

Post by Beberik » Fri Jun 15, 2007 7:48 am

I confirm this one. And blitzmaster especially once again for you, please don't plume yourself here. Please, let us report our bugs in peace. Thank you.

User avatar
blitzmaster
Fan
Fan
Posts: 198
Joined: Wed Apr 25, 2007 12:13 pm
Windows Version: Vista Ultimate x86
Avant Version: 11.7 build 26
IE Version: IE 8
Location: Manila, Philippines

Post by blitzmaster » Fri Jun 15, 2007 12:27 pm

lol!

u cant blame me Avant works perfectly on my system! right click, tabs, on-line strorage..etc. the real problem that i only encountered most of the time is the sudden han-up of avant..its just freezes and i have to use the task manager to end avant!

i've been an avant user since version 10! i dont complain coz i know only 1 person is responsible in fixing avant! but i do also report bugs and errors!

and pluming you say? you no have no idea?!

and also its really unfair to say that its all Avants' fault, sometimes its the user who doesnt know how to figure out simple solutions! they find a problem and they blame avant w/o searching for solutions first...maybe its the OS, Firewall. sometimes the solution is very simple!

cheers!
By Any Means Necessary!

User avatar
caffeinated
Newbie
Newbie
Posts: 4
Joined: Fri Jun 15, 2007 2:17 pm
Avant Version:

Post by caffeinated » Fri Jun 15, 2007 2:20 pm

I'll chime in here as another user experiencing this problem exactly as described in the OP.

User avatar
KY Dave
Avant Fanatic
Avant Fanatic
Posts: 390
Joined: Mon Dec 01, 2003 1:53 pm
Windows Version: XP Home, Pro, Vista, Win 7
Avant Version: 11.7 build 46SR
IE Version: 8.0.7600.3865
Location: Burkesville, KY
Contact:

Post by KY Dave » Fri Jun 15, 2007 2:38 pm

Have you guys checked your TOOLS, AVANT OPTIONS, NEW WINDOW Options' settings?

I have mine set to...

CTRL+N = Open CURRENT page in a NEW WINDOW

ALWAYS CREATE A NEW WINDOW for = ADDRESS BAR

ALWAYS CREATE A NEW BROWSING WINDOW in = FOREGROUND

and it works correctly. When CTRL+N is pressed or ADDRESS is typed and return hit, the new window takes the focus.

XP Pro with Avant 11. build 8
KY Dave

Family Blog

User avatar
hornakapopolis
AvantGuard
AvantGuard
Posts: 11321
Joined: Thu Jul 31, 2003 2:09 pm
Windows Version: Windows 10 Pro 64
Avant Version: 2015
Default engine: Chrome
IE Version: 11
Skin: Stickers
Location: Ohio, USA
Contact:

Post by hornakapopolis » Fri Jun 15, 2007 2:43 pm

Everyone keep in mind that 1. It's helpful to know that an issue isn't happening with other users and 2. We must understand that people can get frustrated when things work and might misinterpret our declarations of it working fine for us as annoyances.

Now let's put this part of the thread to rest.

Psykocyber
Fan
Fan
Posts: 163
Joined: Sat Aug 19, 2006 6:04 pm
Windows Version: XP SP3, Vista SP1, Win 7
Avant Version: V11.7 B21
IE Version: IE7 & IE8
Location: Denmark

Post by Psykocyber » Fri Jun 15, 2007 6:39 pm

Well I cant confirm that example, but I'm frequently experiencing that problem.
And it's not about if you open the tabs in the foreground or background.
Danish translator of Avant Browser, Folder2MyPC, Folderico & Google

User avatar
mkk
Newbie
Newbie
Posts: 43
Joined: Mon May 03, 2004 3:34 am
Windows Version: Windows
Avant Version:
Location: Gefle, Sweden
Contact:

Post by mkk » Fri Jun 15, 2007 8:24 pm

Yup, it's a new bug from build 7.
Avoided half a million ads in twelve months thanks to Ad Muncher

User avatar
caffeinated
Newbie
Newbie
Posts: 4
Joined: Fri Jun 15, 2007 2:17 pm
Avant Version:

Re: New Tabs Not Receiving Focus in 11.5b8

Post by caffeinated » Fri Jun 15, 2007 8:30 pm

I double checked and, not surprisingly, my settings were retained exactly from my previous Avant install (v11.0.46). Using that version, I would CTRL+N, type in a URL, hit ENTER, and go about viewing the page that came up, as it would retain focus as the top-most tab.

This is no longer the case. Now, I CTRL+N, type URL, hit ENTER, and focus goes immediately back to the previous tab I was viewing. The tab that lost the focus continues to properly load the page I want, but I have to select that tab to bring it back to the top.
ALWAYS CREATE A NEW WINDOW for = ADDRESS BAR
This was not selected in my settings. But when I did select it and tried to follow the same procedure I described above, I got the (expected) result of now having a new, in-focus tab on top displaying the desired URL, and another "about: blank" page remaining where I typed the URL to begin with.

The unfortunate fact is that, for me anyway, this functionality is definitely not working as it previously did.

User avatar
hornakapopolis
AvantGuard
AvantGuard
Posts: 11321
Joined: Thu Jul 31, 2003 2:09 pm
Windows Version: Windows 10 Pro 64
Avant Version: 2015
Default engine: Chrome
IE Version: 11
Skin: Stickers
Location: Ohio, USA
Contact:

Post by hornakapopolis » Fri Jun 15, 2007 9:27 pm

Yes. Let's be clear, this isn't setting related.

Moved from Unconfirmed to Confirmed. - hornakapopolis

iceshake
Newbie
Newbie
Posts: 48
Joined: Mon Oct 24, 2005 3:31 pm
Avant Version:

Post by iceshake » Tue Jun 19, 2007 1:50 am

Yes i am also experiencing this issue. press ctrl + T to open a new tab or pressing ctrl+n to open a new tab doesn't matter.. the new tabs will lose focus..

User avatar
Blitzkrieg
Newbie
Newbie
Posts: 21
Joined: Thu Jun 12, 2003 11:17 am
Windows Version: Vista Business SP1
Avant Version: 11.6 b11
IE Version: 8 beta 1
Contact:

Post by Blitzkrieg » Tue Jun 19, 2007 1:36 pm

This bug is still apparent in 11.5b9

Lord Chaos
Avant Fanatic
Avant Fanatic
Posts: 389
Joined: Tue Oct 26, 2004 1:48 pm
Windows Version: Windows Vista 64 Bit
Avant Version: Ver. 11.5 Build 21
IE Version: IE 7

Post by Lord Chaos » Tue Jun 19, 2007 3:27 pm

I am experiencing this bug too, highly annoying.

iceshake
Newbie
Newbie
Posts: 48
Joined: Mon Oct 24, 2005 3:31 pm
Avant Version:

Post by iceshake » Wed Jun 20, 2007 1:08 am

what i've done is to temporarily switch on the "open new window" when typing in a url in the address bar...

User avatar
hornakapopolis
AvantGuard
AvantGuard
Posts: 11321
Joined: Thu Jul 31, 2003 2:09 pm
Windows Version: Windows 10 Pro 64
Avant Version: 2015
Default engine: Chrome
IE Version: 11
Skin: Stickers
Location: Ohio, USA
Contact:

Post by hornakapopolis » Wed Jun 20, 2007 2:18 am

Huh... thanks, iceshake, for the simple and seemingly rather obvious workaround. :doh: Good work!

Post Reply