HELP!!! I lost all my bookmarks!

Request help with using Avant Browser here.

Moderators: Support Staff², Support Staff, AvantGuard, Developer

gadi_sam
Newbie
Newbie
Posts: 23
Joined: Sun Apr 22, 2012 9:37 pm
Windows Version: XP
Avant Version: 2012 build8
IE Version: 8

HELP!!! I lost all my bookmarks!

Post by gadi_sam » Sun Mar 17, 2013 10:59 pm

Avant Browser went crazy, so I had to uninstall/reinstall it, and on unistalling I specifically unchecked the "erase bookmarks" box, but alas, when I reinstalled it all my bookmarks were gone!
Where can I find them?
Thanks!

mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: 10
Avant Version: 2015 Ultimate Build 28
Default engine: Gecko (Firefox)
IE Version: 10
Skin: Monai XP
Location: Grass Valley, CA

Re: HELP!!! I lost all my bookmarks!

Post by mbrazil » Mon Mar 18, 2013 12:21 am

gadi_sam wrote:Avant Browser went crazy, so I had to uninstall/reinstall it, and on unistalling I specifically unchecked the "erase bookmarks" box, but alas, when I reinstalled it all my bookmarks were gone!
Where can I find them?
Thanks!
If you have Online Storage enabled, logging in should automatically restore them. If not, try Tools > Backup/Restore Profiles. If there's a backup listed there that's dated prior to when you reinstalled, restoring it should bring them back (choose the most recent one prior to when you reinstalled). If that doesn't work, shut Avant down, and search your hard drive(s) for bookmarks.dat. You may find more than one, so choose the one that has the most recent modification date and time prior to when you reinstalled, and copy it to your Avant profile folder (the path is listed in Tools > Avant Browser Options > Profile). Make sure the bookmarks.dat you copy is from Avant by checking the path to the folder it's in.

gadi_sam
Newbie
Newbie
Posts: 23
Joined: Sun Apr 22, 2012 9:37 pm
Windows Version: XP
Avant Version: 2012 build8
IE Version: 8

Re: HELP!!! I lost all my bookmarks!

Post by gadi_sam » Mon Mar 18, 2013 4:57 am

Thank you for your help.

Unfortunately, there''s no bookmarks.dat in the path (c:\Documents and Settings...) which is prior to when I reinstalled.
So I guess that's it? my bookmarks gone forever?

mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: 10
Avant Version: 2015 Ultimate Build 28
Default engine: Gecko (Firefox)
IE Version: 10
Skin: Monai XP
Location: Grass Valley, CA

Re: HELP!!! I lost all my bookmarks!

Post by mbrazil » Mon Mar 18, 2013 5:09 am

Is there a bookmarks.dat anywhere on your PC?

User avatar
AXEMAN
Avantic Elite
Avantic Elite
Posts: 1606
Joined: Thu Jan 24, 2008 12:55 am
Windows Version: WIN 7 64 BIT
Avant Version: THE LATEST
IE Version: 9

Re: HELP!!! I lost all my bookmarks!

Post by AXEMAN » Mon Mar 18, 2013 3:54 pm

From now on save your whole profile before uninstalling avant :)

gadi_sam
Newbie
Newbie
Posts: 23
Joined: Sun Apr 22, 2012 9:37 pm
Windows Version: XP
Avant Version: 2012 build8
IE Version: 8

Re: HELP!!! I lost all my bookmarks!

Post by gadi_sam » Mon Mar 18, 2013 6:09 pm

mbrazil wrote:Is there a bookmarks.dat anywhere on your PC?
Yes, I found some more bookmarks.dat's, from several days before the disaster.
I copied one of them to c:\Documents and Settings\gadi\Application Data (which is the folder , shut and opened Avant, but the bookmarks haven't changed.

How do I "activate" this bookmarks.dat ?

mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: 10
Avant Version: 2015 Ultimate Build 28
Default engine: Gecko (Firefox)
IE Version: 10
Skin: Monai XP
Location: Grass Valley, CA

Re: HELP!!! I lost all my bookmarks!

Post by mbrazil » Mon Mar 18, 2013 6:29 pm

gadi_sam wrote:How do I "activate" this bookmarks.dat ?
I should have been more specific about where the bookmarks.dat file is kept. You should see a folder called Avant Profiles and another folder under that one called Bookmarks. Copy it to the Bookmarks folder. That's where the current one should be, so you'll be overwriting the current one. Be sure to shut Avant down before you copy the file.

gadi_sam
Newbie
Newbie
Posts: 23
Joined: Sun Apr 22, 2012 9:37 pm
Windows Version: XP
Avant Version: 2012 build8
IE Version: 8

Re: HELP!!! I lost all my bookmarks!

Post by gadi_sam » Mon Mar 18, 2013 9:35 pm

mbrazil wrote:
gadi_sam wrote:How do I "activate" this bookmarks.dat ?
I should have been more specific about where the bookmarks.dat file is kept. You should see a folder called Avant Profiles and another folder under that one called Bookmarks. Copy it to the Bookmarks folder. That's where the current one should be, so you'll be overwriting the current one. Be sure to shut Avant down before you copy the file.
I found the Avant Profiles folder, but there was no Bookmarks folder under it, so I created one and copied bookmarks.dat into it, but to no avail.
Then I went to Avant Options/Profiles and changed the location to that Bookmarks folder, when I hit Apply a small "updating" window flashed for half a second, but stiil to no avail. When I went again to Avant Options/Profiles, the location changed back to its default.

mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: 10
Avant Version: 2015 Ultimate Build 28
Default engine: Gecko (Firefox)
IE Version: 10
Skin: Monai XP
Location: Grass Valley, CA

Re: HELP!!! I lost all my bookmarks!

Post by mbrazil » Mon Mar 18, 2013 9:46 pm

Based on what you said earlier in this thread, the bookmarks.dat should be at:

C:\Documents and Settings\gadi\Application Data\Avant Profiles\gadi\bookmarks\bookmarks.dat

gadi_sam
Newbie
Newbie
Posts: 23
Joined: Sun Apr 22, 2012 9:37 pm
Windows Version: XP
Avant Version: 2012 build8
IE Version: 8

Re: HELP!!! I lost all my bookmarks!

Post by gadi_sam » Mon Mar 18, 2013 10:06 pm

Sorry, still won't work.
And the Profile location in Avant/Options keeps bouncing to its default -
C:\Documents and Settings\gadi\Application Data.
It won't let me change it.

mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: 10
Avant Version: 2015 Ultimate Build 28
Default engine: Gecko (Firefox)
IE Version: 10
Skin: Monai XP
Location: Grass Valley, CA

Re: HELP!!! I lost all my bookmarks!

Post by mbrazil » Tue Mar 19, 2013 12:09 am

The only other thing I can suggest is to back up the earlier version you found of the bookmarks.dat and then uninstall and reinstall Avant. You'd be best off to use Revo Uninstaller in its Advanced mode to uninstall Avant to be sure everything is removed. If Revo finds leftover registry data and files, select all of the things it finds and have it delete them. After you're done and you've got Avant reinstalled, locate the new bookmarks.dat that Avant creates during installation and copy your backup of bookmarks.dat over the new one.

gadi_sam
Newbie
Newbie
Posts: 23
Joined: Sun Apr 22, 2012 9:37 pm
Windows Version: XP
Avant Version: 2012 build8
IE Version: 8

Re: HELP!!! I lost all my bookmarks!

Post by gadi_sam » Tue Mar 19, 2013 11:59 am

Thanks, I will try to do that today or tomorrow and let you know.

mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: 10
Avant Version: 2015 Ultimate Build 28
Default engine: Gecko (Firefox)
IE Version: 10
Skin: Monai XP
Location: Grass Valley, CA

Re: HELP!!! I lost all my bookmarks!

Post by mbrazil » Tue Mar 19, 2013 7:56 pm

Before you do the uninstall, find the folder that the older bookmarks.dat file is in (the original of the one you copied), and copy the entire Avant Profiles folder it is under to a flash drive or an external hard drive that you can disconnect from the computer. This way, you have a backup that cannot be lost during the uninstall.

gadi_sam
Newbie
Newbie
Posts: 23
Joined: Sun Apr 22, 2012 9:37 pm
Windows Version: XP
Avant Version: 2012 build8
IE Version: 8

Re: HELP!!! I lost all my bookmarks!

Post by gadi_sam » Wed Mar 20, 2013 10:16 pm

I uninstalled and reinstalled Avant according to your instructions, still no good.

I'm now more than sure that it's not only bookmarks.dat, there must be something else. And I'll tell you why I think so:

I change something in my bookmarks (add, delete, etc), let's call the current bookmarks structure "1". I verify that the file bookmarks.dat (in the folder C:\Documents and Settings\gadi\Application Data\Avant Profiles\.default\bookmarks) is dated March 20, 11:30pm. Then I exit Avant, and copy my OLD bookmarks.dat (dated March 2) to the same folder, so bookmarks.dat of March 20 exists no more. I verify that bookmarks.dat file is now dated March 2. I re-enter Avant, and the bookmarks structure is still structure "1"…..

It looks like Avant is indifferent to the changes I make externally in bookmarks.dat.

mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: 10
Avant Version: 2015 Ultimate Build 28
Default engine: Gecko (Firefox)
IE Version: 10
Skin: Monai XP
Location: Grass Valley, CA

Re: HELP!!! I lost all my bookmarks!

Post by mbrazil » Wed Mar 20, 2013 10:28 pm

gadi_sam wrote:It looks like Avant is indifferent to the changes I make externally in bookmarks.dat.
Is there a bookmarks.dat folder at C:\Documents and Settings\gadi\Application Data\Avant Profiles\gadi\bookmarks ? If so, copy the March 2 bookmarks.dat to that bookmarks folder instead of the one at C:\Documents and Settings\gadi\Application Data\Avant Profiles\.default\bookmarks

gadi_sam
Newbie
Newbie
Posts: 23
Joined: Sun Apr 22, 2012 9:37 pm
Windows Version: XP
Avant Version: 2012 build8
IE Version: 8

Re: HELP!!! I lost all my bookmarks!

Post by gadi_sam » Wed Mar 20, 2013 10:56 pm

No, there isn't such folder, please see the attached jpg with the file structure
Attachments
avant.jpg
avant.jpg (25.71 KiB) Viewed 6565 times

User avatar
Nederpietos
Semi-Avantic
Semi-Avantic
Posts: 506
Joined: Sun Jan 25, 2004 5:25 pm
Windows Version: 10 pro
Avant Version: 2018 build 7 ult
Default engine: Firefox
IE Version: IE11
Skin: stickers on blue

Re: HELP!!! I lost all my bookmarks!

Post by Nederpietos » Thu Mar 21, 2013 1:05 am

Name the bookmarks bookmarks.dat.bak and then copy your "old" bookmarks.dat to that default folder. Or did you already try this?

gadi_sam
Newbie
Newbie
Posts: 23
Joined: Sun Apr 22, 2012 9:37 pm
Windows Version: XP
Avant Version: 2012 build8
IE Version: 8

Re: HELP!!! I lost all my bookmarks!

Post by gadi_sam » Thu Mar 21, 2013 4:15 pm

Already done that, of course.

bigC
AvantGuard
AvantGuard
Posts: 7244
Joined: Thu Jan 30, 2003 10:40 pm
Windows Version: 10
Avant Version: 2016 Build 1
Default engine: Firefox
IE Version: 11
Skin: Crystal
Location: New York

Re: HELP!!! I lost all my bookmarks!

Post by bigC » Thu Mar 21, 2013 7:06 pm

Try deleting all files in C:\Documents and Settings\gadi\Application Data\Avant Profiles\.default\bookmarks then copy your OLD bookmarks.dat (dated March 2) to that folder, so bookmarks.dat is the only file there.

mbrazil
AvantGuard
AvantGuard
Posts: 1966
Joined: Tue Jul 26, 2005 10:04 pm
Windows Version: 10
Avant Version: 2015 Ultimate Build 28
Default engine: Gecko (Firefox)
IE Version: 10
Skin: Monai XP
Location: Grass Valley, CA

Re: HELP!!! I lost all my bookmarks!

Post by mbrazil » Thu Mar 21, 2013 9:02 pm

I'm running out of ideas, here. This shouldn't happen unless something is left behind after the uninstall. Either there is more than one Avant Profiles folder on your system, or something is restoring the empty bookmarks.dat after you've copied the older file. Have you checked the date stamp and file size of the bookmarks.dat files before and after copying?

Let's give this one more try with a slightly different approach.

1. Use Windows System Restore to take your system back to a date prior to losing your bookmarks.
2. Search for and locate all instances of bookmarks.dat.
3. If you find more than one, compare the dates and file sizes to determine which one(s) contain the largest set of bookmarks.
The larger the file, the more bookmarks it contains. For example, my current bookmarks.dat is 52 KB, but a freshly created bookmarks.dat (right after installing Avant) is only 1 KB.
3. Copy the entire Avant Profiles folder that contains the file you selected to an external drive, and then disconnect the external drive.
4. Use Revo in its Advanced mode to uninstall Avant.
5. Search your hard drive(s) for all instances of bookmarks.dat, and delete the entire folder branch it's contained in. If there's more than one Avant Profiles folder anywhere on the drives, delete them all.
6. Reboot the computer, and search again for bookmarks.dat. There shouldn't be any, but if there are, repeat step 5, and reboot again.
7. Install Avant, but don't start it yet.
8. Search again for bookmarks.dat. There should be one instance in the \Avant Profiles\.default\bookmarks\ folder.
9. Connect the external drive, and copy bookmarks.dat and bookmarks.dat.vdt from the external drive to the \Avant Profiles\.default\bookmarks\ folder.
10. Start Avant and check to see if your bookmarks are back. If they're not, you must be in another universe with different laws of physics. :)

Your profile says you're running Avant 2012 build 8. Is that correct? You should really consider updating to Avant 2012 build 197 or Avant 2013. Is there any reason you are still using such an outdated version?

Post Reply